Bug 1294272 - Graphical corruption under wayland
Summary: Graphical corruption under wayland
Status: CLOSED DUPLICATE of bug 1255007
Alias: None
Product: Fedora
Classification: Fedora
Component: eclipse
Version: 23
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Alexander Kurtakov
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-12-26 09:33 UTC by drago01
Modified: 2015-12-28 23:32 UTC (History)
8 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2015-12-28 23:32:50 UTC


Attachments (Terms of Use)

Description drago01 2015-12-26 09:33:17 UTC
Description of problem:

Eclipse is not really usable on wayland due to drawing errors everywhere.

Version-Release number of selected component (if applicable):

4.5.1-6.fc23.x86_64

How reproducible:

Always

Steps to Reproduce:
1. Log into a wayland session
2. Start eclipse
3. See corruption

Actual results:

Missdrawings and corruption everywhere.

Expected results:

Should work and behave like under X11.

Additional info:

It works fine when started with "GDK_BACKEND=x11 eclipse" (in that case it runs under XWayland) ... that might be a good short term workaround but ideally it should be made to work nativly.

Comment 1 Mat Booth 2015-12-26 20:04:18 UTC
You have not supplied any screenshots, do you see the same errors as shown in bug 1255007 ?

Comment 2 drago01 2015-12-26 20:16:34 UTC
I didn't include any screenshots because it was so obviously broken that I didn't think it would be necessary. But yes seems to be the same as in the linked bug.

Comment 3 Mat Booth 2015-12-28 23:32:50 UTC
Great, thanks.

*** This bug has been marked as a duplicate of bug 1255007 ***


Note You need to log in before you can comment on or make changes to this bug.