Bug 1294305 - Unicode Encode Error on dnf info for adobe OpenType Pan-CJK font package
Unicode Encode Error on dnf info for adobe OpenType Pan-CJK font package
Status: CLOSED DUPLICATE of bug 1295090
Product: Fedora
Classification: Fedora
Component: dnf (Show other bugs)
23
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: packaging-team-maint
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-26 12:43 EST by Peter Jennings
Modified: 2016-01-04 08:07 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-01-04 08:07:33 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Python3 exception stack trace (1.44 KB, text/plain)
2015-12-26 12:43 EST, Peter Jennings
no flags Details

  None (edit)
Description Peter Jennings 2015-12-26 12:43:35 EST
Created attachment 1109690 [details]
Python3 exception stack trace

Description of problem: dnf info throws an exception when it attempts to provide the "Description :" for adobe-source-han-sans-cn-fonts (Adobe OpenType Pan-CJK font family for Simplified Chinese) package


Version-Release number of selected component (if applicable): 
dnf --version
1.1.5
  Installed: dnf-0:1.1.5-1.fc23.noarch at 2015-12-23 02:38
  Built    : Fedora Project at 2015-12-18 17:24

  Installed: rpm-0:4.13.0-0.rc1.7.fc23.x86_64 at 2015-11-23 23:02
  Built    : Fedora Project at 2015-11-20 13:08



How reproducible: always 


Steps to Reproduce:
1. install adobe-source-han-sans-cn-fonts
2. dnf info
3.

Actual results:
Python exception

UnicodeEncodeError: 'latin-1' codec can't encode character '\u2014' in position 112: ordinal not in range(256)

Expected results:
Description of package


Additional info:
This error occurred with zh_CN Language Pack installed and also with python3-dnf-langpacks installed
Comment 1 Jaroslav Mracek 2016-01-04 08:07:33 EST

*** This bug has been marked as a duplicate of bug 1295090 ***

Note You need to log in before you can comment on or make changes to this bug.