This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1294349 - pre starting vms in pool fail with stateless snapshot stuck in locked state
pre starting vms in pool fail with stateless snapshot stuck in locked state
Status: CLOSED DUPLICATE of bug 1294350
Product: ovirt-engine
Classification: oVirt
Component: BLL.Virt (Show other bugs)
3.6.2
Unspecified Unspecified
medium Severity high (vote)
: ---
: ---
Assigned To: Michal Skrivanek
Ilanit Stein
: Automation
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-27 07:27 EST by sefi litmanovich
Modified: 2016-02-04 10:27 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-04 10:27:21 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Virt
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
rule-engine: planning_ack?
rule-engine: devel_ack?
rule-engine: testing_ack?


Attachments (Terms of Use)
engine log (171.77 KB, application/x-gzip)
2015-12-27 07:27 EST, sefi litmanovich
no flags Details

  None (edit)
Description sefi litmanovich 2015-12-27 07:27:11 EST
Created attachment 1109802 [details]
engine log

Description of problem:

After creating vm pool with X vms I edit the pool and define e.g. 2 prestarted vms.
after the defined VmPoolMonitorIntervalInMinutes (this happened with values set to 1) engine attempts to start 2 vms from the pool but fails leaving the 2 vms down with 'stateless snapshot' stuck in locked state.
After another VmPoolMonitorIntervalInMinutes engine attempts to start 2 new vms and same thing happens until pool has run out of vms.

The same thing happens when trying to start a stateless vm.

Version-Release number of selected component (if applicable):
rhevm-3.6.2-0.1.el6.noarch

How reproducible:
always

Steps to Reproduce:
1. Create vm pool with some vms lets say 3.
2. Edit pool and set prestarted vms to x <=3.


Actual results:

after VmPoolMonitorIntervalInMinutes vm are trying to start but fail leaving the stateless snapshot locked.

Expected results:

prestarted vms start successfully with a working stateless snapshot.

Additional info:

might be due to the fix for the following bz: 
https://bugzilla.redhat.com/show_bug.cgi?id=1287771
Comment 1 Michal Skrivanek 2016-01-29 07:59:19 EST
(In reply to sefi litmanovich from comment #0)

> might be due to the fix for the following bz: 
> https://bugzilla.redhat.com/show_bug.cgi?id=1287771

so was your test on cinder volume? if so can you retest now, since that bug is fixed by now?
Comment 2 sefi litmanovich 2016-02-04 10:27:21 EST
I'm sorry for some reason I accidentally created this bug twice.
The "original" is fixed: https://bugzilla.redhat.com/show_bug.cgi?id=1294350

*** This bug has been marked as a duplicate of bug 1294350 ***

Note You need to log in before you can comment on or make changes to this bug.