Bug 1294350 - pre starting vms in pool fail with stateless snapshot stuck in locked state
pre starting vms in pool fail with stateless snapshot stuck in locked state
Status: CLOSED CURRENTRELEASE
Product: ovirt-engine
Classification: oVirt
Component: BLL.Virt (Show other bugs)
3.6.2
Unspecified Unspecified
unspecified Severity high (vote)
: ovirt-3.6.3
: 3.6.3
Assigned To: Michal Skrivanek
sefi litmanovich
: Regression
: 1294349 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-27 07:28 EST by sefi litmanovich
Modified: 2016-05-24 12:13 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-18 06:05:33 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Virt
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
rule-engine: ovirt‑3.6.z+
rule-engine: blocker+
rule-engine: planning_ack+
rule-engine: devel_ack+
mavital: testing_ack+


Attachments (Terms of Use)

  None (edit)
Description sefi litmanovich 2015-12-27 07:28:03 EST
Description of problem:

After creating vm pool with X vms I edit the pool and define e.g. 2 prestarted vms.
after the defined VmPoolMonitorIntervalInMinutes (this happened with values set to 1) engine attempts to start 2 vms from the pool but fails leaving the 2 vms down with 'stateless snapshot' stuck in locked state.
After another VmPoolMonitorIntervalInMinutes engine attempts to start 2 new vms and same thing happens until pool has run out of vms.

The same thing happens when trying to start a stateless vm.

Version-Release number of selected component (if applicable):
rhevm-3.6.2-0.1.el6.noarch

How reproducible:
always

Steps to Reproduce:
1. Create vm pool with some vms lets say 3.
2. Edit pool and set prestarted vms to x <=3.


Actual results:

after VmPoolMonitorIntervalInMinutes vm are trying to start but fail leaving the stateless snapshot locked.

Expected results:

prestarted vms start successfully with a working stateless snapshot.

Additional info:

might be due to the fix for the following bz: 
https://bugzilla.redhat.com/show_bug.cgi?id=1287771
Comment 2 Red Hat Bugzilla Rules Engine 2015-12-27 08:44:32 EST
Fixed bug tickets must have version flags set prior to fixing them. Please set the correct version flags and move the bugs back to the previous status after this is corrected.
Comment 3 Red Hat Bugzilla Rules Engine 2016-01-03 04:58:48 EST
This bug report has Keywords: Regression or TestBlocker.
Since no regressions or test blockers are allowed between releases, it is also being identified as a blocker for this release. Please resolve ASAP.
Comment 4 Red Hat Bugzilla Rules Engine 2016-01-28 07:16:00 EST
Bug tickets that are moved to testing must have target release set to make sure tester knows what to test. Please set the correct target release before moving to ON_QA.
Comment 5 Red Hat Bugzilla Rules Engine 2016-01-28 07:24:51 EST
Bug tickets that are moved to testing must have target release set to make sure tester knows what to test. Please set the correct target release before moving to ON_QA.
Comment 6 Red Hat Bugzilla Rules Engine 2016-01-28 07:28:58 EST
Bug tickets that are moved to testing must have target release set to make sure tester knows what to test. Please set the correct target release before moving to ON_QA.
Comment 7 Michal Skrivanek 2016-01-28 09:48:26 EST
I wonder whether you find entries since comment #2 onwards useful. 
I find it confusing, useless and a waste of time for anyone who has to deal with this bug.
Please disable the bot, and set up whines instead.
Comment 8 sefi litmanovich 2016-01-28 11:34:51 EST
Verified with rhevm-3.6.3-0.1.el6.noarch.

checked both stateless vm and prestarted pool vms (which is the same), snapshot created successfully and delted when shutting vm down as expected.
Comment 9 Yaniv Lavi 2016-01-28 15:28:32 EST
(In reply to Michal Skrivanek from comment #7)
> I wonder whether you find entries since comment #2 onwards useful. 
> I find it confusing, useless and a waste of time for anyone who has to deal
> with this bug.
> Please disable the bot, and set up whines instead.

The person doing the build need to set target release. you can CI to not move bugs unless they have target release.
Comment 10 sefi litmanovich 2016-02-04 10:27:21 EST
*** Bug 1294349 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.