Bug 1294361 - Can't upgrade rhevm-3.6.1.3-0.1.el6->rhev-release-3.6.2-2-001.noarch (due to rhevm-reports)
Can't upgrade rhevm-3.6.1.3-0.1.el6->rhev-release-3.6.2-2-001.noarch (due to ...
Status: CLOSED WORKSFORME
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: rhevm-setup-plugins (Show other bugs)
3.6.2
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Sandro Bonazzola
Pavel Stehlik
integration
:
Depends On: 1290528 1295178
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-27 11:38 EST by Nikolai Sednev
Modified: 2017-01-17 04:14 EST (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-01-13 07:42:14 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Integration
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
engine's sosreport (17.97 MB, application/x-xz)
2015-12-27 11:47 EST, Nikolai Sednev
no flags Details

  None (edit)
Description Nikolai Sednev 2015-12-27 11:38:43 EST
Description of problem:
engine-setup fails because of the:
Error: Package: rhevm-reports-3.5.5-2.el6ev.noarch (@qa-latest)
           Requires: jasperreports-server-pro < 5.6.0
           Removing: jasperreports-server-pro-5.5.0-10.el6ev.noarch (@qa-latest)
               jasperreports-server-pro = 5.5.0-10.el6ev
           Updated By: jasperreports-server-pro-6.0.1-1.el6ev.noarch (rhev-3.6.1-7)
               jasperreports-server-pro = 6.0.1-1.el6ev
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest
[root@Upgrade_setup ~]# engine-setup
[ INFO  ] Stage: Initializing
[ INFO  ] Stage: Environment setup
          Configuration files: ['/etc/ovirt-engine-setup.conf.d/10-packaging-dwh.conf', '/etc/ovirt-engine-setup.conf.d/10-packaging-wsp.conf', '/etc/ovirt-engine-setup.conf.d/10-packaging.conf', '/etc/ovirt-engine-setup.conf.d/20-packaging-rhevm-reports.conf', '/etc/ovirt-engine-setup.conf.d/20-setup-ovirt-post.conf']
          Log file: /var/log/ovirt-engine/setup/ovirt-engine-setup-20151227183209-5ip1st.log
          Version: otopi-1.4.0 (otopi-1.4.0-1.el6ev)
[ INFO  ] Stage: Environment packages setup
[ INFO  ] Stage: Programs detection
[ INFO  ] Stage: Environment setup
[ INFO  ] Stage: Environment customization
         
          Welcome to the RHEV 3.6 setup/upgrade.
          Please read the RHEV 3.6 install guide
          https://access.redhat.com/site/documentation/en-US/Red_Hat_Enterprise_Virtualization/3.6/html/Installation_Guide/index.html.
          Please refer to the RHEV Upgrade Helper application
          https://access.redhat.com/labs/rhevupgradehelper/ which will guide you in the upgrading process.
          Would you like to proceed? (Yes, No) [Yes]: 
         
          --== PRODUCT OPTIONS ==--
         
          Configure VM Console Proxy on this host (Yes, No) [Yes]: 
         
          --== PACKAGES ==--
         
[ INFO  ] Checking for product updates...
          Setup has found updates for some packages:
          PACKAGE: [install] ovirt-setup-lib-1.0.1-1.el6ev.noarch
          PACKAGE: [updated] rhevm-3.6.1.3-0.1.el6.noarch
          PACKAGE: [update] rhevm-3.6.2-0.1.el6.noarch
          PACKAGE: [updated] rhevm-backend-3.6.1.3-0.1.el6.noarch
          PACKAGE: [update] rhevm-backend-3.6.2-0.1.el6.noarch
          PACKAGE: [updated] rhevm-dbscripts-3.6.1.3-0.1.el6.noarch
          PACKAGE: [update] rhevm-dbscripts-3.6.2-0.1.el6.noarch
          PACKAGE: [updated] rhevm-dwh-3.6.1-1.el6ev.noarch
          PACKAGE: [update] rhevm-dwh-3.6.2-1.el6ev.noarch
          PACKAGE: [updated] rhevm-dwh-setup-3.6.1-1.el6ev.noarch
          PACKAGE: [update] rhevm-dwh-setup-3.6.2-1.el6ev.noarch
          PACKAGE: [updated] rhevm-extensions-api-impl-3.6.1.3-0.1.el6.noarch
          PACKAGE: [update] rhevm-extensions-api-impl-3.6.2-0.1.el6.noarch
          PACKAGE: [updated] rhevm-lib-3.6.1.3-0.1.el6.noarch
          PACKAGE: [update] rhevm-lib-3.6.2-0.1.el6.noarch
          PACKAGE: [updated] rhevm-restapi-3.6.1.3-0.1.el6.noarch
          PACKAGE: [update] rhevm-restapi-3.6.2-0.1.el6.noarch
          PACKAGE: [updated] rhevm-setup-3.6.1.3-0.1.el6.noarch
          PACKAGE: [update] rhevm-setup-3.6.2-0.1.el6.noarch
          PACKAGE: [updated] rhevm-setup-base-3.6.1.3-0.1.el6.noarch
          PACKAGE: [update] rhevm-setup-base-3.6.2-0.1.el6.noarch
          PACKAGE: [updated] rhevm-setup-plugin-ovirt-engine-3.6.1.3-0.1.el6.noarch
          PACKAGE: [update] rhevm-setup-plugin-ovirt-engine-3.6.2-0.1.el6.noarch
          PACKAGE: [updated] rhevm-setup-plugin-ovirt-engine-common-3.6.1.3-0.1.el6.noarch
          PACKAGE: [update] rhevm-setup-plugin-ovirt-engine-common-3.6.2-0.1.el6.noarch
          PACKAGE: [updated] rhevm-setup-plugin-vmconsole-proxy-helper-3.6.1.3-0.1.el6.noarch
          PACKAGE: [update] rhevm-setup-plugin-vmconsole-proxy-helper-3.6.2-0.1.el6.noarch
          PACKAGE: [updated] rhevm-setup-plugin-websocket-proxy-3.6.1.3-0.1.el6.noarch
          PACKAGE: [update] rhevm-setup-plugin-websocket-proxy-3.6.2-0.1.el6.noarch
          PACKAGE: [updated] rhevm-tools-3.6.1.3-0.1.el6.noarch
          PACKAGE: [update] rhevm-tools-3.6.2-0.1.el6.noarch
          PACKAGE: [updated] rhevm-userportal-3.6.1.3-0.1.el6.noarch
          PACKAGE: [update] rhevm-userportal-3.6.2-0.1.el6.noarch
          PACKAGE: [updated] rhevm-vmconsole-proxy-helper-3.6.1.3-0.1.el6.noarch
          PACKAGE: [update] rhevm-vmconsole-proxy-helper-3.6.2-0.1.el6.noarch
          PACKAGE: [updated] rhevm-webadmin-portal-3.6.1.3-0.1.el6.noarch
          PACKAGE: [update] rhevm-webadmin-portal-3.6.2-0.1.el6.noarch
          PACKAGE: [updated] rhevm-websocket-proxy-3.6.1.3-0.1.el6.noarch
          PACKAGE: [update] rhevm-websocket-proxy-3.6.2-0.1.el6.noarch
          do you wish to update them now? (Yes, No) [Yes]: 
[ INFO  ] Checking for an update for Setup...
          An update for the Setup packages rhevm-setup rhevm-dwh-setup rhevm-setup-plugin-websocket-proxy was found. Please update that package by running:
          "yum update rhevm-setup rhevm-dwh-setup rhevm-setup-plugin-websocket-proxy"
          and then execute Setup again.
[ ERROR ] Failed to execute stage 'Environment customization': Please update the Setup packages
[ INFO  ] Stage: Clean up
          Log file is located at /var/log/ovirt-engine/setup/ovirt-engine-setup-20151227183209-5ip1st.log
[ INFO  ] Generating answer file '/var/lib/ovirt-engine/setup/answers/20151227183253-setup.conf'
[ INFO  ] Stage: Pre-termination
[ INFO  ] Stage: Termination
[ ERROR ] Execution of setup failed
[root@Upgrade_setup ~]# 



Version-Release number of selected component (if applicable):
rhevm-3.6.1.3-0.1.el6.noarch
ovirt-host-deploy-java-1.4.1-1.el6ev.noarch
ovirt-vmconsole-proxy-1.0.0-1.el6ev.noarch
ovirt-engine-extension-aaa-jdbc-1.0.4-1.el6ev.noarch
ovirt-vmconsole-1.0.0-1.el6ev.noarch
ovirt-host-deploy-1.4.1-1.el6ev.noarch
rhevm-reports-3.5.5-2.el6ev.noarch
jasperreports-server-pro-5.5.0-10.el6ev.noarch



How reproducible:
100%

Steps to Reproduce:
1.Have the engine upgraded from 3.5 to 3.6.1.3-0.1 with DWH reports components installed.
2.Try upgrading from 3.6.1.3-0.1->3.6.2-2-001.
3.

Actual results:
--> Finished Dependency Resolution
Error: Package: rhevm-reports-3.5.5-2.el6ev.noarch (@qa-latest)
           Requires: jasperreports-server-pro < 5.6.0
           Removing: jasperreports-server-pro-5.5.0-10.el6ev.noarch (@qa-latest)
               jasperreports-server-pro = 5.5.0-10.el6ev
           Updated By: jasperreports-server-pro-6.0.1-1.el6ev.noarch (rhev-3.6.1-7)
               jasperreports-server-pro = 6.0.1-1.el6ev
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest


[ ERROR ] Failed to execute stage 'Environment customization': Please update the Setup packages
[ INFO  ] Stage: Clean up
          Log file is located at /var/log/ovirt-engine/setup/ovirt-engine-setup-20151227183209-5ip1st.log
[ INFO  ] Generating answer file '/var/lib/ovirt-engine/setup/answers/20151227183253-setup.conf'
[ INFO  ] Stage: Pre-termination
[ INFO  ] Stage: Termination
[ ERROR ] Execution of setup failed


Expected results:

Reports package should be updated successfully along with the engine.
Additional info:
logs attached.
Comment 1 Nikolai Sednev 2015-12-27 11:47 EST
Created attachment 1109837 [details]
engine's sosreport
Comment 2 Yedidyah Bar David 2015-12-30 09:12:56 EST
(In reply to Nikolai Sednev from comment #0)
> Description of problem:
> engine-setup fails because of the:
> Error: Package: rhevm-reports-3.5.5-2.el6ev.noarch (@qa-latest)
>            Requires: jasperreports-server-pro < 5.6.0
>            Removing: jasperreports-server-pro-5.5.0-10.el6ev.noarch
> (@qa-latest)
>                jasperreports-server-pro = 5.5.0-10.el6ev
>            Updated By: jasperreports-server-pro-6.0.1-1.el6ev.noarch
> (rhev-3.6.1-7)
>                jasperreports-server-pro = 6.0.1-1.el6ev
>  You could try using --skip-broken to work around the problem
>  You could try running: rpm -Va --nofiles --nodigest

This is the output of yum right? Not of engine-setup.

> Steps to Reproduce:
> 1.Have the engine upgraded from 3.5 to 3.6.1.3-0.1 with DWH reports
> components installed.
> 2.Try upgrading from 3.6.1.3-0.1->3.6.2-2-001.

Please provide more details.

Seems similar to bug 1289660, but you do not seem to have upgraded jasper.
Comment 3 Nikolai Sednev 2015-12-30 09:59:51 EST
(In reply to Yedidyah Bar David from comment #2)
> (In reply to Nikolai Sednev from comment #0)
> > Description of problem:
> > engine-setup fails because of the:
> > Error: Package: rhevm-reports-3.5.5-2.el6ev.noarch (@qa-latest)
> >            Requires: jasperreports-server-pro < 5.6.0
> >            Removing: jasperreports-server-pro-5.5.0-10.el6ev.noarch
> > (@qa-latest)
> >                jasperreports-server-pro = 5.5.0-10.el6ev
> >            Updated By: jasperreports-server-pro-6.0.1-1.el6ev.noarch
> > (rhev-3.6.1-7)
> >                jasperreports-server-pro = 6.0.1-1.el6ev
> >  You could try using --skip-broken to work around the problem
> >  You could try running: rpm -Va --nofiles --nodigest
> 
> This is the output of yum right? Not of engine-setup.
> 
> > Steps to Reproduce:
> > 1.Have the engine upgraded from 3.5 to 3.6.1.3-0.1 with DWH reports
> > components installed.
> > 2.Try upgrading from 3.6.1.3-0.1->3.6.2-2-001.
> 
> Please provide more details.
> 
> Seems similar to bug 1289660, but you do not seem to have upgraded jasper.

It was initially yum update rhevm -y, then yum update -y, then tried also yum update jasperreports, not worked for me in either way. Then after the update failed, also engine-setup failed.


It's not the same as 1290518, because I was already after 3.5->3.6, I've tried to 3.6->3.6(with newer components on board).
Comment 4 Nikolai Sednev 2015-12-30 10:01:19 EST
See also attached sosreport at the top of the bug.
Comment 5 Nikolai Sednev 2015-12-30 10:08:03 EST
Updated:
  rhev-release-3.6.2.noarch 0:3-001                                                                                                               

Complete!

yum update -y
Loaded plugins: product-id, security, subscription-manager, versionlock
This system is not registered to Red Hat Subscription Management. You can use subscription-manager to register.
Repository jboss-eap-6.4.Z is listed more than once in the configuration
Repository jboss-eap-6.4.Z is listed more than once in the configuration
Setting up Update Process
jboss-eap-6.4.Z                                                                                                            | 3.8 kB     00:00     
jboss-eap-6.4.Z/primary_db                                                                                                 |  95 kB     00:00     
rhel-6                                                                                                                     | 4.1 kB     00:00     
rhel-6/primary_db                                                                                                          | 3.1 MB     00:00     
rhel-67-optional                                                                                                           | 3.8 kB     00:00     
rhel-67-optional/primary_db                                                                                                | 1.2 MB     00:00     
rhel-67-suppl                                                                                                              | 4.1 kB     00:00     
rhel-67-suppl/primary_db                                                                                                   |  36 kB     00:00     
rhel-67-zstream                                                                                                            | 2.6 kB     00:00     
rhel-67-zstream/primary_db                                                                                                 | 3.8 MB     00:02     
rhev-3.6.1-7                                                                                                               | 2.9 kB     00:00     
rhev-3.6.1-7/primary_db                                                                                                    |  42 kB     00:00     
rhev-3.6.2-3                                                                                                               | 2.9 kB     00:00     
rhev-3.6.2-3/primary_db                                                                                                    |  43 kB     00:00     
Resolving Dependencies
--> Running transaction check
---> Package jasperreports-server-pro.noarch 0:5.5.0-10.el6ev will be updated
--> Processing Dependency: jasperreports-server-pro < 5.6.0 for package: rhevm-reports-3.5.5-2.el6ev.noarch
---> Package jasperreports-server-pro.noarch 0:6.0.1-1.el6ev will be an update
---> Package novnc.noarch 0:0.4-8.1.el6 will be updated
---> Package novnc.noarch 0:0.5.1-2.el6 will be an update
---> Package rhev-guest-tools-iso.noarch 0:3.5-11.el6ev will be updated
---> Package rhev-guest-tools-iso.noarch 0:3.6-2.el6ev will be an update
---> Package rhev-hypervisor7.noarch 0:7.2-20151221.1.el6ev will be installed
---> Package rhevm-dwh-setup.noarch 0:3.6.1-1.el6ev will be updated
---> Package rhevm-dwh-setup.noarch 0:3.6.2-1.el6ev will be an update
---> Package rhevm-extensions-api-impl.noarch 0:3.6.1.3-0.1.el6 will be updated
---> Package rhevm-extensions-api-impl.noarch 0:3.6.2-0.1.el6 will be an update
---> Package rhevm-lib.noarch 0:3.6.1.3-0.1.el6 will be updated
---> Package rhevm-lib.noarch 0:3.6.2-0.1.el6 will be an update
---> Package rhevm-sdk-python.noarch 0:3.6.0.3-1.el6ev will be updated
---> Package rhevm-sdk-python.noarch 0:3.6.2.0-1.el6ev will be an update
---> Package rhevm-setup.noarch 0:3.6.1.3-0.1.el6 will be updated
---> Package rhevm-setup.noarch 0:3.6.2-0.1.el6 will be an update
---> Package rhevm-setup-base.noarch 0:3.6.1.3-0.1.el6 will be updated
---> Package rhevm-setup-base.noarch 0:3.6.2-0.1.el6 will be an update
---> Package rhevm-setup-plugin-ovirt-engine.noarch 0:3.6.1.3-0.1.el6 will be updated
---> Package rhevm-setup-plugin-ovirt-engine.noarch 0:3.6.2-0.1.el6 will be an update
---> Package rhevm-setup-plugin-ovirt-engine-common.noarch 0:3.6.1.3-0.1.el6 will be updated
---> Package rhevm-setup-plugin-ovirt-engine-common.noarch 0:3.6.2-0.1.el6 will be an update
--> Processing Dependency: ovirt-setup-lib for package: rhevm-setup-plugin-ovirt-engine-common-3.6.2-0.1.el6.noarch
---> Package rhevm-setup-plugin-vmconsole-proxy-helper.noarch 0:3.6.1.3-0.1.el6 will be updated
---> Package rhevm-setup-plugin-vmconsole-proxy-helper.noarch 0:3.6.2-0.1.el6 will be an update
---> Package rhevm-setup-plugin-websocket-proxy.noarch 0:3.6.1.3-0.1.el6 will be updated
---> Package rhevm-setup-plugin-websocket-proxy.noarch 0:3.6.2-0.1.el6 will be an update
---> Package rhevm-vmconsole-proxy-helper.noarch 0:3.6.1.3-0.1.el6 will be updated
---> Package rhevm-vmconsole-proxy-helper.noarch 0:3.6.2-0.1.el6 will be an update
---> Package rhevm-websocket-proxy.noarch 0:3.6.1.3-0.1.el6 will be updated
---> Package rhevm-websocket-proxy.noarch 0:3.6.2-0.1.el6 will be an update
---> Package spice-html5.noarch 0:0.1.4-1.el6 will be updated
---> Package spice-html5.noarch 0:0.1.6-2.el6 will be an update
--> Running transaction check
---> Package jasperreports-server-pro.noarch 0:5.5.0-10.el6ev will be updated
--> Processing Dependency: jasperreports-server-pro < 5.6.0 for package: rhevm-reports-3.5.5-2.el6ev.noarch
---> Package ovirt-setup-lib.noarch 0:1.0.1-1.el6ev will be installed
--> Finished Dependency Resolution
Error: Package: rhevm-reports-3.5.5-2.el6ev.noarch (@qa-latest)
           Requires: jasperreports-server-pro < 5.6.0
           Removing: jasperreports-server-pro-5.5.0-10.el6ev.noarch (@qa-latest)
               jasperreports-server-pro = 5.5.0-10.el6ev
           Updated By: jasperreports-server-pro-6.0.1-1.el6ev.noarch (rhev-3.6.1-7)
               jasperreports-server-pro = 6.0.1-1.el6ev
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest

# yum update -y jasper*
Loaded plugins: product-id, security, subscription-manager, versionlock
This system is not registered to Red Hat Subscription Management. You can use subscription-manager to register.
Repository jboss-eap-6.4.Z is listed more than once in the configuration
Repository jboss-eap-6.4.Z is listed more than once in the configuration
Setting up Update Process
Resolving Dependencies
--> Running transaction check
---> Package jasperreports-server-pro.noarch 0:5.5.0-10.el6ev will be updated
--> Processing Dependency: jasperreports-server-pro < 5.6.0 for package: rhevm-reports-3.5.5-2.el6ev.noarch
---> Package jasperreports-server-pro.noarch 0:6.0.1-1.el6ev will be an update
--> Finished Dependency Resolution
Error: Package: rhevm-reports-3.5.5-2.el6ev.noarch (@qa-latest)
           Requires: jasperreports-server-pro < 5.6.0
           Removing: jasperreports-server-pro-5.5.0-10.el6ev.noarch (@qa-latest)
               jasperreports-server-pro = 5.5.0-10.el6ev
           Updated By: jasperreports-server-pro-6.0.1-1.el6ev.noarch (rhev-3.6.1-7)
               jasperreports-server-pro = 6.0.1-1.el6ev
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest
Comment 6 Yedidyah Bar David 2016-01-03 04:45:57 EST
Seems like the flow is:

1. Install 3.5 engine+dwh+reports

2. run engine-setup, choose to not configure reports

rhevm-reports is versionlocked anyway, due to the change done for bug 1098191.

A possible workaround:

yum remove rhevm-reports

Changing product and component.

The bug probably affects 3.4 and later.
Comment 7 Yedidyah Bar David 2016-01-03 04:51:19 EST
Lowering severity, as it seems like there is a workaround and the flow is not very common.
Comment 8 Nikolai Sednev 2016-01-03 05:05:37 EST
I'm hitting the https://bugzilla.redhat.com/show_bug.cgi?id=1295178, during WA.
Comment 9 Nikolai Sednev 2016-01-03 06:03:27 EST
Might be also connected to https://bugzilla.redhat.com/show_bug.cgi?id=1072360
Comment 10 Nikolai Sednev 2016-01-05 04:22:59 EST
(In reply to Yedidyah Bar David from comment #7)
> Lowering severity, as it seems like there is a workaround and the flow is
> not very common.

There is currently no WA available, should priority still remain the same?
Comment 11 Yedidyah Bar David 2016-01-05 05:15:10 EST
bug 1295178 is not a blocker and unrelated.

If you hit it, try again on a new clean system without on-going tasks. That said, I pushed a patch for it, you might want to try it. I intend to do that myself, but am stuck due to bug 1293135 :-( (but would still not call it a blocker).

I also still think it's not very common.
Comment 12 Nikolai Sednev 2016-01-12 07:38:29 EST
(In reply to Yedidyah Bar David from comment #11)
> bug 1295178 is not a blocker and unrelated.
> 
> If you hit it, try again on a new clean system without on-going tasks. That
> said, I pushed a patch for it, you might want to try it. I intend to do that
> myself, but am stuck due to bug 1293135 :-( (but would still not call it a
> blocker).
> 
> I also still think it's not very common.

Worked for me eventually, after powering ON/OFF the engine's VM and migrating it to less memory loaded host. Upgraded 3.6.1.3-0.1->3.6.2-0.1.

The way to do the upgrade was:

1.Removing DWH reports from the engine.
2.Updating the engine-setup.
3.Updating the whole components on OS.
4.Installing back the DWH component.
5.Powering OFF the VM.
6.Starting the engine's VM on less loaded host.
7.Running engine-setup.
Comment 13 Yedidyah Bar David 2016-01-13 08:07:58 EST
Not sure it should be closed, it might be quite easy to add a condition in rhevm-setup-plugins and versionlock dwh/reports only if configured. When doing that we need to also consider partial cleanup (which is buggy), manually removing dwh/reports rpms (which we suggest to do as part of migrating them to another machine) etc.

Also we might consider removing this hack from there altogether. I thought we'll be able to do this in 3.5, but then had another case and left it in, if you remember. And removing means to carefully create a list of all relevant flows to test and see that are not badly affected.

Setting needinfo on Sandro to review.

Note You need to log in before you can comment on or make changes to this bug.