Bug 1294416 - heat missing modules - mistralclient, magnumclient and designateclient.
heat missing modules - mistralclient, magnumclient and designateclient.
Status: CLOSED DUPLICATE of bug 1294489
Product: Red Hat OpenStack
Classification: Red Hat
Component: rhosp-director (Show other bugs)
8.0 (Liberty)
Unspecified Unspecified
unspecified Severity high
: ga
: 8.0 (Liberty)
Assigned To: chris alfonso
yeylon@redhat.com
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-28 02:03 EST by bkopilov
Modified: 2016-04-18 03:12 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-01-07 12:41:52 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
heat-engine logs (5.57 KB, application/x-gzip)
2015-12-28 02:16 EST, bkopilov
no flags Details

  None (edit)
Description bkopilov 2015-12-28 02:03:31 EST
Description of problem:
Installing director on rhel7.2  / rhos8 latests.
Heat logs show import error for these packages : 


2015-12-24 14:52:52.716 10674 ERROR stevedore.extension ImportError: No module named mistralclient.api
2015-12-24 14:52:52.823 10674 ERROR stevedore.extension ImportError: No module named manilaclient
2015-12-24 14:52:52.835 10674 ERROR stevedore.extension ImportError: No module named magnumclient.openstack.common.apiclient
2015-12-24 14:52:53.269 10674 ERROR stevedore.extension ImportError: No module named designateclient
2015-12-24 14:52:53.287 10674 ERROR stevedore.extension ImportError: No module named designateclient
2015-12-24 14:52:53.304 10674 ERROR stevedore.extension ImportError: No module named manilaclient
2015-12-24 14:52:53.306 10674 ERROR stevedore.extension ImportError: No module named manilaclient
2015-12-24 14:52:53.308 10674 ERROR stevedore.extension ImportError: No module named manilaclient
2015-12-24 14:56:20.587 23159 ERROR stevedore.extension ImportError: No module named mistralclient.api
2015-12-24 14:56:20.605 23159 ERROR stevedore.extension ImportError: No module named manilaclient
2015-12-24 14:56:20.607 23159 ERROR stevedore.extension ImportError: No module named magnumclient.openstack.common.apiclient
2015-12-24 14:56:20.781 23159 ERROR stevedore.extension ImportError: No module named designateclient
2015-12-24 14:56:20.803 23159 ERROR stevedore.extension ImportError: No module named designateclient
2015-12-24 14:56:20.808 23159 ERROR stevedore.extension ImportError: No module named manilaclient
2015-12-24 14:56:20.810 23159 ERROR stevedore.extension ImportError: No module named manilaclient
2015-12-24 14:56:20.811 23159 ERROR stevedore.extension ImportError: No module named manilaclient

Version-Release number of selected component (if applicable):

Probably packaging issues ,

Benny

How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Attaching log file from heat.
Comment 2 bkopilov 2015-12-28 02:16 EST
Created attachment 1109962 [details]
heat-engine logs

heat-engine logs
Comment 3 Zane Bitter 2016-01-07 12:41:52 EST

*** This bug has been marked as a duplicate of bug 1294489 ***

Note You need to log in before you can comment on or make changes to this bug.