Bug 1294489 - ImportError for mistralclient, magnumclient and designateclient
ImportError for mistralclient, magnumclient and designateclient
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-heat (Show other bugs)
8.0 (Liberty)
Unspecified Unspecified
unspecified Severity high
: ga
: 8.0 (Liberty)
Assigned To: Crag Wolfe
Amit Ugol
:
: 1294416 1294490 1294494 1294496 1294504 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-28 07:38 EST by Ronnie Rasouli
Modified: 2016-04-26 19:22 EDT (History)
9 users (show)

See Also:
Fixed In Version: openstack-heat-5.0.1-1.el7ost
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-04-07 17:16:42 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ronnie Rasouli 2015-12-28 07:38:07 EST
Description of problem:

Post deployment failed in heat-* logs found errors.
2015-12-28 03:49:26.777 4825 ERROR stevedore.extension [-] Could not load 'manila.share_snapshot': No module named manilaclient
2015-12-28 03:49:26.777 4825 ERROR stevedore.extension [-] No module named manilaclient
2015-12-28 03:49:26.777 4825 ERROR stevedore.extension Traceback (most recent call last):
2015-12-28 03:49:26.777 4825 ERROR stevedore.extension   File "/usr/lib/python2.7/site-packages/stevedore/extension.py", line 162, in _load_plugins
2015-12-28 03:49:26.777 4825 ERROR stevedore.extension     verify_requirements,
2015-12-28 03:49:26.777 4825 ERROR stevedore.extension   File "/usr/lib/python2.7/site-packages/stevedore/extension.py", line 185, in _load_one_plugin
2015-12-28 03:49:26.777 4825 ERROR stevedore.extension     plugin = ep.load(require=verify_requirements)
2015-12-28 03:49:26.777 4825 ERROR stevedore.extension   File "/usr/lib/python2.7/site-packages/pkg_resources.py", line 2260, in load
2015-12-28 03:49:26.777 4825 ERROR stevedore.extension     entry = __import__(self.module_name, globals(),globals(), ['__name__'])
2015-12-28 03:49:26.777 4825 ERROR stevedore.extension   File "/usr/lib/python2.7/site-packages/heat/engine/clients/os/manila.py", line 16, in <module>
2015-12-28 03:49:26.777 4825 ERROR stevedore.extension     from manilaclient import client as manila_client
2015-12-28 03:49:26.777 4825 ERROR stevedore.extension ImportError: No module named manilaclient



Version-Release number of selected component (if applicable):

heat-cfntools-1.2.8-2.el7.noarch
openstack-heat-engine-5.0.0-1.el7ost.noarch
python-heatclient-0.8.0-1.el7ost.noarch
openstack-heat-api-cfn-5.0.0-1.el7ost.noarch
openstack-heat-common-5.0.0-1.el7ost.noarch
openstack-heat-api-cloudwatch-5.0.0-1.el7ost.noarch
openstack-heat-api-5.0.0-1.el7ost.noarch

How reproducible:

100%

Steps to Reproduce:
1. deploy openstack with the command script detailed in
http://file.tlv.redhat.com/~rrasouli/rhos8
2. deployment failed in post deploy status code: 6 
3. login to one of the HA controllers
4. look for errors in heat logs 

Actual results:

post Deployment failed, the error with Manila client appears

Expected results:

Should have no errors of components that hasn't been installed

Additional info:

from heat-engine.api

2015-12-28 03:49:26.530 4825 ERROR stevedore.extension [-] Could not load 'manila': No module named manilaclient
2015-12-28 03:49:26.530 4825 ERROR stevedore.extension [-] No module named manilaclient
2015-12-28 03:49:26.530 4825 ERROR stevedore.extension Traceback (most recent call last):
2015-12-28 03:49:26.530 4825 ERROR stevedore.extension   File "/usr/lib/python2.7/site-packages/stevedore/extension.py", line 162, in _load_plugins
2015-12-28 03:49:26.530 4825 ERROR stevedore.extension     verify_requirements,
2015-12-28 03:49:26.530 4825 ERROR stevedore.extension   File "/usr/lib/python2.7/site-packages/stevedore/enabled.py", line 67, in _load_one_plugin
2015-12-28 03:49:26.530 4825 ERROR stevedore.extension     verify_requirements,
2015-12-28 03:49:26.530 4825 ERROR stevedore.extension   File "/usr/lib/python2.7/site-packages/stevedore/extension.py", line 185, in _load_one_plugin
2015-12-28 03:49:26.530 4825 ERROR stevedore.extension     plugin = ep.load(require=verify_requirements)
2015-12-28 03:49:26.530 4825 ERROR stevedore.extension   File "/usr/lib/python2.7/site-packages/pkg_resources.py", line 2260, in load
2015-12-28 03:49:26.530 4825 ERROR stevedore.extension     entry = __import__(self.module_name, globals(),globals(), ['__name__'])
2015-12-28 03:49:26.530 4825 ERROR stevedore.extension   File "/usr/lib/python2.7/site-packages/heat/engine/clients/os/manila.py", line 16, in <module>
2015-12-28 03:49:26.530 4825 ERROR stevedore.extension     from manilaclient import client as manila_client
2015-12-28 03:49:26.530 4825 ERROR stevedore.extension ImportError: No module named manilaclient
Comment 2 Ronnie Rasouli 2015-12-28 09:52:53 EST
*** Bug 1294490 has been marked as a duplicate of this bug. ***
Comment 3 Zane Bitter 2016-01-04 11:36:07 EST
*** Bug 1294496 has been marked as a duplicate of this bug. ***
Comment 4 Zane Bitter 2016-01-04 11:36:15 EST
*** Bug 1294494 has been marked as a duplicate of this bug. ***
Comment 5 Zane Bitter 2016-01-04 11:36:22 EST
*** Bug 1294504 has been marked as a duplicate of this bug. ***
Comment 6 Zane Bitter 2016-01-04 11:41:34 EST
Thanks Ronnie. I've consolidated all of the bug reports under this one, since they all have the same fix. For completeness, the list of clients that should not be loaded is:

barbican
designate
magnum
manila
mistral
monasca
zaqar

(Some of these use conditional imports, and therefore don't generate errors.)

Of these, manila, designate and monasca define constraints that also need to be excluded.

A patch was already merged, but may not have been built yet.
Comment 7 Zane Bitter 2016-01-07 12:41:52 EST
*** Bug 1294416 has been marked as a duplicate of this bug. ***
Comment 10 Ronnie Rasouli 2016-02-07 07:34:52 EST
Verfied on openstack-heat-api-5.0.1-1.el7ost.noarch, there are not missing modules error in heat logs
Comment 11 Marcus Furlong 2016-02-25 19:48:07 EST
This also affects RDO, should I open a new bug report against RDO?

Also, the upstream bug report is here -> https://bugs.launchpad.net/heat/+bug/1544220
Comment 12 Steve Baker 2016-02-25 20:59:10 EST
Marcus the fix for RHOS was to patch out references to those clients in downstream heat. This isn't an option for RDO due to the no downstream patches policy.

Ideally RDO would fix this by packaging the client libraries which heat expects - do you know which ones are actually missing and whether anyone is working on packaging them?
Comment 13 Marcus Furlong 2016-02-25 21:47:56 EST
The missing packages in RDO are:

No package python-magnumclient available.
No package python-mistralclient available.
No package python-monascaclient available.

They are packaged for Mitaka, but I don't think anyone is working on packaging them for Liberty.
Comment 14 errata-xmlrpc 2016-04-07 17:16:42 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-0603.html

Note You need to log in before you can comment on or make changes to this bug.