Bug 1294453 - [ppc64le] v2v: webadmin uncaught exception occurs when trying to import VM without selecting cluster.
[ppc64le] v2v: webadmin uncaught exception occurs when trying to import VM wi...
Status: CLOSED DUPLICATE of bug 1294451
Product: ovirt-engine
Classification: oVirt
Component: BLL.Virt (Show other bugs)
3.6.1
ppc64le Unspecified
unspecified Severity high (vote)
: ---
: ---
Assigned To: Michal Skrivanek
Nisim Simsolo
virt
:
Depends On:
Blocks: RHV4.1PPC RHEV3.6PPC RHEV4.0PPC
  Show dependency treegraph
 
Reported: 2015-12-28 04:21 EST by Nisim Simsolo
Modified: 2016-07-25 10:18 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-28 09:51:57 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
rule-engine: planning_ack?
rule-engine: devel_ack?
rule-engine: testing_ack?


Attachments (Terms of Use)

  None (edit)
Description Nisim Simsolo 2015-12-28 04:21:55 EST
Description of problem:
In some cases, such as using PPC, the cluster dropbox in the second import dialog will be empty. clicking "ok" in such case leads to webadmin exception.

Version-Release number of selected component (if applicable):
rhevm-3.6.1.3-0.1.el6

How reproducible:
Consistently.

Steps to Reproduce:
1. Browse webadmin UI and navigate to virtual machines tab > import > set VMware parameters and click "load" > select VM to import > click next.
2. See that second import dialog does not shows cluster in cluster dropbox > click ok
3.

Actual results:
Uncaught exception appears on the top of webadmin: 
Uncaught exception occurred. Please try reloading the page. Details: Exception caught: (TypeError) __gwt$exception:..

Expected results:
Exception should not occur, furthermore, when there is no available cluster to import to (such as PPC which is not supported yet) an appropriate message should appear.

Additional info:
Webadmin web-console log: 
Mon Dec 28 11:02:02 GMT+200 2015 
SEVERE: Uncaught exception: com.google.gwt.event.shared.UmbrellaException: Exception caught: (TypeError) 
 __gwt$exception: <skipped>: zab(...) is null
	at Unknown.ms(Unknown Source)
	at Unknown.us(Unknown Source)
	at Unknown.e3(Unknown Source)
	at Unknown.h3(Unknown Source)
	at Unknown.s2(Unknown Source)
	at Unknown.Im(Unknown Source)
	at Unknown.Sm(Unknown Source)
	at Unknown.g$(Unknown Source)
	at Unknown.Km(Unknown Source)
	at Unknown.v5e(Unknown Source)
	at Unknown.$Ve(Unknown Source)
	at Unknown.$Xe(Unknown Source)
	at Unknown.Yt(Unknown Source)
	at Unknown.au(Unknown Source)
	at Unknown._t/<(Unknown Source)
	at Unknown.ty(Unknown Source)
	at Unknown._4e(Unknown Source)
	at Unknown.eml(Unknown Source)
	at Unknown.v5e(Unknown Source)
	at Unknown.$Ve(Unknown Source)
	at Unknown.ZVe(Unknown Source)
	at Unknown.YXe(Unknown Source)
	at Unknown.Yt(Unknown Source)
	at Unknown.au(Unknown Source)
	at Unknown._t/<(Unknown Source)
	at Unknown.anonymous(Unknown Source)
Caused by: com.google.gwt.core.client.JavaScriptException: (TypeError) 
 __gwt$exception: <skipped>: zab(...) is null
	at Unknown.H2q(Unknown Source)
	at Unknown.N2q(Unknown Source)
	at Unknown.r3q(Unknown Source)
	at Unknown.hrr(Unknown Source)
	at Unknown.qll(Unknown Source)
	at Unknown.tyk(Unknown Source)
	at Unknown.B$(Unknown Source)
	at Unknown.C2(Unknown Source)
	at Unknown.s2(Unknown Source)
	at Unknown.Im(Unknown Source)
	at Unknown.Sm(Unknown Source)
	at Unknown.g$(Unknown Source)
	at Unknown.Km(Unknown Source)
	at Unknown.v5e(Unknown Source)
	at Unknown.$Ve(Unknown Source)
	at Unknown.$Xe(Unknown Source)
	at Unknown.Yt(Unknown Source)
	at Unknown.au(Unknown Source)
	at Unknown._t/<(Unknown Source)
	at Unknown.ty(Unknown Source)
	at Unknown._4e(Unknown Source)
	at Unknown.eml(Unknown Source)
	at Unknown.v5e(Unknown Source)
	at Unknown.$Ve(Unknown Source)
	at Unknown.ZVe(Unknown Source)
	at Unknown.YXe(Unknown Source)
	at Unknown.Yt(Unknown Source)
	at Unknown.au(Unknown Source)
	at Unknown._t/<(Unknown Source)
	at Unknown.anonymous(Unknown Source)
 06550BCB73EB7864DA79284790C1A9ED.cache.html:24013:11922
Comment 1 Nisim Simsolo 2015-12-28 09:51:57 EST

*** This bug has been marked as a duplicate of bug 1294451 ***

Note You need to log in before you can comment on or make changes to this bug.