Bug 1294490 - ImportError: No module named manilaclient
ImportError: No module named manilaclient
Status: CLOSED DUPLICATE of bug 1294489
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-heat (Show other bugs)
8.0 (Liberty)
Unspecified Unspecified
unspecified Severity high
: ---
: 8.0 (Liberty)
Assigned To: Zane Bitter
Amit Ugol
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-28 07:39 EST by Ronnie Rasouli
Modified: 2016-04-26 21:54 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-28 09:52:53 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ronnie Rasouli 2015-12-28 07:39:49 EST
Description of problem:

Post deployment failed in heat-* logs found errors
See BZ#1294469

2015-12-28 03:49:26.777 4825 ERROR stevedore.extension [-] Could not load 'manila.share_snapshot': No module named manilaclient
2015-12-28 03:49:26.777 4825 ERROR stevedore.extension [-] No module named manilaclient
2015-12-28 03:49:26.777 4825 ERROR stevedore.extension Traceback (most recent call last):
2015-12-28 03:49:26.777 4825 ERROR stevedore.extension   File "/usr/lib/python2.7/site-packages/stevedore/extension.py", line 162, in _load_plugins
2015-12-28 03:49:26.777 4825 ERROR stevedore.extension     verify_requirements,
2015-12-28 03:49:26.777 4825 ERROR stevedore.extension   File "/usr/lib/python2.7/site-packages/stevedore/extension.py", line 185, in _load_one_plugin
2015-12-28 03:49:26.777 4825 ERROR stevedore.extension     plugin = ep.load(require=verify_requirements)
2015-12-28 03:49:26.777 4825 ERROR stevedore.extension   File "/usr/lib/python2.7/site-packages/pkg_resources.py", line 2260, in load
2015-12-28 03:49:26.777 4825 ERROR stevedore.extension     entry = __import__(self.module_name, globals(),globals(), ['__name__'])
2015-12-28 03:49:26.777 4825 ERROR stevedore.extension   File "/usr/lib/python2.7/site-packages/heat/engine/clients/os/manila.py", line 16, in <module>
2015-12-28 03:49:26.777 4825 ERROR stevedore.extension     from manilaclient import client as manila_client
2015-12-28 03:49:26.777 4825 ERROR stevedore.extension ImportError: No module named manilaclient



Version-Release number of selected component (if applicable):

heat-cfntools-1.2.8-2.el7.noarch
openstack-heat-engine-5.0.0-1.el7ost.noarch
python-heatclient-0.8.0-1.el7ost.noarch
openstack-heat-api-cfn-5.0.0-1.el7ost.noarch
openstack-heat-common-5.0.0-1.el7ost.noarch
openstack-heat-api-cloudwatch-5.0.0-1.el7ost.noarch
openstack-heat-api-5.0.0-1.el7ost.noarch

How reproducible:

100%

Steps to Reproduce:
1. deploy openstack with the command script detailed in
http://file.tlv.redhat.com/~rrasouli/rhos8
2. deployment failed in post deploy status code: 6 
3. login to one of the HA controllers
4. look for errors in heat logs 

Actual results:

post Deployment failed, the error with Manila client appears

Expected results:

Should have no errors of components that hasn't been installed

Additional info:

from heat-engine.api

2015-12-28 03:49:26.530 4825 ERROR stevedore.extension [-] Could not load 'manila': No module named manilaclient
2015-12-28 03:49:26.530 4825 ERROR stevedore.extension [-] No module named manilaclient
2015-12-28 03:49:26.530 4825 ERROR stevedore.extension Traceback (most recent call last):
2015-12-28 03:49:26.530 4825 ERROR stevedore.extension   File "/usr/lib/python2.7/site-packages/stevedore/extension.py", line 162, in _load_plugins
2015-12-28 03:49:26.530 4825 ERROR stevedore.extension     verify_requirements,
2015-12-28 03:49:26.530 4825 ERROR stevedore.extension   File "/usr/lib/python2.7/site-packages/stevedore/enabled.py", line 67, in _load_one_plugin
2015-12-28 03:49:26.530 4825 ERROR stevedore.extension     verify_requirements,
2015-12-28 03:49:26.530 4825 ERROR stevedore.extension   File "/usr/lib/python2.7/site-packages/stevedore/extension.py", line 185, in _load_one_plugin
2015-12-28 03:49:26.530 4825 ERROR stevedore.extension     plugin = ep.load(require=verify_requirements)
2015-12-28 03:49:26.530 4825 ERROR stevedore.extension   File "/usr/lib/python2.7/site-packages/pkg_resources.py", line 2260, in load
2015-12-28 03:49:26.530 4825 ERROR stevedore.extension     entry = __import__(self.module_name, globals(),globals(), ['__name__'])
2015-12-28 03:49:26.530 4825 ERROR stevedore.extension   File "/usr/lib/python2.7/site-packages/heat/engine/clients/os/manila.py", line 16, in <module>
2015-12-28 03:49:26.530 4825 ERROR stevedore.extension     from manilaclient import client as manila_client
2015-12-28 03:49:26.530 4825 ERROR stevedore.extension ImportError: No module named manilaclient
Comment 2 Ronnie Rasouli 2015-12-28 09:52:53 EST

*** This bug has been marked as a duplicate of bug 1294489 ***

Note You need to log in before you can comment on or make changes to this bug.