This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1294496 - Could not load 'magnum': No module named magnumclient.openstack.common.apiclient
Could not load 'magnum': No module named magnumclient.openstack.common.apiclient
Status: CLOSED DUPLICATE of bug 1294489
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-heat (Show other bugs)
8.0 (Liberty)
Unspecified Unspecified
unspecified Severity unspecified
: ---
: 8.0 (Liberty)
Assigned To: Zane Bitter
Amit Ugol
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-28 08:41 EST by Ronnie Rasouli
Modified: 2016-04-26 21:44 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-01-04 11:36:07 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ronnie Rasouli 2015-12-28 08:41:09 EST
Description of problem:

heat-engine.log throws errors of missing with Magnum module

Post deployment fails

Version-Release number of selected component (if applicable):

heat-cfntools-1.2.8-2.el7.noarch
openstack-heat-engine-5.0.0-1.el7ost.noarch
python-heatclient-0.8.0-1.el7ost.noarch
openstack-heat-api-cfn-5.0.0-1.el7ost.noarch
openstack-heat-common-5.0.0-1.el7ost.noarch
openstack-heat-api-cloudwatch-5.0.0-1.el7ost.noarch
openstack-heat-api-5.0.0-1.el7ost.noarch


How reproducible:

100%



Steps to Reproduce:
1.deploy the overcloud as described in http://file.tlv.redhat.com/~rrasouli/rhos8
2. overcloud deployment fails with the error code 6, login to one of the controllers 
3. look for errors in heat* logs

Actual results:

Deployment fails heat complains for missing modules 

Expected results:

no errors and successful deployment 
Additional info:

2015-12-28 03:49:26.536 4825 ERROR stevedore.extension [-] Could not load 'magnum': No module named magnumclient.openstack.common.apiclient
2015-12-28 03:49:26.536 4825 ERROR stevedore.extension [-] No module named magnumclient.openstack.common.apiclient
2015-12-28 03:49:26.536 4825 ERROR stevedore.extension Traceback (most recent call last):
2015-12-28 03:49:26.536 4825 ERROR stevedore.extension   File "/usr/lib/python2.7/site-packages/stevedore/extension.py", line 162, in _load_plugins
2015-12-28 03:49:26.536 4825 ERROR stevedore.extension     verify_requirements,
2015-12-28 03:49:26.536 4825 ERROR stevedore.extension   File "/usr/lib/python2.7/site-packages/stevedore/enabled.py", line 67, in _load_one_plugin
2015-12-28 03:49:26.536 4825 ERROR stevedore.extension     verify_requirements,
2015-12-28 03:49:26.536 4825 ERROR stevedore.extension   File "/usr/lib/python2.7/site-packages/stevedore/extension.py", line 185, in _load_one_plugin
2015-12-28 03:49:26.536 4825 ERROR stevedore.extension     plugin = ep.load(require=verify_requirements)
2015-12-28 03:49:26.536 4825 ERROR stevedore.extension   File "/usr/lib/python2.7/site-packages/pkg_resources.py", line 2260, in load
2015-12-28 03:49:26.536 4825 ERROR stevedore.extension     entry = __import__(self.module_name, globals(),globals(), ['__name__'])
2015-12-28 03:49:26.536 4825 ERROR stevedore.extension   File "/usr/lib/python2.7/site-packages/heat/engine/clients/os/magnum.py", line 14, in <module>
2015-12-28 03:49:26.536 4825 ERROR stevedore.extension     from magnumclient.openstack.common.apiclient import exceptions
2015-12-28 03:49:26.536 4825 ERROR stevedore.extension ImportError: No module named magnumclient.openstack.common.apiclient
Comment 2 Zane Bitter 2016-01-04 11:36:07 EST

*** This bug has been marked as a duplicate of bug 1294489 ***

Note You need to log in before you can comment on or make changes to this bug.