Bug 1294500 - v2v: Cannot import VM as clone if the VM was already imported (not as clone).
v2v: Cannot import VM as clone if the VM was already imported (not as clone).
Status: CLOSED DUPLICATE of bug 1294501
Product: ovirt-engine
Classification: oVirt
Component: BLL.Virt (Show other bugs)
3.6.1
Unspecified Unspecified
unspecified Severity medium (vote)
: ---
: ---
Assigned To: Michal Skrivanek
Nisim Simsolo
virt
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-28 09:39 EST by Nisim Simsolo
Modified: 2015-12-28 09:49 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-28 09:49:46 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
rule-engine: planning_ack?
rule-engine: devel_ack?
rule-engine: testing_ack?


Attachments (Terms of Use)

  None (edit)
Description Nisim Simsolo 2015-12-28 09:39:55 EST
Description of problem:
Importing VM as clone when the same VM was already imported, failed with "VM Id already exist in the system" error message.
This issue is true also when changing destination VM name.

Version-Release number of selected component (if applicable):
rhevm-3.6.2-0.1.el6
vdsm-4.17.14-0.el7ev.noarch
sanlock-3.2.4-1.el7.x86_64
libvirt-client-1.2.17-13.el7_2.2.x86_64
qemu-kvm-rhev-2.3.0-31.el7_2.4.x86_64

How reproducible:
Consistently.

Steps to Reproduce:
1. Import VM from VMware, not as a clone.
2. Import the same VM again, verify clone checkbox is checked, change VM name and click "ok".
3.

Actual results:
Action failed with the next message: 
Error while executing action:

test888:

    Import VM failed - VM Id already exist in the system. Please remove the VM (rhel7_nisim) from the system first

Expected results:
Import VM as clone should succeed.

Additional info:
engine and vdsm log attached.
Engine.log issue: 2015-12-28 16:35:36,283 INFO
Comment 1 Nisim Simsolo 2015-12-28 09:49:46 EST

*** This bug has been marked as a duplicate of bug 1294501 ***

Note You need to log in before you can comment on or make changes to this bug.