Bug 1294501 - v2v: Cannot import VM as clone if the VM was already imported (not as clone).
v2v: Cannot import VM as clone if the VM was already imported (not as clone).
Status: CLOSED CURRENTRELEASE
Product: ovirt-engine
Classification: oVirt
Component: BLL.Virt (Show other bugs)
3.6.1
Unspecified Unspecified
unspecified Severity medium (vote)
: ovirt-3.6.3
: 3.6.3
Assigned To: Arik
meital avital
:
: 1294500 (view as bug list)
Depends On: 1294651
Blocks: 952703 1236075
  Show dependency treegraph
 
Reported: 2015-12-28 09:41 EST by Nisim Simsolo
Modified: 2016-02-18 06:02 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-18 06:02:34 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Virt
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
rule-engine: ovirt‑3.6.z+
rule-engine: planning_ack+
michal.skrivanek: devel_ack+
mavital: testing_ack+


Attachments (Terms of Use)
engine.log (103.28 KB, application/x-gzip)
2015-12-28 09:44 EST, Nisim Simsolo
no flags Details
vdsm.log (183.68 KB, application/x-gzip)
2015-12-28 09:44 EST, Nisim Simsolo
no flags Details
webadmin screenshot (151.00 KB, image/png)
2015-12-28 09:45 EST, Nisim Simsolo
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 51143 None None None 2015-12-30 09:50 EST
oVirt gerrit 51176 ovirt-engine-3.6 MERGED core: fix import vm from vmware as clone 2015-12-31 10:32 EST

  None (edit)
Description Nisim Simsolo 2015-12-28 09:41:26 EST
Description of problem:
Importing VM as clone when the same VM was already imported, failed with "VM Id already exist in the system" error message.
This issue is true also when changing destination VM name.

Version-Release number of selected component (if applicable):
rhevm-3.6.2-0.1.el6
vdsm-4.17.14-0.el7ev.noarch
sanlock-3.2.4-1.el7.x86_64
libvirt-client-1.2.17-13.el7_2.2.x86_64
qemu-kvm-rhev-2.3.0-31.el7_2.4.x86_64

How reproducible:
Consistently.

Steps to Reproduce:
1. Import VM from VMware, not as a clone.
2. Import the same VM again, verify clone checkbox is checked, change VM name and click "ok".
3.

Actual results:
Action failed with the next message: 
Error while executing action:

test888:

    Import VM failed - VM Id already exist in the system. Please remove the VM (rhel7_nisim) from the system first

Expected results:
Import VM as clone should succeed.

Additional info:
engine and vdsm log attached.
Engine.log issue: 2015-12-28 16:35:36,283 INFO
Comment 1 Nisim Simsolo 2015-12-28 09:44 EST
Created attachment 1110034 [details]
engine.log
Comment 2 Nisim Simsolo 2015-12-28 09:44 EST
Created attachment 1110035 [details]
vdsm.log
Comment 3 Nisim Simsolo 2015-12-28 09:45 EST
Created attachment 1110036 [details]
webadmin screenshot
Comment 4 Nisim Simsolo 2015-12-28 09:49:46 EST
*** Bug 1294500 has been marked as a duplicate of this bug. ***
Comment 5 meital avital 2016-02-08 11:50:17 EST
Verified on :
rhevm-3.6.3-0.1.el6
libvirt-client-1.2.17-13.el7_2.2.x86_64
qemu-kvm-rhev-2.3.0-31.el7_2.4.x86_64
vdsm-4.17.19-0.el7ev.noarch

Verified steps:
1)Import VM1 from VMware, not as a clone.
2)Import the same VM1 again as clone, changed VM name.
3)Import the same VM1 again as clone, with name that match other VM in VMware.
4)Import VM2 in the first time and check the clone checkbox.

Note You need to log in before you can comment on or make changes to this bug.