This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1294514 - [abrt] dnf: i18n.py:44:write:UnicodeEncodeError: 'ascii' codec can't encode character '\xe6' in position 4: ordinal not in range(128)
[abrt] dnf: i18n.py:44:write:UnicodeEncodeError: 'ascii' codec can't encode c...
Status: CLOSED DUPLICATE of bug 1295090
Product: Fedora
Classification: Fedora
Component: dnf (Show other bugs)
23
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: packaging-team-maint
Fedora Extras Quality Assurance
https://retrace.fedoraproject.org/faf...
abrt_hash:8ea76d9f42546b0f0e713ab99e2...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-28 11:38 EST by Allan Poulsen
Modified: 2016-01-04 07:57 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-01-04 07:57:20 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: _var_log_dnf.log (704.25 KB, text/plain)
2015-12-28 11:38 EST, Allan Poulsen
no flags Details
File: backtrace (1.36 KB, text/plain)
2015-12-28 11:38 EST, Allan Poulsen
no flags Details
File: dnf-makecache.log (1.40 MB, text/plain)
2015-12-28 11:38 EST, Allan Poulsen
no flags Details
File: environ (1.79 KB, text/plain)
2015-12-28 11:38 EST, Allan Poulsen
no flags Details

  None (edit)
Description Allan Poulsen 2015-12-28 11:38:22 EST
Version-Release number of selected component:
dnf-1.1.4-2.fc23

Additional info:
reporter:       libreport-2.6.3
cmdline:        /usr/bin/python3 -OO /usr/bin/dnf list all
executable:     /usr/bin/dnf
kernel:         4.2.7-300.fc23.x86_64
runlevel:       N 5
type:           Python3
uid:            1000

Truncated backtrace:
i18n.py:44:write:UnicodeEncodeError: 'ascii' codec can't encode character '\xe6' in position 4: ordinal not in range(128)

Traceback (most recent call last):
  File "/usr/bin/dnf", line 57, in <module>
    main.user_main(sys.argv[1:], exit_code=True)
  File "/usr/lib/python3.4/site-packages/dnf/cli/main.py", line 174, in user_main
    errcode = main(args)
  File "/usr/lib/python3.4/site-packages/dnf/cli/main.py", line 60, in main
    return _main(base, args)
  File "/usr/lib/python3.4/site-packages/dnf/cli/main.py", line 112, in _main
    cli.run()
  File "/usr/lib/python3.4/site-packages/dnf/cli/cli.py", line 1091, in run
    return self.command.run(self.base.extcmds)
  File "/usr/lib/python3.4/site-packages/dnf/cli/commands/__init__.py", line 271, in run
    return self.base.output_packages('list', pkgnarrow, patterns)
  File "/usr/lib/python3.4/site-packages/dnf/cli/cli.py", line 435, in output_packages
    '=' : clar, 'not in' : clai})
  File "/usr/lib/python3.4/site-packages/dnf/cli/output.py", line 589, in listPkgs
    print('%s' % description)
  File "/usr/lib/python3.4/site-packages/dnf/i18n.py", line 44, in write
    self.stream.write(s)
UnicodeEncodeError: 'ascii' codec can't encode character '\xe6' in position 4: ordinal not in range(128)

Local variables in innermost frame:
s: 'Tilgængelige pakker'
self: <dnf.i18n.UnicodeStream object at 0x7f5df14a2780>
Comment 1 Allan Poulsen 2015-12-28 11:38:31 EST
Created attachment 1110040 [details]
File: _var_log_dnf.log
Comment 2 Allan Poulsen 2015-12-28 11:38:33 EST
Created attachment 1110041 [details]
File: backtrace
Comment 3 Allan Poulsen 2015-12-28 11:38:41 EST
Created attachment 1110042 [details]
File: dnf-makecache.log
Comment 4 Allan Poulsen 2015-12-28 11:38:42 EST
Created attachment 1110043 [details]
File: environ
Comment 5 Honza Silhan 2016-01-04 07:57:20 EST

*** This bug has been marked as a duplicate of bug 1295090 ***

Note You need to log in before you can comment on or make changes to this bug.