Bug 1294600 - [Tier]: Killing glusterfs tier process doesn't reflect as failed/faulty in tier status
[Tier]: Killing glusterfs tier process doesn't reflect as failed/faulty in ti...
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: tiering (Show other bugs)
mainline
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Mohammed Rafi KC
bugs@gluster.org
: Regression, ZStream
Depends On: 1294594
Blocks: 1295365
  Show dependency treegraph
 
Reported: 2015-12-29 02:54 EST by Mohammed Rafi KC
Modified: 2016-06-16 09:52 EDT (History)
5 users (show)

See Also:
Fixed In Version: glusterfs-3.8rc2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1294594
: 1295365 (view as bug list)
Environment:
Last Closed: 2016-06-16 09:52:41 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 1 Vijay Bellur 2015-12-29 02:55:33 EST
REVIEW: http://review.gluster.org/13107 (tier/glusterd: tier daemon not updating the status) posted (#1) for review on master by mohammed rafi  kc (rkavunga@redhat.com)
Comment 2 Vijay Bellur 2015-12-29 06:46:36 EST
REVIEW: http://review.gluster.org/13107 (tier/glusterd: tier daemon not updating the status) posted (#2) for review on master by mohammed rafi  kc (rkavunga@redhat.com)
Comment 3 Vijay Bellur 2016-01-04 00:19:14 EST
COMMIT: http://review.gluster.org/13107 committed in master by Atin Mukherjee (amukherj@redhat.com) 
------
commit fa4f583e469c065b4e1fb7ddfadfd14e1e6d62ae
Author: Mohammed Rafi KC <rkavunga@redhat.com>
Date:   Tue Dec 29 12:42:30 2015 +0530

    tier/glusterd: tier daemon not updating the status
    
    Tier process is not updating the status when the process killed
    mnually.
    
    Change-Id: Ia5ea903af78ff3582da2242e6058f11c71923fab
    BUG: 1294600
    Signed-off-by: Mohammed Rafi KC <rkavunga@redhat.com>
    Reviewed-on: http://review.gluster.org/13107
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    Reviewed-by: Atin Mukherjee <amukherj@redhat.com>
Comment 4 Niels de Vos 2016-06-16 09:52:41 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.0, please open a new bug report.

glusterfs-3.8.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://blog.gluster.org/2016/06/glusterfs-3-8-released/
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.