Bug 1295365 - [Tier]: Killing glusterfs tier process doesn't reflect as failed/faulty in tier status
[Tier]: Killing glusterfs tier process doesn't reflect as failed/faulty in ti...
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: tiering (Show other bugs)
3.7.7
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Mohammed Rafi KC
bugs@gluster.org
: Regression, ZStream
Depends On: 1294594 1294600
Blocks: glusterfs-3.7.9
  Show dependency treegraph
 
Reported: 2016-01-04 04:23 EST by Mohammed Rafi KC
Modified: 2016-04-19 03:24 EDT (History)
6 users (show)

See Also:
Fixed In Version: glusterfs-3.7.9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1294600
Environment:
Last Closed: 2016-04-19 03:24:20 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 1 Vijay Bellur 2016-01-04 04:24:24 EST
REVIEW: http://review.gluster.org/13165 (tier/glusterd: tier daemon not updating the status) posted (#1) for review on release-3.7 by mohammed rafi  kc (rkavunga@redhat.com)
Comment 2 Vijay Bellur 2016-02-10 00:30:34 EST
REVIEW: http://review.gluster.org/13165 (tier/glusterd: tier daemon not updating the status) posted (#2) for review on release-3.7 by mohammed rafi  kc (rkavunga@redhat.com)
Comment 3 Vijay Bellur 2016-02-22 09:50:10 EST
COMMIT: http://review.gluster.org/13165 committed in release-3.7 by Dan Lambright (dlambrig@redhat.com) 
------
commit d48f1640b7c3932e0dfa979df8f25a5062ec4c37
Author: Mohammed Rafi KC <rkavunga@redhat.com>
Date:   Tue Dec 29 12:42:30 2015 +0530

    tier/glusterd: tier daemon not updating the status
    
    Tier process is not updating the status when the process killed
    mnually.
    
    backport of>
    >Change-Id: Ia5ea903af78ff3582da2242e6058f11c71923fab
    >BUG: 1294600
    >Signed-off-by: Mohammed Rafi KC <rkavunga@redhat.com>
    >Reviewed-on: http://review.gluster.org/13107
    >Tested-by: Gluster Build System <jenkins@build.gluster.com>
    >Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    >Reviewed-by: Atin Mukherjee <amukherj@redhat.com>
    
    Change-Id: I208953af5ee7985ad5b01a434ef0c94fefb0af2d
    BUG: 1295365
    Signed-off-by: Mohammed Rafi KC <rkavunga@redhat.com>
    Reviewed-on: http://review.gluster.org/13165
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    Smoke: Gluster Build System <jenkins@build.gluster.com>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Dan Lambright <dlambrig@redhat.com>
Comment 4 Kaushal 2016-04-19 03:24:20 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.9, please open a new bug report.

glusterfs-3.7.9 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] https://www.gluster.org/pipermail/gluster-users/2016-March/025922.html
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.