Bug 1294619 - Guest should failed to boot if set iops,bps to negative number
Guest should failed to boot if set iops,bps to negative number
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: qemu-kvm (Show other bugs)
6.8
x86_64 All
high Severity high
: rc
: ---
Assigned To: Fam Zheng
Virtualization Bugs
: Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-29 05:11 EST by Qianqian Zhu
Modified: 2016-05-10 17:02 EDT (History)
8 users (show)

See Also:
Fixed In Version: qemu-kvm-0.12.1.2-2.486.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-05-10 17:02:21 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Qianqian Zhu 2015-12-29 05:11:28 EST
Description of problem:
Guest should failed to boot if set iops,bps to negative number

Version-Release number of selected component (if applicable):
qemu-kvm-rhev-0.12.1.2-2.482.el6.x86_64
kernel-2.6.32-590.el6.x86_64

How reproducible:
100%

Steps to Reproduce:
1.Launch guest with:
/usr/libexec/qemu-kvm -name virtio -m 1024 -cpu Westmere,check -realtime mlock=off -smp 2 -global PIIX4_PM.disable_s4=1 -global PIIX4_PM.disable_s3=1 -boot order=c,menu=on -device virtio-serial-pci,id=virtio-serial0,bus=pci.0,addr=0x6 -drive file=/nfs/rhel6.7_virtio.qcow2,format=qcow2,if=none,id=block-virtio,cache=none,werror=stop,rerror=stop -device virtio-blk-pci,bus=pci.0,addr=0x8,drive=block-virtio,id=block-virtio,bootindex=1 -device virtio-balloon-pci,id=balloon0,bus=pci.0,addr=0x7 -monitor stdio -vnc :4 -vga cirrus -drive file=/nfs/test20G.qcow2,if=none,cache=none,id=drive-ide0-1-0,format=qcow2,iops=-1,bps=-1
2.
3.

Actual results:
qemu launched successfully and no error prompt.
(qemu) info block
block-virtio: removable=0 io-status=ok file=/nfs/rhel6.7_virtio.qcow2 ro=0 drv=qcow2 encrypted=0 bps=0 bps_rd=0 bps_wr=0 iops=0 iops_rd=0 iops_wr=0
drive-ide0-1-0: removable=1 locked=0 tray-open=0 file=/nfs/test20G.qcow2 ro=0 drv=qcow2 encrypted=0 bps=-9223372036854775808 bps_rd=0 bps_wr=0 iops=-9223372036854775808 iops_rd=0 iops_wr=0


Expected results:
qemu prompt error like "bps and iops values must be 0 or greater" and then quit.

Additional info:
Tried same scenario with qemu-kvm-rhev-0.12.1.2-2.448.el6_6.3.x86_64, got expected prompt:
qemu-kvm: -drive file=/nfs/test20G.qcow2,if=none,cache=none,id=drive-ide0-1-0,format=qcow2,iops=-1,bps=-1: bps and iops values must be 0 or greater

Reproduced with qemu-kvm-rhev-0.12.1.2-2.477.el6.x86_64
Comment 5 Fam Zheng 2016-01-11 00:45:05 EST
RHEL 7.2 is okay, but not RHEV 7.2 (qemu-kvm-rhev). Please test that and clone this bug to qemu-kvm-rhev 7.3 if it's the case.
Comment 6 Qianqian Zhu 2016-01-11 04:21:35 EST
(In reply to Fam Zheng from comment #5)
> RHEL 7.2 is okay, but not RHEV 7.2 (qemu-kvm-rhev). Please test that and
> clone this bug to qemu-kvm-rhev 7.3 if it's the case.

Created Bug 1297334.
Comment 9 Jeff Nelson 2016-01-25 16:39:22 EST
Fix included in qemu-kvm-0.12.1.2-2.486.el6
Comment 12 Qianqian Zhu 2016-02-14 01:13:31 EST
Verified with:
qemu-kvm-rhev-0.12.1.2-2.486.el6.x86_64
kernel-2.6.32-584.el6.x86_64

Steps:
1.Launch guest with:
/usr/libexec/qemu-kvm -drive file=/mnt/RHEL-Server-6.7-64-virtio.qcow2,if=none,cache=none,id=drive-ide0-1-0,format=qcow2,iops=-1,bps=-1

Result:
qemu prompts proper info and quit:
qemu-kvm: -drive file=/mnt/RHEL-Server-6.7-64-virtio.qcow2,if=none,cache=none,id=drive-ide0-1-0,format=qcow2,iops=-1,bps=-1: bps/iops/max values must be within [0, 1000000000000000]
Comment 15 errata-xmlrpc 2016-05-10 17:02:21 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0815.html

Note You need to log in before you can comment on or make changes to this bug.