Bug 1297334 - Guest should failed to boot if set iops,bps to negative number
Summary: Guest should failed to boot if set iops,bps to negative number
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: qemu-kvm-rhev
Version: 7.3
Hardware: x86_64
OS: Linux
high
high
Target Milestone: rc
: ---
Assignee: Fam Zheng
QA Contact: Gu Nini
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-01-11 09:18 UTC by Qianqian Zhu
Modified: 2016-11-07 20:54 UTC (History)
6 users (show)

Fixed In Version: QEMU 2.6
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-11-07 20:54:09 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:2673 normal SHIPPED_LIVE qemu-kvm-rhev bug fix and enhancement update 2016-11-08 01:06:13 UTC

Description Qianqian Zhu 2016-01-11 09:18:21 UTC
+++ This bug was initially created as a clone of Bug 1294619 +++

Description of problem:
Guest should failed to boot if set iops,bps to negative number

Version-Release number of selected component (if applicable):
kernel-3.10.0-328.el7.x86_64
qemu-kvm-rhev-2.3.0-31.el7.x86_64

How reproducible:
100%

Steps to Reproduce:
1.Launch guest with:
/usr/libexec/qemu-kvm -name virtio -m 1024 -cpu Westmere,check -realtime mlock=off -smp 2 -global PIIX4_PM.disable_s4=1 -global PIIX4_PM.disable_s3=1 -boot order=c,menu=on -device virtio-serial-pci,id=virtio-serial0,bus=pci.0,addr=0x6 -drive file=/nfs/rhel6.7_virtio.qcow2,format=qcow2,if=none,id=block-virtio,cache=none,werror=stop,rerror=stop -device virtio-blk-pci,bus=pci.0,addr=0x8,drive=block-virtio,id=block-virtio,bootindex=1 -device virtio-balloon-pci,id=balloon0,bus=pci.0,addr=0x7 -monitor stdio -vnc :4 -vga cirrus -drive file=/nfs/test20G.qcow2,if=none,cache=none,id=drive-ide0-1-0,format=qcow2,iops=-1,bps=-1
2.
3.

Actual results:
qemu launched successfully and no error prompt.
(qemu) info block
block-virtio: removable=0 io-status=ok file=/nfs/rhel6.7_virtio.qcow2 ro=0 drv=qcow2 encrypted=0 bps=0 bps_rd=0 bps_wr=0 iops=0 iops_rd=0 iops_wr=0
drive-ide0-1-0: removable=1 locked=0 tray-open=0 file=/nfs/test20G.qcow2 ro=0 drv=qcow2 encrypted=0 bps=-9223372036854775808 bps_rd=0 bps_wr=0 iops=-9223372036854775808 iops_rd=0 iops_wr=0


Additional info:

Comment 2 Ademar Reis 2016-01-11 12:56:33 UTC
I see Fam submitted patches upstream. They will probably be accepted and we'll get the fix via rebase. Otherwise, I wonder if this issue is hit via libvirt (direct usage of QEMU/QMP is not supported).

Comment 3 Fam Zheng 2016-02-15 02:36:52 UTC
Upstream commit:

commit 972606c4db826f286f7f475551180502859f49b9
Author: Fam Zheng <famz@redhat.com>
Date:   Wed Jan 20 12:21:20 2016 +0800

    blockdev: Error out on negative throttling option values

Comment 4 Mike McCune 2016-03-28 22:35:49 UTC
This bug was accidentally moved from POST to MODIFIED via an error in automation, please see mmccune@redhat.com with any questions

Comment 6 Gu Nini 2016-08-12 10:11:21 UTC
Verify the bug on following sw versions:
Kernel: 3.10.0-489.el7.x86_64
Qemu-kvm-rhev: qemu-kvm-rhev-2.6.0-20.el7.x86_64


Now once set negative number for FOO/FOO_max, the guest could not boot up and there is following prompt:

qemu-kvm: -drive id=drive_image2,if=none,snapshot=off,aio=native,cache=none,format=qcow2,file=/home/hd1,bps=-512000,bps_max=1024000,throttling.bps-total-max-length=5: bps/iops/max values must be within [0, 1000000000000000]

Comment 8 errata-xmlrpc 2016-11-07 20:54:09 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2673.html


Note You need to log in before you can comment on or make changes to this bug.