Bug 1294743 - Lot of Inode not found messages in glfsheal log file
Lot of Inode not found messages in glfsheal log file
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: disperse (Show other bugs)
mainline
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Pranith Kumar K
: ZStream
Depends On: 1294059
Blocks: 1302943
  Show dependency treegraph
 
Reported: 2015-12-29 23:54 EST by Pranith Kumar K
Modified: 2016-06-16 09:52 EDT (History)
3 users (show)

See Also:
Fixed In Version: glusterfs-3.8rc2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1294059
: 1302943 (view as bug list)
Environment:
Last Closed: 2016-06-16 09:52:41 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 1 Pranith Kumar K 2015-12-29 23:55:07 EST
Seeing lot of inode not found messages in glfsheal log file.

This is on a 4+2 ec volume and 2x2 tier attached to it. Was running brick down and heal info commands

[2015-12-24 10:23:47.397946] W [inode.c:646:inode_new] (-->/usr/sbin/glfsheal(+0x2ab1) [0x7f36f0c27ab1] -->/lib64/libglusterfs.so.0(syncop_gfid_to_path+0x5c) [0x7f36f07bd6fc] -->/lib64/libglusterfs.so.0(inode_new+0x8c) [0x7f36f077bf4c] ) 0-dpvol-disperse-0: inode not found
[2015-12-24 10:23:47.398344] W [inode.c:646:inode_new] (-->/usr/sbin/glfsheal(+0x2ab1) [0x7f36f0c27ab1] -->/lib64/libglusterfs.so.0(syncop_gfid_to_path+0x5c) [0x7f36f07bd6fc] -->/lib64/libglusterfs.so.0(inode_new+0x8c) [0x7f36f077bf4c] ) 0-dpvol-disperse-0: inode not found
[2015-12-24 10:23:47.398544] W [inode.c:646:inode_new] (-->/usr/sbin/glfsheal(+0x2ab1) [0x7f36f0c27ab1] -->/lib64/libglusterfs.so.0(syncop_gfid_to_path+0x5c) [0x7f36f07bd6fc] -->/lib64/libglusterfs.so.0(inode_new+0x8c) [0x7f36f077bf4c] ) 0-dpvol-disperse-0: inode not found
[2015-12-24 10:23:47.398748] W [inode.c:646:inode_new] (-->/usr/sbin/glfsheal(+0x2ab1) [0x7f36f0c27ab1] -->/lib64/libglusterfs.so.0(syncop_gfid_to_path+0x5c) [0x7f36f07bd6fc] -->/lib64/libglusterfs.so.0(inode_new+0x8c) [0x7f36f077bf4c] ) 0-dpvol-disperse-0: inode not found
[2015-12-24 10:23:47.399003] W [inode.c:646:inode_new] (-->/usr/sbin/glfsheal(+0x2ab1) [0x7f36f0c27ab1] -->/lib64/libglusterfs.so.0(syncop_gfid_to_path+0x5c) [0x7f36f07bd6fc] -->/lib64/libglusterfs.so.0(inode_new+0x8c) [0x7f36f077bf4c] ) 0-dpvol-disperse-0: inode not found
[2015-12-24 10:23:47.399204] W [inode.c:646:inode_new] (-->/usr/sbin/glfsheal(+0x2ab1) [0x7f36f0c27ab1] -->/lib64/libglusterfs.so.0(syncop_gfid_to_path+0x5c) [0x7f36f07bd6fc] -->/lib64/libglusterfs.so.0(inode_new+0x8c) [0x7f36f077bf4c] ) 0-dpvol-disperse-0: inode not found
[2015-12-24 10:23:47.399392] W [inode.c:646:inode_new] (-->/usr/sbin/glfsheal(+0x2ab1) [0x7f36f0c27ab1] -->/lib64/libglusterfs.so.0(syncop_gfid_to_path+0x5c) [0x7f36f07bd6fc] -->/lib64/libglusterfs.so.0(inode_new+0x8c) [0x7f36f077bf4c] ) 0-dpvol-disperse-0: inode not found
[2015-12-24 10:23:47.399579] W [inode.c:646:inode_new] (-->/usr/sbin/glfsheal(+0x2ab1) [0x7f36f0c27ab1] -->/lib64/libglusterfs.so.0(syncop_gfid_to_path+0x5c) [0x7f36f07bd6fc] -->/lib64/libglusterfs.so.0(inode_new+0x8c) [0x7f36f077bf4c] ) 0-dpvol-disperse-0: inode not found
Comment 2 Vijay Bellur 2015-12-29 23:56:01 EST
REVIEW: http://review.gluster.org/13112 (cluster/ec: Create this->itable in all cases) posted (#1) for review on master by Pranith Kumar Karampuri (pkarampu@redhat.com)
Comment 3 Vijay Bellur 2016-01-05 23:53:15 EST
REVIEW: http://review.gluster.org/13112 (cluster/ec: Create this->itable in all cases) posted (#2) for review on master by Pranith Kumar Karampuri (pkarampu@redhat.com)
Comment 4 Vijay Bellur 2016-01-28 20:46:13 EST
REVIEW: http://review.gluster.org/13112 (cluster/ec: Create this->itable in all cases) posted (#3) for review on master by Pranith Kumar Karampuri (pkarampu@redhat.com)
Comment 5 Vijay Bellur 2016-01-29 00:13:06 EST
COMMIT: http://review.gluster.org/13112 committed in master by Pranith Kumar Karampuri (pkarampu@redhat.com) 
------
commit 080ddb79d8805253a7f4274606351570faae1add
Author: Pranith Kumar K <pkarampu@redhat.com>
Date:   Wed Dec 30 10:17:00 2015 +0530

    cluster/ec: Create this->itable in all cases
    
    Problem:
    glfsheal operates based on mount's volfile which doesn't have iamshd flag due
    to which this->itable is NULL, this leads to "inode not found" logs in glfsheal
    logs.
    
    Fix:
    Ec only allocates itable with 10 inodes, so allocating this->itable in all
    cases in init.
    
    Change-Id: I01d3c05e93a17007a4716a2d6f392d2aa306a34b
    BUG: 1294743
    Signed-off-by: Pranith Kumar K <pkarampu@redhat.com>
    Reviewed-on: http://review.gluster.org/13112
    Smoke: Gluster Build System <jenkins@build.gluster.com>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.com>
Comment 6 Mike McCune 2016-03-28 19:18:47 EDT
This bug was accidentally moved from POST to MODIFIED via an error in automation, please see mmccune@redhat.com with any questions
Comment 7 Niels de Vos 2016-06-16 09:52:41 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.0, please open a new bug report.

glusterfs-3.8.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://blog.gluster.org/2016/06/glusterfs-3-8-released/
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.