Bug 1302943 - Lot of Inode not found messages in glfsheal log file
Lot of Inode not found messages in glfsheal log file
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: disperse (Show other bugs)
3.7.7
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Pranith Kumar K
: ZStream
Depends On: 1294059 1294743
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-29 00:13 EST by Pranith Kumar K
Modified: 2016-04-19 03:53 EDT (History)
4 users (show)

See Also:
Fixed In Version: glusterfs-3.7.7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1294743
Environment:
Last Closed: 2016-04-19 03:53:11 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 1 Vijay Bellur 2016-01-29 00:16:43 EST
REVIEW: http://review.gluster.org/13312 (cluster/ec: Create this->itable in all cases) posted (#1) for review on release-3.7 by Pranith Kumar Karampuri (pkarampu@redhat.com)
Comment 2 Vijay Bellur 2016-01-30 21:27:11 EST
COMMIT: http://review.gluster.org/13312 committed in release-3.7 by Pranith Kumar Karampuri (pkarampu@redhat.com) 
------
commit 4a9e1a10b454751f70bad36b49fc201a98f314be
Author: Pranith Kumar K <pkarampu@redhat.com>
Date:   Wed Dec 30 10:17:00 2015 +0530

    cluster/ec: Create this->itable in all cases
    
    Problem:
    glfsheal operates based on mount's volfile which doesn't have iamshd flag due
    to which this->itable is NULL, this leads to "inode not found" logs in glfsheal
    logs.
    
    Fix:
    Ec only allocates itable with 10 inodes, so allocating this->itable in all
    cases in init.
    
     >Change-Id: I01d3c05e93a17007a4716a2d6f392d2aa306a34b
     >BUG: 1294743
     >Signed-off-by: Pranith Kumar K <pkarampu@redhat.com>
     >Reviewed-on: http://review.gluster.org/13112
     >Smoke: Gluster Build System <jenkins@build.gluster.com>
     >NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
     >CentOS-regression: Gluster Build System <jenkins@build.gluster.com>
     >(cherry picked from commit 080ddb79d8805253a7f4274606351570faae1add)
    
    Change-Id: I4fb624fc26d47128221322da077d04b12add6452
    Signed-off-by: Pranith Kumar K <pkarampu@redhat.com>
    BUG: 1302943
    Reviewed-on: http://review.gluster.org/13312
    Smoke: Gluster Build System <jenkins@build.gluster.com>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.com>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
Comment 6 Mike McCune 2016-03-28 19:18:47 EDT
This bug was accidentally moved from POST to MODIFIED via an error in automation, please see mmccune@redhat.com with any questions
Comment 7 Kaushal 2016-04-19 03:53:11 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.7, please open a new bug report.

glusterfs-3.7.7 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] https://www.gluster.org/pipermail/gluster-users/2016-February/025292.html
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.