Bug 1294783 - rhevm-setup-plugins and rhevm-setup mismatch causes rhevm-setup to fail
Summary: rhevm-setup-plugins and rhevm-setup mismatch causes rhevm-setup to fail
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: rhevm-appliance
Version: 3.6.2
Hardware: Unspecified
OS: Unspecified
urgent
urgent
Target Milestone: ovirt-3.6.2
: 3.6.2
Assignee: Anatoly Litovsky
QA Contact: Nikolai Sednev
URL:
Whiteboard:
: 1295192 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-12-30 10:13 UTC by cshao
Modified: 2016-03-09 21:44 UTC (History)
22 users (show)

Fixed In Version: rhevm-appliance-20160120.0-1
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-03-09 21:44:49 UTC
oVirt Team: Node
Target Upstream Version:


Attachments (Terms of Use)
setup-failed-ova.tar.gz (552.88 KB, application/x-gzip)
2015-12-30 10:13 UTC, cshao
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:0385 normal SHIPPED_LIVE rhevm-appliance bug fix and enhancement update 2016-03-10 02:43:23 UTC

Description cshao 2015-12-30 10:13:01 UTC
Created attachment 1110471 [details]
setup-failed-ova.tar.gz

Description of problem:
Failed to setup engine via OVA

# engine-setup --offline --config-append=ovirt-engine-answers
[ INFO  ] Stage: Initializing
[ ERROR ] Failed to execute stage 'Initializing': type object 'RPMDistroEnv' has no attribute 'ADDITIONAL_PACKAGES'
[ INFO  ] Stage: Clean up
          Log file is located at /var/log/ovirt-engine/setup/ovirt-engine-setup-20151230020222-pq2a6b.log
[ ERROR ] Failed to execute stage 'Clean up': 'NoneType' object has no attribute 'cleanup'
[ INFO  ] Generating answer file '/var/lib/ovirt-engine/setup/answers/20151230020222-setup.conf'
[ INFO  ] Stage: Pre-termination
[ INFO  ] Stage: Termination
[ ERROR ] Execution of setup failed


Version-Release number of selected component (if applicable):
rhev-hypervisor7-7.2-20151229.0 
ovirt-node-3.6.1-1.0.el7ev.noarch
ovirt-node-plugin-hosted-engine-0.3.0-5.el7ev.noarch
rhev-m appliance: rhevm-appliance-20151228.0-2


How reproducible:
100%

Steps to Reproduce:
1.TUI install rhev-hypervisor7-7.2-20151229.0 
2. Setup Hosted Engine
3. login engine, setup engine with below cmd
#engine-setup --offline --config-append=ovirt-engine-answers


Actual results:
Failed to setup engine via OVA

Expected results:
Setup engine via OVA can succeed.

Additional info:
No such issue with 20151216.0-1.3.6.ova, so it is a regression bug.

Comment 1 Yedidyah Bar David 2015-12-30 12:49:18 UTC
This failure is a result of using rhevm-setup-plugins-3.6.1, which includes [1], with an engine that was build without [2].

We should build an engine that includes [2], and then build an appliance that includes both.

[1] https://code.engineering.redhat.com/gerrit/64443
[2] https://gerrit.ovirt.org/#/q/I5e7b5885e2b600b49e2c0a97392bc6c640901033

Comment 3 Yedidyah Bar David 2016-01-03 12:41:11 UTC
*** Bug 1295192 has been marked as a duplicate of this bug. ***

Comment 4 Fabian Deutsch 2016-01-04 11:00:40 UTC
According to comment 1 a package is missing. The newer package will be picked up on a new build.

Tolik, can you check if the most recetn 3.6.1 build contains a package higher than the one in comment 1?

Comment 5 Anatoly Litovsky 2016-01-04 12:49:31 UTC
The rhevm-appliance already has the latest brew package 
rhevm-setup-plugins-3.6.1-1.el6ev.noarch

We need a new build with the mentioned patch in comment 1

Comment 6 Yedidyah Bar David 2016-01-04 13:08:48 UTC
Setting needinfo on Eyal, not sure who builds the engine and where this is tracked/managed. I hope this happens before Sandro is back, or we'll have to wait another week.

Comment 8 Eyal Edri 2016-01-04 15:16:11 UTC
why move to ASSIGNED if the fix is merged?
a full build including engine is planned for tomorrow.

Comment 9 Eyal Edri 2016-01-04 15:16:56 UTC
of sorry, this is an appliance bug, so it will move to modified after rebuilding with tomorrow engine?

Comment 10 Anatoly Litovsky 2016-01-05 10:09:24 UTC
the build of plugins is not part of your engine build .
Or does it ?

Comment 11 Yedidyah Bar David 2016-01-05 10:18:30 UTC
(In reply to Anatoly Litovsky from comment #10)
> the build of plugins is not part of your engine build .
> Or does it ?

You mean rhevm-setup-plugins? Not part of engine, that's a different package. Already built on brew a week ago, that was your problem :-( I somehow understood that engine will be built the same day but it wasn't.

Comment 12 wanghui 2016-01-08 06:26:06 UTC
Still encounter this issue in rhevm-appliance-20150107.0-1(rhevm-setup-plugins-3.6.1-1.el6ev.noarch).

# engine-setup --offline --config-append=ovirt-engine-answers
[ INFO  ] Stage: Initializing
[ ERROR ] Failed to execute stage 'Initializing': type object 'RPMDistroEnv' has no attribute 'ADDITIONAL_PACKAGES'
[ INFO  ] Stage: Clean up
          Log file is located at /var/log/ovirt-engine/setup/ovirt-engine-setup-20160108012330-3r9hkd.log
[ ERROR ] Failed to execute stage 'Clean up': 'NoneType' object has no attribute 'cleanup'
[ INFO  ] Generating answer file '/var/lib/ovirt-engine/setup/answers/20160108012330-setup.conf'
[ INFO  ] Stage: Pre-termination
[ INFO  ] Stage: Termination
[ ERROR ] Execution of setup failed

Comment 13 Fabian Deutsch 2016-01-13 10:35:48 UTC
Sandro, can't set rhevm-setup-plugins set the correct Requires in the spec to ensure that the correct engine is pulled in?

Comment 14 Fabian Deutsch 2016-01-13 10:36:52 UTC
Moving to ASSIGNED until this is clarified

Comment 15 Yedidyah Bar David 2016-01-13 10:53:31 UTC
(In reply to Fabian Deutsch from comment #13)
> Sandro, can't set rhevm-setup-plugins set the correct Requires in the spec
> to ensure that the correct engine is pulled in?

Isn't that exactly change 65356? I might be missing something.

Comment 16 Fabian Deutsch 2016-01-13 11:15:44 UTC
Yes, that can well be.

Comment 17 Sandro Bonazzola 2016-01-21 13:15:22 UTC
Why this is this still in assigned? Am I missing something? IMHO this should be on qa.

Comment 18 Nikolai Sednev 2016-01-24 14:34:19 UTC
(In reply to Sandro Bonazzola from comment #17)
> Why this is this still in assigned? Am I missing something? IMHO this should
> be on qa.

It's not fixed, I've just installed the latest rhev-release-3.6.2-10-001.noarch.rpm and got rhevm-appliance.noarch              20150107.0-1.el7ev      @rhev-3.6.2-10  from the repositories, then failed on HE-deployment.

Last appliance that worked for me was rhevm-appliance-20151216.0-1.x86_64.rhevm.ova.

Returning to assigned. Please fill in the "Fixed In Version:" field accordingly. 	

20**FILTERED**6-0**FILTERED**-24 09:**FILTERED**4:3**FILTERED** DEBUG otopi.context context._executeMethod:**FILTERED**56 method exception
Traceback (most recent call last):
  File "/usr/lib/python2.6/site-packages/otopi/context.py", line **FILTERED**46, in _executeMethod
    method['method']()
  File "/usr/share/ovirt-engine/setup/bin/../plugins/ovirt-engine-setup/rhevm-setup-plugins/distro-rhel/additional_packages.py", line 43, in _init
    ] = rhevmcons.Const.RHEVM_ADDITIONAL_PACKAGES
AttributeError: type object 'RPMDistroEnv' has no attribute 'ADDITIONAL_PACKAGES'
20**FILTERED**6-0**FILTERED**-24 09:**FILTERED**4:3**FILTERED** ERROR otopi.context context._executeMethod:**FILTERED**65 Failed to execute stage 'Initializing': type object 'RPMDistroEnv' has no attribute 'ADDITIONAL_PACKAGES'
20**FILTERED**6-0**FILTERED**-24 09:**FILTERED**4:3**FILTERED** DEBUG otopi.context context.dumpEnvironment:500 ENVIRONMENT DUMP - BEGIN
20**FILTERED**6-0**FILTERED**-24 09:**FILTERED**4:3**FILTERED** DEBUG otopi.context context.dumpEnvironment:5**FILTERED**0 ENV BASE/error=bool:'True'
20**FILTERED**6-0**FILTERED**-24 09:**FILTERED**4:3**FILTERED** DEBUG otopi.context context.dumpEnvironment:5**FILTERED**0 ENV BASE/exceptionInfo=list:'[(<type 'exceptions.AttributeError'>, AttributeError("type object 'RPMDistroEnv' has no attribute 'ADDITIONAL_PACKAGES'",), <traceback object at 0x2cbf248>)]'
20**FILTERED**6-0**FILTERED**-24 09:**FILTERED**4:3**FILTERED** DEBUG otopi.context context.dumpEnvironment:5**FILTERED**4 ENVIRONMENT DUMP - END
20**FILTERED**6-0**FILTERED**-24 09:**FILTERED**4:3**FILTERED** DEBUG otopi.context context._executeMethod:**FILTERED**42 Stage init METHOD otopi.plugins.ovirt_engine_setup.rhevm_setup_plugins.distro-rhel.image_upload.Plugin._init
20**FILTERED**6-0**FILTERED**-24 09:**FILTERED**4:3**FILTERED** DEBUG otopi.context context._executeMethod:**FILTERED**42 Stage init METHOD otopi.plugins.ovirt_engine_setup.rhevm_setup_plugins.distro-rhel.public_glance_repository.Plugin._init
20**FILTERED**6-0**FILTERED**-24 09:**FILTERED**4:3**FILTERED** DEBUG otopi.context context.dumpEnvironment:500 ENVIRONMENT DUMP - BEGIN

Comment 19 Nikolai Sednev 2016-01-24 14:39:31 UTC
[ INFO  ] Running engine-setup on the appliance
          |- [ INFO  ] Stage: Initializing
          |- [ ERROR ] Failed to execute stage 'Initializing': type object 'RPMDistroEnv' has no attribute 'ADDITIONAL_PACKAGES'
          |- [ INFO  ] Stage: Clean up
          |-           Log file is located at /var/log/ovirt-engine/setup/ovirt-engine-setup-20160121131654-aixtov.log
          |- [ ERROR ] Failed to execute stage 'Clean up': 'NoneType' object has no attribute 'cleanup'
          |- [ INFO  ] Generating answer file '/var/lib/ovirt-engine/setup/answers/20160121131654-setup.conf'
          |- [ INFO  ] Stage: Pre-termination
          |- [ INFO  ] Stage: Termination
          |- [ ERROR ] Execution of setup failed
          |- HE_APPLIANCE_ENGINE_SETUP_FAIL
[ ERROR ] Engine setup failed on the appliance
[ ERROR ] Failed to execute stage 'Closing up': Engine setup failed on the appliance Please check its log on the appliance. 
[ INFO  ] Stage: Clean up
[ INFO  ] Generating answer file '/var/lib/ovirt-hosted-engine-setup/answers/answers-20160121201659.conf'
[ INFO  ] Stage: Pre-termination
[ INFO  ] Stage: Termination
[ ERROR ] Hosted Engine deployment failed: this system is not reliable, please check the issue, fix and redeploy
          Log file is located at /var/log/ovirt-hosted-engine-setup/ovirt-hosted-engine-setup-20160121200447-yi9gwv.log

Comment 20 Eyal Edri 2016-01-24 14:48:09 UTC
Nikolai,
Since the appliance is always built async and not released as part of the whole release, it won't appear in the release rpm, and you'll need to install it manually from the link supplied in the release email from appliance.

This will be fixed hopefully once the appliance build is automated.

Comment 22 Yedidyah Bar David 2016-01-24 14:56:26 UTC
(In reply to Eyal Edri from comment #20)
> Nikolai,
> Since the appliance is always built async and not released as part of the
> whole release, it won't appear in the release rpm, and you'll need to
> install it manually from the link supplied in the release email from
> appliance.

But bob does have [1] the package Nikolai installed. Note that there's something weird about it - its version is 20150107.0 and not 20160107.0 as one might expect. It was build on brew [2] on 2016-01-07. Latest on brew [3] was built on 2016-01-20. Not sure what caused [2] to be named with 2015, but I think bob should have [3].

[1] http://bob.eng.lab.tlv.redhat.com/builds/latest_3.6/el7/noarch/
[2] https://brewweb.devel.redhat.com/rpminfo?rpmID=4104968
[3] https://brewweb.devel.redhat.com/rpminfo?rpmID=4132528

Comment 23 Eyal Edri 2016-01-24 15:00:11 UTC
Exactly my point, he shouldn't install the appliance or RHEVH from bob (i.e from the release rpm),
because the repo is created before appliance/rhevh is built.

Because we can't delay the release and wait for these async pkg, they are by design not updated in the bob repo.

Only if we'll respin for any reason, we'll pick them up for the repo.

Comment 24 Nikolai Sednev 2016-01-25 15:50:03 UTC
I've got HE-VM installed on Red Hat Enterprise Virtualization Hypervisor (Beta) release 7.2 (20160113.0.el7ev) with rhevm-appliance-20160120.0-1 taken manually during TUI HE-deployment. iSCSI HE's SD was not auto-imported, but data SD was successfully added and I've created working guest VM for farther tasks. HE-deployment finished successfully, although HE-SD was not auto-imported.

For more details see the https://bugzilla.redhat.com/show_bug.cgi?id=1293928

Engine:
rhevm-3.6.2.6-0.1.el6.noarch

Host:
rhevm-sdk-python-3.6.2.1-1.el7ev.noarch
sanlock-3.2.4-1.el7.x86_64
libvirt-client-1.2.17-13.el7_2.2.x86_64
mom-0.5.1-1.el7ev.noarch
vdsm-4.17.17-0.el7ev.noarch

Comment 25 Nikolai Sednev 2016-01-25 15:50:50 UTC
Host was Red Hat Enterprise Virtualization Hypervisor (Beta) release 7.2 (20160113.0.el7ev).

Comment 26 Nikolai Sednev 2016-01-25 15:53:25 UTC
Works on rhevm-appliance-20160120.0-1.x86_64.rhevm.ova

Comment 28 errata-xmlrpc 2016-03-09 21:44:49 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:0385


Note You need to log in before you can comment on or make changes to this bug.