Bug 1294826 - Speed up regression tests
Summary: Speed up regression tests
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: GlusterFS
Classification: Community
Component: tests
Version: mainline
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Raghavendra Talur
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: 1314680
TreeView+ depends on / blocked
 
Reported: 2015-12-30 14:07 UTC by Raghavendra Talur
Modified: 2018-08-29 03:53 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 1314680 (view as bug list)
Environment:
Last Closed: 2018-08-29 03:53:51 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Raghavendra Talur 2015-12-30 14:07:13 UTC
Description of problem:

Gluster regression tests currently takes 3 hours for complete run.
It is possible to reduce it if 
a. unwanted commands are removed
b. multiple .t files are merged if they belong to same functional test.


and so on..

Use this bug for any such test improvements.

Comment 1 Vijay Bellur 2015-12-30 15:39:56 UTC
REVIEW: http://review.gluster.org/13121 (tests: use SIGKILL in cleanup, not SIGTERM) posted (#1) for review on master by Raghavendra Talur (rtalur@redhat.com)

Comment 2 Vijay Bellur 2015-12-30 16:50:11 UTC
REVIEW: http://review.gluster.org/13122 (tests: remove redundant test lines) posted (#1) for review on master by Raghavendra Talur (rtalur@redhat.com)

Comment 3 Vijay Bellur 2016-01-08 07:38:45 UTC
COMMIT: http://review.gluster.org/13121 committed in master by Raghavendra Talur (rtalur@redhat.com) 
------
commit 6019e988a3ec40fb78127dce577be125ac23af98
Author: Raghavendra Talur <rtalur@redhat.com>
Date:   Wed Dec 30 21:07:54 2015 +0530

    tests: use SIGKILL in cleanup, not SIGTERM
    
    Sending a SIGTERM to test processes and waiting
    a second for them to gracefully exit before
    sending a SIGKILL seems like a waste of time.
    
    Just send SIGKILL directly.
    
    Change-Id: Icc73b07eae47876ba41955793a8daf77a964a0e0
    BUG: 1294826
    Signed-off-by: Raghavendra Talur <rtalur@redhat.com>
    Reviewed-on: http://review.gluster.org/13121
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Atin Mukherjee <amukherj@redhat.com>

Comment 4 Vijay Bellur 2016-01-11 13:21:17 UTC
REVIEW: http://review.gluster.org/13216 (tests/quota : improving tests for quota) posted (#1) for review on master by Manikandan Selvaganesh (mselvaga@redhat.com)

Comment 5 Vijay Bellur 2016-01-12 12:16:46 UTC
REVIEW: http://review.gluster.org/13216 (tests/quota : improving tests for quota) posted (#2) for review on master by Manikandan Selvaganesh (mselvaga@redhat.com)

Comment 6 Vijay Bellur 2016-01-25 06:45:06 UTC
REVIEW: http://review.gluster.org/13216 (tests/quota : improving tests for quota) posted (#3) for review on master by Manikandan Selvaganesh (mselvaga@redhat.com)

Comment 7 Vijay Bellur 2016-01-27 13:15:09 UTC
REVIEW: http://review.gluster.org/13216 (tests/quota : improving tests for quota) posted (#4) for review on master by Manikandan Selvaganesh (mselvaga@redhat.com)

Comment 8 Vijay Bellur 2016-01-27 19:33:31 UTC
REVIEW: http://review.gluster.org/13216 (tests/quota : improving tests for quota) posted (#5) for review on master by Manikandan Selvaganesh (mselvaga@redhat.com)

Comment 9 Vijay Bellur 2016-01-28 05:35:07 UTC
REVIEW: http://review.gluster.org/13216 (tests/quota : improving tests for quota) posted (#6) for review on master by Manikandan Selvaganesh (mselvaga@redhat.com)

Comment 10 Vijay Bellur 2016-02-01 10:43:55 UTC
REVIEW: http://review.gluster.org/13216 (tests/quota : improving tests for quota) posted (#7) for review on master by Manikandan Selvaganesh (mselvaga@redhat.com)

Comment 11 Vijay Bellur 2016-02-03 04:53:42 UTC
REVIEW: http://review.gluster.org/13216 (tests/quota : improving tests for quota) posted (#8) for review on master by Manikandan Selvaganesh (mselvaga@redhat.com)

Comment 12 Vijay Bellur 2016-02-03 11:20:28 UTC
REVIEW: http://review.gluster.org/13216 (tests/quota : improving tests for quota) posted (#9) for review on master by Manikandan Selvaganesh (mselvaga@redhat.com)

Comment 13 Vijay Bellur 2016-02-04 16:04:27 UTC
REVIEW: http://review.gluster.org/13216 (tests/quota : improving tests for quota) posted (#10) for review on master by Manikandan Selvaganesh (mselvaga@redhat.com)

Comment 14 Vijay Bellur 2016-02-04 16:07:32 UTC
REVIEW: http://review.gluster.org/13216 (tests/quota : improving tests for quota) posted (#11) for review on master by Manikandan Selvaganesh (mselvaga@redhat.com)

Comment 15 Vijay Bellur 2016-02-08 09:01:51 UTC
REVIEW: http://review.gluster.org/13122 (tests: remove redundant test lines) posted (#2) for review on master by Raghavendra Talur (rtalur@redhat.com)

Comment 16 Vijay Bellur 2016-02-22 05:50:11 UTC
REVIEW: http://review.gluster.org/13216 (tests/quota : improving tests for quota) posted (#12) for review on master by Manikandan Selvaganesh (mselvaga@redhat.com)

Comment 17 Vijay Bellur 2016-03-02 07:04:35 UTC
REVIEW: http://review.gluster.org/13216 (tests/quota : improving tests for quota) posted (#13) for review on master by Manikandan Selvaganesh (mselvaga@redhat.com)

Comment 18 Vijay Bellur 2016-03-02 09:02:40 UTC
REVIEW: http://review.gluster.org/13216 (tests/quota : improving tests for quota) posted (#14) for review on master by Manikandan Selvaganesh (mselvaga@redhat.com)

Comment 19 Vijay Bellur 2016-03-02 12:08:46 UTC
REVIEW: http://review.gluster.org/13216 (tests/quota : improving tests for quota) posted (#15) for review on master by Manikandan Selvaganesh (mselvaga@redhat.com)

Comment 20 Vijay Bellur 2016-03-03 11:52:47 UTC
COMMIT: http://review.gluster.org/13216 committed in master by Jeff Darcy (jdarcy@redhat.com) 
------
commit 15be1c1a00089ad4d9de18f1351c17d067949b61
Author: Manikandan Selvaganesh <mselvaga@redhat.com>
Date:   Tue Jan 12 16:58:57 2016 +0530

    tests/quota : improving tests for quota
    
    tests/basic/quota.t includes all the basic test that
    needs to be tested for quota. In most of the other
    tests specific to bugs(tests/bugs/quota/*), tests
    such as creating and starting volume, enabling quota,
    setting limit, writing data, doing list have been done
    which is essential to write a individual quota test
    file, but, if the specific bug just needs to test
    *few* particular cases, I have moved those tests
    under tests/basic itself to speedup the regressions.
    
    Basics of inode-quota and it's enforcing, renaming
    with quota are basic tests and is hence moved under
    tests/basic folder.
    
    In other files, I have removed tests which are not
    needed, such as 'pidof glusterd' or checking for
    'gluster volume info' or if there are any test which
    is already being tested under tests/basic and is being
    written again.
    
    Change-Id: Iefd6d9529246d59829cc5bf02687a1861d8462a8
    BUG: 1294826
    Signed-off-by: Manikandan Selvaganesh <mselvaga@redhat.com>
    Reviewed-on: http://review.gluster.org/13216
    Smoke: Gluster Build System <jenkins@build.gluster.com>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Vijaikumar Mallikarjuna <vmallika@redhat.com>
    Reviewed-by: Jeff Darcy <jdarcy@redhat.com>

Comment 21 Amar Tumballi 2018-08-29 03:53:51 UTC
Lot of time since no activity on this bug. We have either fixed it already or it is mostly not critical anymore!

Please re-open the bug if the issue is burning for you, or you want to take the bug to closure with fixes.


Note You need to log in before you can comment on or make changes to this bug.