Bug 1314680 - Speed up regression tests
Speed up regression tests
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: tests (Show other bugs)
3.7.9
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Raghavendra Talur
: Tracking, Triaged
Depends On: 1294826
Blocks:
  Show dependency treegraph
 
Reported: 2016-03-04 03:49 EST by Manikandan
Modified: 2016-09-20 00:28 EDT (History)
4 users (show)

See Also:
Fixed In Version: glusterfs-3.7.9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1294826
Environment:
Last Closed: 2016-04-19 03:20:19 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Manikandan 2016-03-04 03:49:45 EST
+++ This bug was initially created as a clone of Bug #1294826 +++

Description of problem:

Gluster regression tests currently takes 3 hours for complete run.
It is possible to reduce it if 
a. unwanted commands are removed
b. multiple .t files are merged if they belong to same functional test.


and so on..

Use this bug for any such test improvements.

--- Additional comment from Vijay Bellur on 2015-12-30 10:39:56 EST ---

REVIEW: http://review.gluster.org/13121 (tests: use SIGKILL in cleanup, not SIGTERM) posted (#1) for review on master by Raghavendra Talur (rtalur@redhat.com)

--- Additional comment from Vijay Bellur on 2015-12-30 11:50:11 EST ---

REVIEW: http://review.gluster.org/13122 (tests: remove redundant test lines) posted (#1) for review on master by Raghavendra Talur (rtalur@redhat.com)

--- Additional comment from Vijay Bellur on 2016-01-08 02:38:45 EST ---

COMMIT: http://review.gluster.org/13121 committed in master by Raghavendra Talur (rtalur@redhat.com) 
------
commit 6019e988a3ec40fb78127dce577be125ac23af98
Author: Raghavendra Talur <rtalur@redhat.com>
Date:   Wed Dec 30 21:07:54 2015 +0530

    tests: use SIGKILL in cleanup, not SIGTERM
    
    Sending a SIGTERM to test processes and waiting
    a second for them to gracefully exit before
    sending a SIGKILL seems like a waste of time.
    
    Just send SIGKILL directly.
    
    Change-Id: Icc73b07eae47876ba41955793a8daf77a964a0e0
    BUG: 1294826
    Signed-off-by: Raghavendra Talur <rtalur@redhat.com>
    Reviewed-on: http://review.gluster.org/13121
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Atin Mukherjee <amukherj@redhat.com>

--- Additional comment from Vijay Bellur on 2016-01-11 08:21:17 EST ---

REVIEW: http://review.gluster.org/13216 (tests/quota : improving tests for quota) posted (#1) for review on master by Manikandan Selvaganesh (mselvaga@redhat.com)

--- Additional comment from Vijay Bellur on 2016-01-12 07:16:46 EST ---

REVIEW: http://review.gluster.org/13216 (tests/quota : improving tests for quota) posted (#2) for review on master by Manikandan Selvaganesh (mselvaga@redhat.com)

--- Additional comment from Vijay Bellur on 2016-01-25 01:45:06 EST ---

REVIEW: http://review.gluster.org/13216 (tests/quota : improving tests for quota) posted (#3) for review on master by Manikandan Selvaganesh (mselvaga@redhat.com)

--- Additional comment from Vijay Bellur on 2016-01-27 08:15:09 EST ---

REVIEW: http://review.gluster.org/13216 (tests/quota : improving tests for quota) posted (#4) for review on master by Manikandan Selvaganesh (mselvaga@redhat.com)

--- Additional comment from Vijay Bellur on 2016-01-27 14:33:31 EST ---

REVIEW: http://review.gluster.org/13216 (tests/quota : improving tests for quota) posted (#5) for review on master by Manikandan Selvaganesh (mselvaga@redhat.com)

--- Additional comment from Vijay Bellur on 2016-01-28 00:35:07 EST ---

REVIEW: http://review.gluster.org/13216 (tests/quota : improving tests for quota) posted (#6) for review on master by Manikandan Selvaganesh (mselvaga@redhat.com)

--- Additional comment from Vijay Bellur on 2016-02-01 05:43:55 EST ---

REVIEW: http://review.gluster.org/13216 (tests/quota : improving tests for quota) posted (#7) for review on master by Manikandan Selvaganesh (mselvaga@redhat.com)

--- Additional comment from Vijay Bellur on 2016-02-02 23:53:42 EST ---

REVIEW: http://review.gluster.org/13216 (tests/quota : improving tests for quota) posted (#8) for review on master by Manikandan Selvaganesh (mselvaga@redhat.com)

--- Additional comment from Vijay Bellur on 2016-02-03 06:20:28 EST ---

REVIEW: http://review.gluster.org/13216 (tests/quota : improving tests for quota) posted (#9) for review on master by Manikandan Selvaganesh (mselvaga@redhat.com)

--- Additional comment from Vijay Bellur on 2016-02-04 11:04:27 EST ---

REVIEW: http://review.gluster.org/13216 (tests/quota : improving tests for quota) posted (#10) for review on master by Manikandan Selvaganesh (mselvaga@redhat.com)

--- Additional comment from Vijay Bellur on 2016-02-04 11:07:32 EST ---

REVIEW: http://review.gluster.org/13216 (tests/quota : improving tests for quota) posted (#11) for review on master by Manikandan Selvaganesh (mselvaga@redhat.com)

--- Additional comment from Vijay Bellur on 2016-02-08 04:01:51 EST ---

REVIEW: http://review.gluster.org/13122 (tests: remove redundant test lines) posted (#2) for review on master by Raghavendra Talur (rtalur@redhat.com)

--- Additional comment from Vijay Bellur on 2016-02-22 00:50:11 EST ---

REVIEW: http://review.gluster.org/13216 (tests/quota : improving tests for quota) posted (#12) for review on master by Manikandan Selvaganesh (mselvaga@redhat.com)

--- Additional comment from Vijay Bellur on 2016-03-02 02:04:35 EST ---

REVIEW: http://review.gluster.org/13216 (tests/quota : improving tests for quota) posted (#13) for review on master by Manikandan Selvaganesh (mselvaga@redhat.com)

--- Additional comment from Vijay Bellur on 2016-03-02 04:02:40 EST ---

REVIEW: http://review.gluster.org/13216 (tests/quota : improving tests for quota) posted (#14) for review on master by Manikandan Selvaganesh (mselvaga@redhat.com)

--- Additional comment from Vijay Bellur on 2016-03-02 07:08:46 EST ---

REVIEW: http://review.gluster.org/13216 (tests/quota : improving tests for quota) posted (#15) for review on master by Manikandan Selvaganesh (mselvaga@redhat.com)

--- Additional comment from Vijay Bellur on 2016-03-03 06:52:47 EST ---

COMMIT: http://review.gluster.org/13216 committed in master by Jeff Darcy (jdarcy@redhat.com) 
------
commit 15be1c1a00089ad4d9de18f1351c17d067949b61
Author: Manikandan Selvaganesh <mselvaga@redhat.com>
Date:   Tue Jan 12 16:58:57 2016 +0530

    tests/quota : improving tests for quota
    
    tests/basic/quota.t includes all the basic test that
    needs to be tested for quota. In most of the other
    tests specific to bugs(tests/bugs/quota/*), tests
    such as creating and starting volume, enabling quota,
    setting limit, writing data, doing list have been done
    which is essential to write a individual quota test
    file, but, if the specific bug just needs to test
    *few* particular cases, I have moved those tests
    under tests/basic itself to speedup the regressions.
    
    Basics of inode-quota and it's enforcing, renaming
    with quota are basic tests and is hence moved under
    tests/basic folder.
    
    In other files, I have removed tests which are not
    needed, such as 'pidof glusterd' or checking for
    'gluster volume info' or if there are any test which
    is already being tested under tests/basic and is being
    written again.
    
    Change-Id: Iefd6d9529246d59829cc5bf02687a1861d8462a8
    BUG: 1294826
    Signed-off-by: Manikandan Selvaganesh <mselvaga@redhat.com>
    Reviewed-on: http://review.gluster.org/13216
    Smoke: Gluster Build System <jenkins@build.gluster.com>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Vijaikumar Mallikarjuna <vmallika@redhat.com>
    Reviewed-by: Jeff Darcy <jdarcy@redhat.com>
Comment 1 Vijay Bellur 2016-03-04 04:12:59 EST
REVIEW: http://review.gluster.org/13606 (tests/quota : improving tests for quota) posted (#1) for review on release-3.7 by Manikandan Selvaganesh (mselvaga@redhat.com)
Comment 2 Vijay Bellur 2016-03-15 05:48:18 EDT
COMMIT: http://review.gluster.org/13606 committed in release-3.7 by Vijaikumar Mallikarjuna (vmallika@redhat.com) 
------
commit 16a535753c4e5ef8b579d3758a5f709c19fb9592
Author: Manikandan Selvaganesh <mselvaga@redhat.com>
Date:   Tue Jan 12 16:58:57 2016 +0530

    tests/quota : improving tests for quota
    
    tests/basic/quota.t includes all the basic test that
    needs to be tested for quota. In most of the other
    tests specific to bugs(tests/bugs/quota/*), tests
    such as creating and starting volume, enabling quota,
    setting limit, writing data, doing list have been done
    which is essential to write a individual quota test
    file, but, if the specific bug just needs to test
    *few* particular cases, I have moved those tests
    under tests/basic itself to speedup the regressions.
    
    Basics of inode-quota and it's enforcing, renaming
    with quota are basic tests and is hence moved under
    tests/basic folder.
    
    In other files, I have removed tests which are not
    needed, such as 'pidof glusterd' or checking for
    'gluster volume info' or if there are any test which
    is already being tested under tests/basic and is being
    written again.
    
            Backport of http://review.gluster.org/#/c/13216/
    
    > Change-Id: Iefd6d9529246d59829cc5bf02687a1861d8462a8
    > BUG: 1294826
    > Signed-off-by: Manikandan Selvaganesh <mselvaga@redhat.com>
    > Reviewed-on: http://review.gluster.org/13216
    > Smoke: Gluster Build System <jenkins@build.gluster.com>
    > NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    > CentOS-regression: Gluster Build System <jenkins@build.gluster.com>
    > Reviewed-by: Vijaikumar Mallikarjuna <vmallika@redhat.com>
    > Reviewed-by: Jeff Darcy <jdarcy@redhat.com>
    
    Change-Id: Iefd6d9529246d59829cc5bf02687a1861d8462a8
    BUG: 1314680
    Signed-off-by: Manikandan Selvaganesh <mselvaga@redhat.com>
    Reviewed-on: http://review.gluster.org/13606
    Smoke: Gluster Build System <jenkins@build.gluster.com>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.com>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    Reviewed-by: Vijaikumar Mallikarjuna <vmallika@redhat.com>
Comment 3 Kaushal 2016-04-19 03:20:19 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.9, please open a new bug report.

glusterfs-3.7.9 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] https://www.gluster.org/pipermail/gluster-users/2016-March/025922.html
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.