Bug 1294884 - Support for Virt-FS (via NFS + virtio-vsock) (libvirt)
Summary: Support for Virt-FS (via NFS + virtio-vsock) (libvirt)
Keywords:
Status: CLOSED DEFERRED
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: libvirt
Version: 7.3
Hardware: All
OS: Linux
high
high
Target Milestone: rc
: 7.7
Assignee: Ján Tomko
QA Contact: yafu
URL:
Whiteboard:
: 1338715 (view as bug list)
Depends On: 1291286 1294880 1378137 1518996 1291282 1291284 1291851 1294879 1315822 1382695 1518995
Blocks: 1363787 1553272 1563290 1577865 1518997
TreeView+ depends on / blocked
 
Reported: 2015-12-30 19:46 UTC by Ademar Reis
Modified: 2018-12-04 17:01 UTC (History)
17 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1294879
: 1518997 (view as bug list)
Environment:
Last Closed: 2018-12-03 16:35:54 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
IBM Linux Technology Center 148080 None None None 2019-08-07 03:39:08 UTC
Red Hat Bugzilla 1291286 None ASSIGNED NFS client support for virtio-vsock 2019-08-07 03:39:12 UTC
Red Hat Bugzilla 1294880 None None None 2019-08-07 03:39:12 UTC
Red Hat Bugzilla 1519459 None ASSIGNED RFE: Virt-FS support (exporting directories from host to guest) (libvirt) 2019-08-07 03:39:12 UTC

Internal Links: 1291286 1294880 1519459

Description Ademar Reis 2015-12-30 19:46:06 UTC
Once we have support for virtio-sock everywhere (QEMU, Kernel and NFS), libvirt will have to provide some mechanism for a Virt-FS feature, where a folder gets shared between host and guest.

+++ This bug was initially created as a clone of Bug #1294879 +++

We'we working on virtio-vsock in QEMU/KVM, which implements a host/guest communication device, allowing applications from both sides to communicate without the need of a network. It implements the POSIX Sockets API and supports both SOCK_STREAM and SOCK_DGRAM.

For virtio-vsock support in QEMU/kernel, see bug 1291282 and bug 1291284.

Once virtio-vsock is implemented, we want NFS (both server and client) to support it so that we can use it to share directories between the host and the guest, a feature we call "Virt-FS".

Comment 2 Stefan Hajnoczi 2016-09-21 15:05:52 UTC
*** Bug 1338715 has been marked as a duplicate of this bug. ***

Comment 4 IBM Bug Proxy 2017-06-19 19:21:20 UTC
------- Comment From lagarcia@br.ibm.com 2017-06-19 15:17 EDT-------
Is this on track for RHEL 7.4?

Comment 5 Ademar Reis 2017-06-19 23:41:54 UTC
(In reply to IBM Bug Proxy from comment #4)
> ------- Comment From lagarcia@br.ibm.com 2017-06-19 15:17 EDT-------
> Is this on track for RHEL 7.4?

Unfortunately not. We're still working on upstream support for virtio-vsock in NFS and the complete feature has been deferred to a future release of RHEL or layered products.

Comment 11 IBM Bug Proxy 2018-03-23 14:21:25 UTC
------- Comment From lagarcia@br.ibm.com 2018-03-23 10:20 EDT-------
Ademar,

Is this on track for RHEL 7.5?

Comment 12 Ademar Reis 2018-03-23 15:00:21 UTC
(In reply to IBM Bug Proxy from comment #11)
> ------- Comment From lagarcia@br.ibm.com 2018-03-23 10:20 EDT-------
> Ademar,
> 
> Is this on track for RHEL 7.5?

Unfortunately not. We couldn't get upstream NFS to accept vsock support yet, so this is still in progress. We had to submit a IETF RFC to get it accepted as a standard and that process takes time. Even RHEL-7.6 is a stretch target.

Comment 13 Ademar Reis 2018-12-03 16:35:54 UTC
Will not be implemented in RHEL-7.

For sometime in RHEL-8, we're planning a different approach, using virtio-fs. This is being tracked via Bug 1519458 and Bug 1519459.

Comment 14 IBM Bug Proxy 2018-12-04 08:00:25 UTC
------- Comment From KURZGREG@fr.ibm.com 2018-12-04 02:56 EDT-------
(In reply to comment #16)
> Will not be implemented in RHEL-7.
> For sometime in RHEL-8, we're planning a different approach, using
> virtio-fs. This is being tracked via Bug 1519458 and Bug 1519459.

Access to these BZs is denied, and they don't seem to have been mirrored to IBM's BZ.

Please provide access. My login in RH's BZ is gkurz@linux.vnet.ibm.com.

Comment 15 Ján Tomko 2018-12-04 14:27:05 UTC
I made bug 1519459 public since it does not contain any different information than this one.

Comment 16 Ademar Reis 2018-12-04 17:01:50 UTC
(In reply to Ján Tomko from comment #15)
> I made bug 1519459 public since it does not contain any different
> information than this one.

Ditto for Bug 1519458.


Note You need to log in before you can comment on or make changes to this bug.