Bug 1315822 - [RFE 7.4] support for virtio-vsock - qemu-kvm
[RFE 7.4] support for virtio-vsock - qemu-kvm
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: qemu-kvm (Show other bugs)
7.3
Unspecified Unspecified
high Severity high
: rc
: ---
Assigned To: Stefan Hajnoczi
FuXiangChun
: FutureFeature
Depends On: 1378137 1291282 1291284 1382695
Blocks: 1291286 1291851 1294880 1294884 1518995 1518996 1518997 1294879
  Show dependency treegraph
 
Reported: 2016-03-08 12:18 EST by Ademar Reis
Modified: 2017-11-29 17:37 EST (History)
17 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of: 1291284
Environment:
Last Closed: 2017-11-29 10:24:49 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ademar Reis 2016-03-08 12:18:57 EST
This is the clone for qemu-kvm (RHEL version, not qemu-kvm-rhev). 

+++ This bug was initially created as a clone of Bug #1291284 +++

Description of problem:

To enable VSOCK support in 7.3, we will need the userspace qemu changes that correspond to the kernel changes in https://bugzilla.redhat.com/show_bug.cgi?id=1291282

These are currently a work in progress[1] but should be picked from upstream qemu when merged.

1. https://github.com/stefanha/qemu/tree/vsock
Comment 2 Ademar Reis 2016-03-15 10:23:01 EDT
Removing Bug 1308609 from the blockers list. As this particular BZ is for qemu-kvm (RHEL), not qemu-kvm-rhev (layered products).
Comment 3 Stefan Hajnoczi 2017-01-16 11:22:53 EST
Investigating backport.
Comment 4 Ian Colle 2017-05-16 15:44:47 EDT
What did your backport investigation turn up?
Comment 5 Stefan Hajnoczi 2017-05-19 10:33:46 EDT
This BZ was postponed to RHEL 7.5.  I will do the backport at that time.
Comment 6 Stefan Hajnoczi 2017-11-29 10:24:49 EST
virtio-vsock is a qemu-kvm-rhev feature.  It will not be in qemu-kvm in RHEL 7.5.

Note You need to log in before you can comment on or make changes to this bug.