Bug 1295179 - It's not possible to overwrite a default value of a parameter inherited from parent host group in nested host group [NEEDINFO]
It's not possible to overwrite a default value of a parameter inherited from ...
Status: CLOSED ERRATA
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Host Group (Show other bugs)
6.0.4
Unspecified Unspecified
unspecified Severity medium (vote)
: Beta
: --
Assigned To: Ohad Levy
Kedar Bidarkar
http://projects.theforeman.org/issues...
: Triaged
Depends On:
Blocks: 1314392
  Show dependency treegraph
 
Reported: 2016-01-03 04:43 EST by orabin
Modified: 2016-07-27 05:00 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1314392 (view as bug list)
Environment:
Last Closed: 2016-07-27 05:00:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
mruzicka: needinfo? (tcaspy)


Attachments (Terms of Use)
global params can now be overriden (54.72 KB, image/png)
2016-04-12 12:07 EDT, Kedar Bidarkar
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 2111361 None None None 2016-01-04 09:22 EST

  None (edit)
Description orabin 2016-01-03 04:43:13 EST
1 - create a new host group named 'parent' with global parameter named 'parameter1' with value 'parentValue'
2 - create a new host group named 'child' and set Parent to host group created in step 1. and change value of 'parameter1' to 'changed'

Result:
Value of 'parameter1' in 'child' host group is still 'parentValue'
Value of 'parameter1' in 'child' host group is editable but no change is applied.
Comment 1 orabin 2016-01-03 04:43:15 EST
Created from redmine issue http://projects.theforeman.org/issues/9108
Comment 2 orabin 2016-01-03 04:43:20 EST
Upstream bug assigned to tcaspy@redhat.com
Comment 10 Kedar Bidarkar 2016-04-12 12:05:38 EDT
we can now override the default value of a parameter inherited from parent hostgroup in nested host group.

VERIFIED with sat62-snap7.1
Comment 11 Kedar Bidarkar 2016-04-12 12:07 EDT
Created attachment 1146532 [details]
global params can now be overriden
Comment 14 errata-xmlrpc 2016-07-27 05:00:58 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1500

Note You need to log in before you can comment on or make changes to this bug.