This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 129522 - Be able to set 832x624 resolution
Be able to set 832x624 resolution
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: system-config-display (Show other bugs)
2
All Linux
medium Severity medium
: ---
: ---
Assigned To: Paul Nasrat
: FutureFeature
Depends On:
Blocks: FC3BugWeekQA
  Show dependency treegraph
 
Reported: 2004-08-09 20:38 EDT by Paul Vandenberg
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-01-04 10:43:09 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Paul Vandenberg 2004-08-09 20:38:52 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7)
Gecko/20040803 Firefox/0.9.3

Description of problem:
I was using 1024x768 as a system wide setting and 832x624 as my user
setting. This was configured under Screen Resolution in the GNOME
Control Panel. However, whenever I logged out and tried use a GDM
option the screen would go screwy and I would have to restart the X
Server. GDM doesn't give me a problem when the system resolution
matches the user resolution. To get around this problem, I manually
added 832x624 in my xorg.conf file. It would be nice to have it in the
GUI tool. I know it's an oddball size, but it would be nice to have if
it's not a lot of work.

I am using a ViewSonic G70m monitor and a Matrox Millenium G400 video
card.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Set 1024x768 system wide video reolution in system-config-display
2. Set 832x624 as user screen resolution in GNOME Control Panel
3. Logout to GDM. Move mouse to "Shutdown" or "Reboot"

    

Actual Results:  Screen goes screwy

Expected Results:  Reboot or Shutdown should be highlighted.

Additional info:
Comment 1 Paul Nasrat 2004-08-12 07:02:16 EDT
This is two issues on two different components -
gnome-display-properties and system-config-display

1) g-d-properites not resetting back to system settings on logout

Please retest on Fedora Core 3 test1 this seems to be working for me
fine resolution switches back to system settings.  You should not need
to change the system resolution.

2) Non-standard resolutions on LCD displays
Sadly this is non-trivial, per user switching using xrandr is fine,
s-c-display sets the maximum resolution. Presenting every possible
resolution to the user is confusing. Follow bug #122739 for further
details.  As you don't need this now for things to work I'm going to
consider this bug closed if you confirm that 1) is working.
Comment 2 Paul Vandenberg 2004-08-12 09:28:31 EDT
I can't really test FC3 test 1, as I don't have an extra PC. I also 
want to clarify that my PC does revert back to the system settings 
when exiting GNOME, but the problem occurs when I move my mouse to a 
menu option in GDM like Reboot or Shutdown. It is at that point it 
goes screwy. I don't have a problem in setting my system resolution 
manually in my xorg.conf file, so you may consider this bug closed. I 
was only offering a suggestion. However, I agree that too many 
options will make things thing confusing for a user.

Thanks.....Paul
Comment 3 Paul Nasrat 2004-08-12 10:26:07 EDT
Menu high-lighting and selections seem to work from my initial testing
- I'll attempt to get confirmation before I close.


Note You need to log in before you can comment on or make changes to this bug.