This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 122739 - (LCD_Resolution) RFE: Resolution listings for LCD displays (eg 1280x800)
RFE: Resolution listings for LCD displays (eg 1280x800)
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: system-config-display (Show other bugs)
3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Søren Sandmann Pedersen
: FutureFeature
: 126793 127372 136388 141301 (view as bug list)
Depends On:
Blocks: 132514 FC4Target
  Show dependency treegraph
 
Reported: 2004-05-07 12:30 EDT by Flo
Modified: 2014-06-18 05:07 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-21 15:59:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Test case for rhpl (427 bytes, text/plain)
2004-08-12 05:55 EDT, Paul Nasrat
no flags Details
lspci output (6.17 KB, text/plain)
2004-10-24 17:23 EDT, Eric Bourque
no flags Details
Patch against /usr/share/rhpl/extramodes (391 bytes, patch)
2004-10-30 10:02 EDT, Robert Shearman
no flags Details | Diff

  None (edit)
Description Flo 2004-05-07 12:30:13 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; fr; rv:1.6)
Gecko/20040206 Firefox/0.8

Description of problem:
Description of problem:
When installing on a Dell Inspiron 8600 (laptop), my screen was not
auto-detected.  Its screen resolution is 1280x800, but that was not an
option under the list of LCD sizes.  After booting, in Gnome desktop,
the maximum resolution available is 1024x768 but when selected and
after restart resolution is 800x600.


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. install and try to select 1280x800 as your screen resolution
2.
3.
    

Additional info:
Comment 1 Thomas Gordon 2004-05-21 20:36:19 EDT
I got this in FC2 on all our WXGA HP/compaq nx9110 .

please add 1280x800 60Hz in the LCD section!
Comment 2 Bastien Nocera 2004-07-11 19:37:40 EDT
Updated. This is the default resolution for some laptops, including mine.

Flo, simply configure your machine to use 1024x768, and edit
/etc/X11/xorg.conf to use 1280x800 in the "Screen" section (replace
1024x768 by 1280x800). The mode is already in X' modelines.
Comment 3 david d zuhn 2004-07-14 13:02:42 EDT
I just installed FC3test1, and I wasn't prompted for a monitor during
the anaconda graphical installation.  A default of 800x600 was used. 
I then used system-config-display to select appropriate hardware, and
I chose LCD Panel 1280x800 (which is correct for my laptop).  But when
I went back to the resolution selection screen, 1280x800 was not in
the list of available settings in the Resolution widget.  

My complaint is not the fact that it wasn't installed correctly, but
that system-config-display has been told (in one panel) how big the
screen is, and that the other panel doesn't use this information.
Comment 4 Dee-Ann LeBlanc 2004-07-22 01:30:54 EDT
I'm having the same problems as David Zuhn in comment #3. When I go in
after the installation and use system-config-display, I go into
Hardware and tell it LCD Panel 1280x800, and in Settings it doesn't
offer me 1280x800. It lets me choose 1024x768 or 1280x960 or 1280x1024
but not 1280x800.

It would be nice if it figured it out on install, too, of course. :)
Comment 5 Paul Nasrat 2004-08-12 05:10:45 EDT
In response to comment #3 the gnome resolution capplet is using xrandr
based on the running xserver, you need to restart X for the
s-c-display changes to take affect.  Does setting the resolution to
1280x800 and restarting X work for you?

For comment #4 I can reproduce the fact that 1280x800 does not appear
on the settings tab resolution list after selecting. The mode needs to
be added to vesamodes by the looks investigation
Comment 7 Paul Nasrat 2004-08-12 05:55:32 EDT
Created attachment 102644 [details]
Test case for rhpl

Simple reproducer for monitor, resolution.  Need to investigate probing a bit
more.

Can everyone reporting this bug please attach the output of kudzu -p -b ddc
please.
Comment 8 Paul Nasrat 2004-08-12 06:36:14 EDT
I'm changing this to be a generic bug for LCD display selection and
then resolution list not being as expected.

This is a harder issue that it might appear due to the fact some
drivers in laptops may not support the native resolution of the LCD panel.

Please add card details as well as monitor resolution and the results
of kudzu -p -b ddc
Comment 9 Paul Nasrat 2004-08-12 06:37:22 EDT
*** Bug 127372 has been marked as a duplicate of this bug. ***
Comment 10 Simon Goodall 2004-08-17 13:25:17 EDT
I have a NVidia Geforce 4 4200 Go 64mb with a LCD panel resolution of
1680x1050.

Results of kudzu -p -b ddc:

-
class: VIDEO
bus: DDC
detached: 0
driver: unknown
desc: "NVIDIA Corporation NV28 Board - p138ch"
mem: 65536
Comment 11 Paul Nasrat 2004-08-19 06:08:06 EDT
*** Bug 126793 has been marked as a duplicate of this bug. ***
Comment 12 Bastien Nocera 2004-08-26 13:41:08 EDT
This Sony S1XP uses an ATI Radeon Mobility 9700, and the resolution is
1280x800 (which works fine with both the Open Source and the
proprietary drivers):

# kudzu -p -b ddc
-
class: VIDEO
bus: DDC
detached: 0
driver: unknown
desc: "ATI Technologies Inc. P11"
mem: 65536
Comment 13 Dee-Ann LeBlanc 2004-08-26 19:38:20 EDT
Oh, I can manually change to 1280x800 and it works just fine, it would
just be nice to have access to the setting in the configuration tools
rather than having to edit files. :)
Comment 14 Tino Meinen 2004-09-01 17:16:17 EDT
Laptop Acer Aspire 2012WLCi with ATI radeon mobility 9700
Monitor resolution 1280x800
# kudzu -p -b ddc
-
class: VIDEO
bus: DDC
detached: 0
driver: unknown
desc: "ATI Technologies Inc. P11"
mem: 65536
-
class: MONITOR
bus: DDC
detached: 0
driver: unknown
desc: "Color LCD"
id: CMO1500
horizSyncMin: 48
horizSyncMax: 50
vertRefreshMin: 59
vertRefreshMax: 61
Comment 15 Emmanuel Seyman 2004-09-06 18:41:10 EDT
Dell Latitude D800 with an NVidia card
Monitor resolution is 1680x1050 .
The nv driver works fine once you've tweaked xorg.conf to use the
appropriate modelines.

# kudzu -p -b ddc
-
class: VIDEO
bus: DDC
detached: 0
driver: unknown
desc: "NVIDIA Corporation NV28 Board - p138ch"
mem: 65536
Comment 16 Rick Richardson 2004-10-16 08:29:28 EDT
Left hand, meet right hand...

With the FC3T3 installer, I was able to select "Generic LCD 1280x800"
for the display type.  But I was not offered this resolution in the X
pulldown.

This is on a brand new HP/Compaq R3000Z widescreen laptop with a 3
year old Geforce chip in it (forget which one).

Sorry, can't get more info right now as the installer failed to make
the touchpad usable.
Comment 17 Paul Nasrat 2004-10-21 04:27:07 EDT
Add to tracker for next round of development.
Comment 18 Paul Nasrat 2004-10-21 04:28:16 EDT
*** Bug 136388 has been marked as a duplicate of this bug. ***
Comment 19 Eric Bourque 2004-10-24 17:22:11 EDT
Closing Bug 136388 as a duplicate of this one is probably not correct
since this was an RFE to add 1280 x 800, and the other is reporting
incorrect behaviour (i.e., a real bug, not a request for enhancement)
since the LCD is in fact configured as 1280 x 800, but this option
does not exist in the resolution menu. Either way, here is the output
requested:

class: VIDEO
bus: DDC
detached: 0
driver: unknown
desc: "ATI Technologies Inc. P10"
mem: 65536
-
class: MONITOR
bus: DDC
detached: 0
driver: unknown
desc: "(null)"
id: SEC0000

The output of lspci will be added an an attachment.
Comment 20 Eric Bourque 2004-10-24 17:23:19 EDT
Created attachment 105708 [details]
lspci output
Comment 21 Robert Shearman 2004-10-28 11:47:33 EDT
I've been hit by this problem too.
If I'm reading the code correctly (I've never programmed or even seen
python before) then /usr/lib/python2.3/site-packages/rhpl/xhwstate.py
gets a full list of modes and then calls
rhpl.monitor.monitor_supports_mode in monitor.py to see whether it is
valid. This function gets a list of valid modes from
/usr/share/rhpl/{vesamodes,extramodes}. I am presuming that 1280x800
is not a VESA mode, so there the proper patch should be to add the
appropriate modes to that file? The trouble is I have no idea what
information is needed for each ModeLine or where to get it from.
Comment 22 Robert Shearman 2004-10-30 10:02:27 EDT
Created attachment 105973 [details]
Patch against /usr/share/rhpl/extramodes

Copying the modeline for the missing resolution from my Xorg.0.log into
/usr/share/rhpl/extramodes fixed the problem for me. Where should I send a
patch against the rhpl package?
Comment 23 Paul Nasrat 2004-12-01 10:53:02 EST
Comment #22, I'm unsure if that modeline is generic enough for all
1200x800 displays cf the 16:10 modelines. I'll check with our X team.
Comment 24 Paul Nasrat 2004-12-06 13:08:42 EST
*** Bug 141301 has been marked as a duplicate of this bug. ***
Comment 26 Flo 2005-01-20 07:28:19 EST
My system works with this Xorg.cong settings :

-----------------------------------
Section "ServerFlags"
    #DontZap # disable <Crtl><Alt><BS> (server abort)
    AllowMouseOpenFail # allows the server to start up even if the
mouse doesn't work
    #DontZoom # disable <Crtl><Alt><KP_+>/<KP_-> (resolution switching)
EndSection

Section "Module"
    Load "dbe" # Double-Buffering Extension
    Load "v4l" # Video for Linux
    Load "extmod"
    Load "type1"
    Load "freetype"
    # Load "glx" # 3D layer
EndSection

Section "InputDevice"
    Identifier "Keyboard1"
    Driver "keyboard"
    Option "XkbModel" "pc105"
    Option "XkbLayout" "fr"
    Option "XkbOptions" ""
EndSection

Section "InputDevice"
    Identifier "Mouse1"
    Driver "mouse"
    Option "Protocol" "ExplorerPS/2"
    Option "Device" "/dev/mouse"
    Option "ZAxisMapping" "6 7"
EndSection

Section "Monitor"
Option "CheckDesktopGeometry"
# DisplaySize 260 195 -- This is 1024x768
# DisplaySize 325 203 # 1280x800 at 100x100 dpi
# Option "IgnoreEDID" "1"
Identifier "Monitor0"
VendorName "Monitor Vendor"
ModelName "0"
HorizSync 31.5 - 61.0
VertRefresh 40.0 - 70.0
Option "dpms"
UseModes "16:10" 
EndSection

Section "Device"
    Identifier "device1"
    VendorName "nVidia"
    BoardName "NVIDIA GeForce FX (generic)"
    Driver "nv"
    Option "DPMS"
EndSection

Section "Screen"
Identifier "Screen0"
Device "device1"
Monitor "Monitor0"
DefaultDepth 24
SubSection "Display"
Depth 24
# Modes "1024x768" "800x600" "640x480"
Modes "1280x800"
EndSubSection
EndSection

Section "ServerLayout"
    Identifier "layout1"
    InputDevice "Keyboard1" "CoreKeyboard"
    InputDevice "Mouse1" "CorePointer"
    Screen "screen0"
EndSection

Section "Modes"
Identifier "16:10"
# Modeline "1024x768" 61.89 1024 1080 1184 1344 768 769 772 794

Modeline "1280x800@60" 83.91 1280 1312 1624 1656 800 816 824 841
# Modeline "1280x800@70" 101.92 1280 1312 1696 1728 800 816 825 841
# Modeline "1280x800@80" 121.48 1280 1312 1768 1800 800 815 826 841

EndSection
Comment 27 Benjamin Schmid 2005-03-08 17:17:12 EST
the problem lies in dm. with kdm the 16:10 resolutions work fine but
gnome does'nt get it.
I added the UseModes "16:10" -thing and gdm worked with 1280x800, but
after reboot x doesn't start when UseMode is active.
what now?
Comment 28 Ben West 2005-04-15 16:31:19 EDT
more information about this laptop and vaious other problems can be
found at: http://lists.pcxperience.com/cgi-bin/mailman/listinfo/linuxr3000
Comment 29 Matthias Saou 2005-04-15 17:12:04 EDT
I've just installed FC4 Test2 on a new Dell Latitude X1 laptop, and
the display of 1280x768 was a total fiasco. I think it's partly
because the video BIOS doesn't report that resolution as being
available, whereas the LCD panel is identified properly as having that
resolution, but not only.

Is there a new and cleaner resolution choosing mechanism planned for
FC4 final? With all those weirdo resolutions we're seeing on laptops
these days, something really needs to be done. Prior to this 1280x768
problem, I already had a similar experience with my Inspiron 8600 and
its 1680x1050 screen...
Comment 30 Søren Sandmann Pedersen 2005-04-21 15:59:12 EDT
I have added a number of weird laptop resolutins to the rhpl/data/extramodes and
to the X server build, so we should have better support for this in FC4.

Note You need to log in before you can comment on or make changes to this bug.