Bug 129527 - Evolution crashes when receiving mail
Evolution crashes when receiving mail
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: evolution (Show other bugs)
3
i686 Linux
high Severity high
: ---
: ---
Assigned To: Matthew Barnes
:
: 139573 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-08-09 21:45 EDT by Thomas J. Baker
Modified: 2007-11-30 17:10 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-04-06 11:43:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
bug buddy stack trace (7.89 KB, text/plain)
2004-08-09 21:46 EDT, Thomas J. Baker
no flags Details
BugBuddy-generated report on my latest crash of Evolution (14.41 KB, text/plain)
2004-11-12 14:06 EST, Terry Hurlbut
no flags Details
backtrace w/debuginfo (90.77 KB, text/plain)
2004-11-19 15:17 EST, Keith Iosso
no flags Details
evolution crash debug info after installing debug packages (13.90 KB, text/plain)
2004-11-30 18:47 EST, Brian Weekes
no flags Details
Backtrace as requested on #evolution (6.73 KB, text/plain)
2004-12-01 13:09 EST, adam.huffman
no flags Details

  None (edit)
Description Thomas J. Baker 2004-08-09 21:45:37 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7)
Gecko/20040625 Galeon/1.3.17

Description of problem:
Evolution crashes when retrieving email. I've got two pop accounts and
one imap and it seems like it crashes randomly when popping the
comcast account. I've sent a similiar bug report to Ximian but it got
bit bucketted as a glibc bug.

Version-Release number of selected component (if applicable):
evolution-1.5.92.1-1

How reproducible:
Sometimes

Steps to Reproduce:
1. hit the send/receive button or wait for it to happen in the background
2.
3.
    

Actual Results:  Evolution will sometimes crash

Expected Results:  It doesn't crash and just get's my email.

Additional info:

I've had this problem since upgrading to fc3t1 from fc2. I've waiting
hoping each successive release of evolution would fix the problem but
it hasn't. I was watching a bug (#127225) that I thought may be the
same thing but I'm not sure it is.
Comment 1 Thomas J. Baker 2004-08-09 21:47:00 EDT
Created attachment 102554 [details]
bug buddy stack trace
Comment 2 Thomas J. Baker 2004-08-09 21:48:51 EDT
FWIW, the ximian bug is http://bugzilla.ximian.com/show_bug.cgi?id=62693
Comment 3 Thomas J. Baker 2004-08-19 09:42:09 EDT
The latest evo doesn't fix the problem (evolution-1.5.93-2). If I
disable the single comcast pop account, the other local pop and remote
imap accounts work perfectly for days at a time. Just for kicks last
night, I enabled the comcast account and evo crashed within 5 minutes.
Comment 4 Dave Malcolm 2004-08-19 11:55:37 EDT
Thanks.  Looking at the stack trace it looks like a crash inside
camel_gethostbyname; might be related to bug #127225 (perhaps a
general problem with gethostbyname); I'll investigate further...
Comment 5 Thomas J. Baker 2004-09-07 13:44:55 EDT
I no longer have this problem. I turned back on the troublesome
account and it has been working for a few weeks now. I don't recall if
it was a glibc update or an evolution update that fixed it but it
definitely seems fixed.
Comment 6 Dave Malcolm 2004-09-07 14:02:34 EDT
Please can you specify which versions you're running in which it seems
to work:
rpm -q evolution
rpm -q glibc

Thanks!
Comment 7 Thomas J. Baker 2004-09-07 14:12:05 EDT
evolution-1.5.94.1-1 and glibc-2.3.3-47 work now but I know it was
working with the prior version of Evolution and glibc too since
glibc-2.3.3-47 was installed on 9/1/2004 and evolution on 9/6/2004.
Comment 8 Terry Hurlbut 2004-11-12 14:06:17 EST
Created attachment 106598 [details]
BugBuddy-generated report on my latest crash of Evolution

To reproduce this on a Fedora Core 2 system after the update of the glibc
packages distributed 11/11/2004:

Start Evolution, and either:
Hit the Send/Receive button, or else:
Wait for Evolution to try to send/receive mail in the background.

This is a total blocker--I had to switch to Mozilla Mail just to keep on
transacting business. I cannot, therefore, recommend Evolution to a client if
it is subject to such breakage. The correspondence I have received before
states that glibc might be responsible in some way. Neither Ximian nor Gnome
want to admit that the problem is with their code.
Comment 9 Dave Malcolm 2004-11-16 14:36:47 EST
*** Bug 139573 has been marked as a duplicate of this bug. ***
Comment 10 Dave Malcolm 2004-11-16 14:43:32 EST
Although the original report is against Evolution 1.5, this looks like
a duplicate of this massively-duplicated bug against Evolution 1.4 in
Ximian's bugzilla:
http://bugzilla.ximian.com/show_bug.cgi?id=69431

I've added a link to this bug into that bug

Comment 11 Dave Malcolm 2004-11-16 14:55:18 EST
Regarding comment #8:  I'm trying to narrow down what changes occurred
to glibc to cuase the problem.  Can you tell me when was the last time
you updated glibc before 11/11/2004 ? (and ideally, exactly which
version of the package you had installed when it was working)  What
version of the package do you now have installed?  Thank you.
Comment 13 Terry Hurlbut 2004-11-16 15:26:37 EST
Regarding Comment #11: I don't remember when the last time was that I
updated before November 11, 2004. I *can* tell you that, in general, I
update whenever up2date says that I should. Therefore, I had the *very
last version before the update*. Before I updated, Evolution never
gave me a lick of trouble. Once I updated, Evo 1.4.6 no longer worked.
(I now use Evo 2.0.2, which was the only way I could restore Evolution
functionality.)

The output of command string "rpm -q glibc" (issued as root) is:

glibc-2.3.3-27.1

The output of command string "rpm -q glibc-common" is:

glibc-common-2.3.3-27.1

As you can see, both those version numbers are consistent.

I also have the packages glibc-devel and glibc-headers installed, and
the version number is the same. (I just checked that out with Synaptic.)
Comment 14 Dave Malcolm 2004-11-16 16:04:30 EST
Thanks for the clarification; this is an FC2 box, right?  the last
update of glibc for FC2 was in May 2004 (glibc-2.3.3-27); the recent
update 2.3.3-27.1 contained a large number of fixes; I'm looking at
them now to see what might have caused this breakage.
Comment 15 Terry Hurlbut 2004-11-16 16:33:34 EST
Re Comment #14, yes, that is correct: this is an FC2 box. I never had
to update glibc until recently--and that's when the trouble started.
Comment 16 Keith Iosso 2004-11-17 19:32:31 EST
I also have been experiencing this since the last update to FC2.  I
also have Comcast as my ISP, which seems like it might be relevant. 
Until it is fixed, could it make sense to retrograde glibc?
Comment 17 Terry Hurlbut 2004-11-17 22:55:13 EST
Re Comment #16: Either roll back your glibc *or* manage to upgrade to
Evolution 2.0.2. You'll need the following as a special devel.conf file:

[main]
#cachedir=/var/cache/yum
debuglevel=2
logfile=/var/log/yum.log
pkgpolicy=newest
distroverpkg=fedora-release
gpgcheck=1
tolerant=1
exactarch=1

[freshrpm - devel]
name=Fedora Linux $releasever - $basearch - fedora - development
baseurl=http://ayo.freshrpms.net/fedora/linux/development/i386/core

Paste the above into a file called devel.conf. Either do this as root
or else run:

chown root /etc/devel.conf

Then run (as root):

yum -c /etc/devel.conf update evolution

Thirty-four RPM's later, you'll at least be able to use Evo 2.0.2 and
get past this problem.

Or, you could fall back on Mozilla Mail, which has *almost* all of
Evo's features.
Comment 18 Alexander Kain 2004-11-18 11:20:43 EST
Just FYI, I upgraded two FC2 systems to glibc and glibc-common
2.3.3-27.1 this week. On the AMD/ACPI machine evolution broke in the
manner described above, but no bad behavior on the Intel/AMP machine.
I rolled back to plain 2.3.3-27 (no .1) by downgrading to the original
glibc* rpms off of CD1, and now evolution works again on the AMD machine.
Comment 19 David Turvene 2004-11-18 11:26:11 EST
Yeah, I tried to upgrade using the yum config in Comment #17 and,
after 1500+ header updates, got the following:

Resolving dependencies
.............Unable to satisfy dependencies
Package openoffice.org-libs needs libdb_cxx-4.2.so, this is not available.

As a final effort, I tried to do an RPM update on evo 2.0.2 and still
got dependency failures (which I expected.)

I'm rolling glibc* back to 2.3.3-27 until I do a fork-lift upgrade to FC3.
Comment 20 Dave Malcolm 2004-11-18 14:07:21 EST
Please, if you're seeing this bug, and haven't yet upgraded, can you
install these packages:

- evolution-debuginfo 
- glibc-debuginfo
- glibc-debuginfo-common

...and then generate a stack backtrace, and post it here.

See this link for more information about how to do this:
http://fedora.linux.duke.edu/wiki/index.cgi/StackTraces

This would be very useful; so far the backtraces I've seen aren't with
the -debuginfo packages; with the debuginfo they should yield much
more information on what's gone wrong.   Thanks.
Comment 21 Keith Iosso 2004-11-19 15:17:16 EST
Created attachment 107084 [details]
backtrace w/debuginfo

here is a back/stacktrace.  Dave, please let me know if it doesn't meet your
needs.
Comment 22 Brian Weekes 2004-11-30 18:47:00 EST
Created attachment 107673 [details]
evolution crash debug info after installing debug packages

I've added an attachment of my debug info after installing the debug packages.
Comment 23 adam.huffman 2004-12-01 13:09:49 EST
Created attachment 107726 [details]
Backtrace as requested on #evolution
Comment 24 gerardo 2005-01-10 14:33:18 EST
From ximian bug:
After reading comments about this bug for about 2 hours, I've
concluded that there is a bug in Fedora's latest (2.3.3-27.1) upgrade
of glibc libraries. (Please read bug # 129527.)
I've upgraded the glibc, glibc-common, and glibc-headers to v2.3.3-74
from Fedora Core 3, and the bug's gone! For added confirmation, I've
re-installed the 2.3.3-27.1 version of the above  libraries, and the
bug's back.
Comment 28 John Thacker 2006-10-29 17:00:30 EST
Changing version to correct one.  (test1 -> fc3test1, and some were filed as
test3 accidentally instead; but clearly must be fc3test1 given the date of filing.)
Comment 29 Matthew Barnes 2006-12-31 17:36:40 EST
If this was really a glibc bug I imagine the problem has long since been fixed,
but is anyone still encountering this crash in Fedora Core 6 or later?
Comment 30 Matthew Miller 2007-04-06 11:08:57 EDT
Fedora Core 3 and Fedora Core 4 are no longer supported. If you could retest
this issue on a current release or on the latest development / test version, we
would appreciate that. Otherwise, this bug will be marked as CANTFIX one month
from now. Thanks for your help and for your patience.
Comment 31 Matthew Miller 2007-04-06 11:43:01 EDT
As I understand it, this is not an issue in current releases. Marking fixed now.
Please reopen if I'm wrong.

Note You need to log in before you can comment on or make changes to this bug.