Bug 129530 - Hindi glyphs spacing problem during display and printing
Hindi glyphs spacing problem during display and printing
Status: CLOSED DUPLICATE of bug 129531
Product: Fedora
Classification: Fedora
Component: openoffice.org (Show other bugs)
All Linux
medium Severity medium
: ---
: ---
Assigned To: Dan Williams
: i18n
Depends On:
Blocks: Indic
  Show dependency treegraph
Reported: 2004-08-10 00:19 EDT by Jatin Nansi
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2004-10-13 06:02:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Jatin Nansi 2004-08-10 00:19:04 EDT
Description of problem:
While inputting hindi text into openoffice writer, calc or impress,
the following is observed:
1. Glyphs overlap over one another
2. The input cursor position is incorrect wrt the current text position

Version-Release number of selected component (if applicable):

How reproducible:
Every time

Steps to Reproduce:
1. Start OOo in hi_IN.UTF-8 locale. 
2. Select gargi-1.3 as the font, at point size 12
3. Copy paste the test text in the attachment into writer
4. Select gargi-1.3 as the font, at point size 14
5. Copy paste the test text from the attachment again
6. Open the .txt attachment in gedit to compare
7. To test the input cursor, switch the keyboard to hindi input by
running "setxkbmap us", followed by "setxkbmap dev" in a gnome-terminal.
8. Input random text into writer. 
9. Reset keyboard to english by switching back to the gnome-terminal,
scroll thru history and select "setxkbmap us"
10. Print the document to a file.

Actual results:
1. with point size 12:
   - some of the glyphs overlap, the text is readable with difficulty.  
   - The input cursor goes ahead of the text after a lot of text has
been input
2. with point size 14:
   - the text is absolutely not readable. The text is not even
displayed after several characters have been input. 
   - Input cursor position is incorrect.
3. The printed output has the same issues as display.

Expected results:
1. The text should be readable at all point sizes
2. Input cursor positioning should be correct in all cases.
3. Printed text should be perfectly legible.

Additional info:
- To test, you may use the Gargi.ttf font available in this rpm: 
- This was tested on RHEL4-Alpha4-RC-re0722.0
Comment 1 Jatin Nansi 2004-08-10 00:21:39 EDT

*** This bug has been marked as a duplicate of 129531 ***
Comment 2 Caolan McNamara 2004-10-13 06:02:35 EDT
close as duplicate

Note You need to log in before you can comment on or make changes to this bug.