Bug 129531 - Hindi glyphs spacing problem during display and printing
Hindi glyphs spacing problem during display and printing
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: openoffice.org (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Dan Williams
: i18n
: 129530 (view as bug list)
Depends On:
Blocks: Indic
  Show dependency treegraph
 
Reported: 2004-08-10 00:19 EDT by Jatin Nansi
Modified: 2007-11-30 17:10 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-28 23:14:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
hindi test txt (469 bytes, text/plain)
2004-08-10 00:28 EDT, Jatin Nansi
no flags Details

  None (edit)
Description Jatin Nansi 2004-08-10 00:19:38 EDT
Description of problem:
While inputting hindi text into openoffice writer, calc or impress,
the following is observed:
1. Glyphs overlap over one another
2. The input cursor position is incorrect wrt the current text position

Version-Release number of selected component (if applicable):
1.1.1-6

How reproducible:
Every time

Steps to Reproduce:
1. Start OOo in hi_IN.UTF-8 locale. 
2. Select gargi-1.3 as the font, at point size 12
3. Copy paste the test text in the attachment into writer
4. Select gargi-1.3 as the font, at point size 14
5. Copy paste the test text from the attachment again
6. Open the .txt attachment in gedit to compare
7. To test the input cursor, switch the keyboard to hindi input by
running "setxkbmap us", followed by "setxkbmap dev" in a gnome-terminal.
8. Input random text into writer. 
9. Reset keyboard to english by switching back to the gnome-terminal,
scroll thru history and select "setxkbmap us"
10. Print the document to a file.

Actual results:
1. with point size 12:
   - some of the glyphs overlap, the text is readable with difficulty.  
   - The input cursor goes ahead of the text after a lot of text has
been input
2. with point size 14:
   - the text is absolutely not readable. The text is not even
displayed after several characters have been input. 
   - Input cursor position is incorrect.
3. The printed output has the same issues as display.

Expected results:
1. The text should be readable at all point sizes
2. Input cursor positioning should be correct in all cases.
3. Printed text should be perfectly legible.

Additional info:
- To test, you may use the Gargi.ttf font available in this rpm: 
http://bob.brisbane.redhat.com/~jnansi/pkgs/ttfonts-hi-1-1.noarch.rpm
- This was tested on RHEL4-Alpha4-RC-re0722.0
Comment 1 Jatin Nansi 2004-08-10 00:21:40 EDT
*** Bug 129530 has been marked as a duplicate of this bug. ***
Comment 2 Jatin Nansi 2004-08-10 00:28:06 EDT
Created attachment 102555 [details]
hindi test txt
Comment 3 Dan Williams 2004-08-10 09:06:56 EDT
confirmed.  How complete is this font?  My initial guess is that OOo
cannot parse the font's kerning tables.  Will investigate further.
Comment 4 Dan Williams 2004-08-10 09:47:25 EDT
Hmm, font has no kerning tables.  It does happen to have:

GDEF
GPOS
GSUB
OS/2
cmap
gasp
head
hhea
hmtx
loca
maxp
name
post

I'll probably confer with Owen about which tables Pango uses for this
font and see if OOo does the same.
Comment 5 Leon Ho 2004-08-25 22:27:30 EDT
Thanks, including Owen into the loop.
Comment 6 Owen Taylor 2004-08-26 14:55:47 EDT
I think I told Dan this in person, but basically I don't think it's
a problem with the selection of tables in the font; rather it's
some bug in the OpenOffice.org/ICU layout code that will have
to be debugged.
Comment 7 Dan Williams 2004-09-15 13:07:35 EDT
With OOo to-be-released (1.1.2-5) this appears to be OK with the SHREE
font...
Comment 8 Dan Williams 2004-09-28 16:44:52 EDT
Can you test with 1.1.2-5 or higher?
Comment 9 Leon Ho 2004-09-28 18:31:01 EDT
1.1.2-6 works for me. this bug should be fixed along with arabic
patch. great work. Jatin, close this bug if you have the same verdict.
Comment 10 Jatin Nansi 2004-09-28 23:14:16 EDT
Tested that this works fine on 1.1.2-6, thanks. Closing bug.

Note You need to log in before you can comment on or make changes to this bug.