Bug 129532 - firstboot isn't appearing
firstboot isn't appearing
Product: Fedora
Classification: Fedora
Component: firstboot (Show other bugs)
All Linux
medium Severity medium
: ---
: ---
Assigned To: Chris Lumens
Depends On: 132300
Blocks: FC3Target
  Show dependency treegraph
Reported: 2004-08-10 00:30 EDT by Jens Petersen
Modified: 2007-11-30 17:10 EST (History)
8 users (show)

See Also:
Fixed In Version: 1.3.33-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2005-09-04 19:20:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
firstboot-patch (584 bytes, patch)
2004-10-18 07:54 EDT, Tim Waugh
no flags Details | Diff

  None (edit)
Description Jens Petersen 2004-08-10 00:30:17 EDT
Description of problem:
The firstboot program isn't appearing on the screen for me
in recent rawhide.

How reproducible:
every time

Steps to Reproduce:
1. First new install for first time.
2. Wait for firstboot to appear.
Actual results:
System switching into X, but firstboot never appears:
just black screen with X cursor.

Expected results:
firstboot is run.

Additional info:
System locale is Japanese if it makes a difference.
Comment 1 Charlie Lesh 2004-08-13 22:31:05 EDT
Firstboot is actually running, you just cant's see it.

Try "Alt-tab" followed by "Alt-F4"

Works for me, not sure why.

Comment 2 Jens Petersen 2004-08-22 22:43:52 EDT
Charlie, thanks.  Which locale is your system running in btw?

It seems this is somewhat locale specific: I see it for ja_JP.UTF-8.
But I hear firstboot appears for other Asian locale at least.
Comment 4 Barry K. Nathan 2004-08-23 03:26:50 EDT
*** Bug 128003 has been marked as a duplicate of this bug. ***
Comment 5 Barry K. Nathan 2004-08-23 03:46:12 EDT
I'm seeing Charlie's behavior (hidden firstboot, but Alt-Tab + Alt-F4
reveals it) with en_US.UTF-8 locale. However, I usually choose to
install all languages (although I keep the default at "English (USA)"
or whatever it's called in the installer). Hopefully I'll be able to
test again with an English-only install soon (as soon as I find a
rawhide snapshot that actually installs onto my main test machine --
but that's unrelated to this bug and I will soon be filing a bug
against anaconda with more information).

In bug 128003 (which I just marked as a duplicate of this bug), I
noted that downgrading to rhgb-0.11.2-7 prevents this bug from
occurring. This is still the case (I just tried it).
Comment 6 Barry K. Nathan 2004-08-23 04:44:38 EDT
Same problem still happens with an English-only (i.e. no extra
languages selected) install of a 20040728 rawhide snapshot.... BTW,
the process name that appears when you press Alt-Tab is "rhgb".
Comment 7 Phil Schaffner 2004-09-09 17:09:56 EDT
No firstboot on FC3T2-candidate2.  Entry in /var/log/messages that
firstboot failed.  Booted without "rhgb quiet" to look for errors, so
the above work-around may not be applicable.
Comment 8 Adrian Likins 2004-09-09 18:13:17 EDT
if downgrading rhgb makes this go away, it certainly sounds
like a rhgb issues, since very little firstboot code
has changed in the meantime (a couple bug fixes in
the date module...)
Comment 9 Adrian Likins 2004-09-09 18:24:04 EDT
erk, comment #8 was for the wrong bug, ignore
Comment 10 Adrian Likins 2004-09-09 19:04:50 EDT
katzj reproduced it, and reproduced it going away with 
after downgrading rhgb (0.12 to 0.11) so bouncing to rhgb

(also, the only firstboot changes have been some bug
fixes in the date module which don't seem a likely
Comment 11 Daniel Veillard 2004-09-10 08:47:26 EDT
Not that fast !!!
Even after downgrading rhgb, firstboot in rawhide still hangs 
leaving rhgb grey screen and failing to start. The following logs
were extracted from stderr of firstboot on rawhide:

Traceback (most recent call last):
  File "/usr/share/firstboot/firstboot.py", line 201, in ?
    firstbootWindow.firstbootWindow(xserver_pid, wm_pid, doReconfig,
doDebug, lowRes, rhgb, autoscreenshot)
  File "/usr/share/firstboot/firstbootWindow.py", line 151, in __init__
  File "/usr/share/firstboot/firstbootWindow.py", line 391, in loadModules
  File "<string>", line 2, in ?
  File "/usr/share/firstboot/modules/soundcard_gui.py", line 52, in
    self.soundcardPage = soundcard.childWindow()
  File "/usr/share/system-config-soundcard/soundcard.py", line 87, in
    self.device, self.module, self.maker, self.model =
  File "/usr/share/system-config-soundcard/soundcardBackend.py", line
98, in getData
    maker, model = string.split(description, "|")
ValueError: unpack list of wrong size
Window manager warning: Lost connection to the display '';
most likely the X server was shut down or you killed/destroyed
the window manager.

  In a nutshell the soundcard configuration module simply failed.
If removing it doing
  mv /usr/share/firstboot/modules/soundcard_gui.py /tmp
then firstboot appears. There is still a number of warning which 
should be handled too:

/usr/share/firstboot/modules/securitylevel.py:74: DeprecationWarning:
use gtk.ComboBox
  self.securityOptionMenu = gtk.OptionMenu()
/usr/share/firstboot/modules/date.py:60: DeprecationWarning: use
  if self.dateWindow.vbox.children() != []:
/usr/share/firstboot/modules/date.py:61: DeprecationWarning: use
/usr/share/system-config-date/mainWindow.py:209: DeprecationWarning:
use GtkContainer.get_children
  if self.vbox.children() != []:
/usr/share/system-config-date/mainWindow.py:210: DeprecationWarning:
use GtkContainer.get_children
* ddcprobe returned bogus values:
ID:   None
Name: None
HorizSync: None
VertSync:  None
Traceback (most recent call last):
  File "/usr/share/firstboot/firstbootWindow.py", line 227, in switchPage
  File "/usr/share/firstboot/modules/finished.py", line 64, in updatePage
    for file in files:
UnboundLocalError: local variable 'files' referenced before assignment
GtkDeprecationWarning: gtk.mainquit is deprecated, use gtk.main_quit
  self.warn(message, DeprecationWarning)

  the hsync/vsync warning is system specific but the other ones 
relat to code rot in the firstboot module which should be fixed.

  I'm fixing the rhgb side (#128003) but the firstboot side need
to be fixed too. Bouncing back to firstboot/Adrian ...

Comment 12 John Reiser 2004-09-10 10:57:56 EDT
No firstboot on FC3T2-candidate2 (FC3-re0908.0-i386); similar to
comment #7 above.  Install was Workstation, minus openoffice-i18n to
save space.   I removed "rghb quient" from kernel command line before
rebooting from install.  'firstboot' started, but result was black
screen with default pointer only [standard arrow pointing northwest,
with white outline] and mouse tracking; no response to keyboard
<Ctrl><Alt>Fn, <Ctrl><Alt><Backspace>, <Alt><SysRq>b,
<Ctrl><Alt><DEL>.   Hardware reset was required to recover.

Second boot attempt: again without "rhgb quiet", but "single" to save
/var/log/Xorg.*.log.  Exit into runlevel 5: same black screen with
pointer only and mouse tracking, no keyboard response.  Hardware reset
 was required to recover.

Third boot attempt: Put back "rhgb quiet", try multiuser (no
"single").  Similar hang in firstboot, except background is now gray
(not black, not stippled.)  Hardware reset was required to recover
from hang.

Fourth boot attempt: Put back "rhgb quiet", got to multiuser in
800x600, no obvious evidence of firstboot: monitor configuration was
skipped, setting date was skipped, creating non-superuser was skipped.

So something about the presence or absence of "rhgb quiet" is
affecting firstboot.  However, firstboot should stand alone, and not
depend on rhgb.
Comment 13 Adrian Likins 2004-09-10 14:16:09 EDT
soundcard screen issue fixed
finish page issue fixed
(in 1.3.23)

I suspect the rhgb/firstboot issue is still
a problem though
Comment 14 Daniel Veillard 2004-09-10 17:30:11 EDT
When removing the soundcard module and with the fix of  
rhgb-0.12.5-1 from 128003 firstboot works for me on an
otherwise fully updated rawhide (but using anaconda from

Comment 16 Dee-Ann LeBlanc 2004-09-14 16:34:45 EDT
No firstboot, with same problems as <A
#7</A>. Machine went straight to a graphical (GDM) login prompt. Will
try sequence from <A
#12</A> and will report if anything different is noticed.
Comment 17 Dee-Ann LeBlanc 2004-09-14 16:37:20 EDT
Not being a programmer, I don't know if this is significant or not. I
just tried to run firstboot by hand and got the following:

[root@elizabeth ~]# firstboot
/usr/share/firstboot/modules/securitylevel.py:74: DeprecationWarning:
use gtk.ComboBox
  self.securityOptionMenu = gtk.OptionMenu()
Traceback (most recent call last):
  File "/usr/share/firstboot/firstboot.py", line 201, in ?
    firstbootWindow.firstbootWindow(xserver_pid, wm_pid, doReconfig,
doDebug, lowRes, rhgb, autoscreenshot)
  File "/usr/share/firstboot/firstbootWindow.py", line 151, in __init__
  File "/usr/share/firstboot/firstbootWindow.py", line 391, in loadModules
  File "<string>", line 2, in ?
  File "/usr/share/firstboot/modules/soundcard_gui.py", line 52, in
    self.soundcardPage = soundcard.childWindow()
  File "/usr/share/system-config-soundcard/soundcard.py", line 87, in
    self.device, self.module, self.maker, self.model =
  File "/usr/share/system-config-soundcard/soundcardBackend.py", line
98, in getData
    maker, model = string.split(description, "|")
ValueError: unpack list of wrong size
Comment 18 Dee-Ann LeBlanc 2004-09-14 17:03:20 EDT
My firstboot problems were all solved by applying the rawhide updates
available at approx. 2pm Pacific time Sept 14.
Comment 19 Charlie Lesh 2004-09-14 17:47:29 EDT
After installing a 'clean' development tree from boot.iso on 9/13/04,
I no longer have to "alt-tab" then "alt-f4" to see firstboot, it just
shows up the way that I expect!
Comment 20 Matthias Clasen 2004-10-05 17:15:56 EDT
I just installed fc1004.2 and did not get firstboot either.
Comment 21 Jens Petersen 2004-10-06 21:24:35 EDT
I got firstboot with the latest test3 candidate FC3-re1005.0
with firstboot-1.3.28-2. :)
Comment 22 Colin Charles 2004-10-09 11:11:39 EDT
firstboot-1.3.28-2 doesn't do it for me, its not appearing. Rawhide
latest 1009 tree
Comment 23 Barry K. Nathan 2004-10-09 22:08:48 EDT
FWIW, firstboot now works fine for me with 1005 and 1006 [and with
RHEL4 beta1 for that matter], but I haven't tried any later fc-devel
trees yet
Comment 24 Alexander Larsson 2004-10-18 06:15:09 EDT
I just installed rawhide-20041017, and didn't get a firstboot.
Didn't get it after a reboot either.
The logs has:
Oct 18 12:11:17 testbox: firstboot:  failed
for both boots.

Running "/sbin/service firstboot start" on a console seems to work
though. It starts a new xserver and brings up firstboot on it.
Comment 25 Tim Waugh 2004-10-18 06:41:17 EDT
I see this too, from a kickstart that worked fine last week.
Comment 26 Alexander Larsson 2004-10-18 06:44:43 EDT
It worked fine for me in the install i did on friday. That would have
been rawhide-20041014 or rawhide-20041015. rawhide-20041015 had
Comment 27 Tim Waugh 2004-10-18 06:52:57 EDT
I see this in /var/log/messages:

Oct 18 08:47:38 hoopoe firstboot:  failed
Comment 28 Tim Waugh 2004-10-18 06:59:31 EDT
Downgrading the firstboot package to 1.3.28-2 on this fresh install makes
firstboot come up on the next boot.  So this is a firstboot regression, not a
problem in something else.
Comment 29 Tim Waugh 2004-10-18 07:54:51 EDT
Created attachment 105369 [details]

This patch fixes it for me.
Comment 30 Alexander Larsson 2004-10-18 09:02:49 EDT
Works for me too.
Comment 31 Tim Waugh 2004-10-18 13:57:44 EDT
1.3.33-1 fixes it here.

Note You need to log in before you can comment on or make changes to this bug.