Bug 132300 - new kudzu format cause souncardBackend to traceback, breaking firstboot
Summary: new kudzu format cause souncardBackend to traceback, breaking firstboot
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: system-config-soundcard   
(Show other bugs)
Version: 4.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Bastien Nocera
QA Contact:
URL:
Whiteboard:
Keywords:
: 132307 133065 133984 (view as bug list)
Depends On:
Blocks: 129532 130007 FC3Blocker 132259
TreeView+ depends on / blocked
 
Reported: 2004-09-10 18:28 UTC by Adrian Likins
Modified: 2007-11-30 22:07 UTC (History)
4 users (show)

Fixed In Version: 1.2.9-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-17 21:48:11 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Adrian Likins 2004-09-10 18:28:37 UTC
when firstboot tries to load the s-c-soundcard module:

Traceback (most recent call last):
  File "/usr/share/firstboot/firstboot.py", line 201, in ?
    firstbootWindow.firstbootWindow(xserver_pid, wm_pid, doReconfig,
doDebug, lowRes, rhgb, autoscreenshot)
  File "/usr/share/firstboot/firstbootWindow.py", line 151, in __init__
    self.loadModules()
  File "/usr/share/firstboot/firstbootWindow.py", line 391, in loadModules
    exec(cmd)
  File "<string>", line 2, in ?
  File "/usr/share/firstboot/modules/soundcard_gui.py", line 52, in
__init__
    self.soundcardPage = soundcard.childWindow()
  File "/usr/share/system-config-soundcard/soundcard.py", line 87, in
__init__
    self.device, self.module, self.maker, self.model =
self.soundcardBackend.getData(card)
  File "/usr/share/system-config-soundcard/soundcardBackend.py", line
98, in getData
    maker, model = string.split(description, "|")
ValueError: unpack list of wrong size

The format of the strings kudzu produces has changed.

see #132259 and #129532

Comment 1 Bill Nottingham 2004-09-10 19:20:24 UTC
I notice this is fixed in CVS - should we just build that?

Comment 2 Bill Nottingham 2004-09-10 20:46:53 UTC
*** Bug 132307 has been marked as a duplicate of this bug. ***

Comment 3 Bill Nottingham 2004-09-17 21:48:11 UTC
Fixed in 1.2.9-1.

Comment 4 Bastien Nocera 2004-09-22 16:01:54 UTC
*** Bug 133065 has been marked as a duplicate of this bug. ***

Comment 5 Bill Nottingham 2004-09-29 05:00:09 UTC
*** Bug 133984 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.