Bug 1295347 - [Tier]: "Bad file descriptor" on removal of symlink only on tiered volume
Summary: [Tier]: "Bad file descriptor" on removal of symlink only on tiered volume
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: tiering
Version: 3.7.7
Hardware: x86_64
OS: Linux
unspecified
urgent
Target Milestone: ---
Assignee: Mohammed Rafi KC
QA Contact: bugs@gluster.org
URL:
Whiteboard:
Depends On: 1293237 1293256
Blocks: glusterfs-3.7.9
TreeView+ depends on / blocked
 
Reported: 2016-01-04 08:51 UTC by Mohammed Rafi KC
Modified: 2016-04-19 07:23 UTC (History)
6 users (show)

Fixed In Version: glusterfs-3.7.9
Doc Type: Bug Fix
Doc Text:
Clone Of: 1293256
Environment:
Last Closed: 2016-04-19 07:23:50 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Comment 1 Vijay Bellur 2016-01-04 09:10:10 UTC
REVIEW: http://review.gluster.org/13159 (tier/unlink: symlink failed to unlink) posted (#1) for review on release-3.7 by mohammed rafi  kc (rkavunga@redhat.com)

Comment 2 Vijay Bellur 2016-01-04 09:20:03 UTC
REVIEW: http://review.gluster.org/13159 (tier/unlink: symlink failed to unlink) posted (#2) for review on release-3.7 by mohammed rafi  kc (rkavunga@redhat.com)

Comment 3 Vijay Bellur 2016-02-10 05:48:45 UTC
REVIEW: http://review.gluster.org/13159 (tier/unlink: symlink failed to unlink) posted (#3) for review on release-3.7 by mohammed rafi  kc (rkavunga@redhat.com)

Comment 4 Vijay Bellur 2016-02-22 14:51:39 UTC
COMMIT: http://review.gluster.org/13159 committed in release-3.7 by Dan Lambright (dlambrig@redhat.com) 
------
commit 830f6ebe7462aef6b190c63d7c49288501283ab3
Author: Mohammed Rafi KC <rkavunga@redhat.com>
Date:   Wed Dec 23 23:37:54 2015 +0530

    tier/unlink: symlink failed to unlink
    
    during unlink of a file, we will get stat just after
    deleting the file, to see if the file is under migration or not
    
    but this stat call will fail for symlink if the actual file
    was deleted.
    
    So it is better not to send stat request from client if it is
    a symlink as we are not migrating symlink
    
    back port of>
    >Change-Id: Idc033b24fa3522b5261e579889d2195b43419682
    >BUG: 1293963
    >Signed-off-by: Mohammed Rafi KC <rkavunga@redhat.com>
    >Reviewed-on: http://review.gluster.org/13074
    >Tested-by: Gluster Build System <jenkins@build.gluster.com>
    >Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    >Reviewed-by: Pranith Kumar Karampuri <pkarampu@redhat.com>
    >Reviewed-by: Dan Lambright <dlambrig@redhat.com>
    >Tested-by: Dan Lambright <dlambrig@redhat.com>
    
    Change-Id: Ic53a9ad29722927f44004d2e7289c807c7485df0
    BUG: 1295347
    Signed-off-by: Mohammed Rafi KC <rkavunga@redhat.com>
    Reviewed-on: http://review.gluster.org/13159
    Smoke: Gluster Build System <jenkins@build.gluster.com>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.com>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    Reviewed-by: Dan Lambright <dlambrig@redhat.com>

Comment 5 Kaushal 2016-04-19 07:23:50 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.9, please open a new bug report.

glusterfs-3.7.9 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] https://www.gluster.org/pipermail/gluster-users/2016-March/025922.html
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user


Note You need to log in before you can comment on or make changes to this bug.