Bug 129541 - changes font when typing different scripts on the same line
changes font when typing different scripts on the same line
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: pango (Show other bugs)
4.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Behdad Esfahbod
desktop-bugs@redhat.com
: i18n, Reopened
Depends On:
Blocks: 149991
  Show dependency treegraph
 
Reported: 2004-08-10 05:07 EDT by Lawrence Lim
Modified: 2014-03-25 20:50 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-07 05:05:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Please note the changes in the font after alpabets are typed after numbers. (52.62 KB, image/png)
2004-08-10 05:09 EDT, Lawrence Lim
no flags Details
Screenshot of illustrating the space's spacing case. (38.84 KB, image/png)
2004-08-10 20:43 EDT, Leon Ho
no flags Details
xchat screenshot (66.82 KB, image/png)
2004-08-26 21:31 EDT, Lawrence Lim
no flags Details
xchat with pango 1.4.0-2 (82.45 KB, image/png)
2004-08-26 21:47 EDT, Lawrence Lim
no flags Details
a pango 1.4.1 screenshot for comparison on comment #4 screenshot (51.52 KB, image/png)
2004-09-10 04:20 EDT, Leon Ho
no flags Details
loading the same file in gedit with pango 1.5.2 - lines are misaligned (50.29 KB, image/png)
2004-09-10 04:25 EDT, Leon Ho
no flags Details

  None (edit)
Description Lawrence Lim 2004-08-10 05:07:42 EDT
Description of problem:
Typing numberic 0-9 is displayed in the font that is inconsistant with
the font after typing any alphabet after the number.

Version-Release number of selected component (if applicable):
pango-1.5.2-1

How reproducible:
Always

Steps to Reproduce:
1.Log in zh_TW (Traditional Chinese) from gdm
2.start gedit
3.enter any number follow by an alphbet
  
Actual results:
See Screen Shots

Expected results:
Should resume in zh_TW font, or uses english font for ascii

Additional info:
Please see screen shot.
Comment 1 Lawrence Lim 2004-08-10 05:09:08 EDT
Created attachment 102557 [details]
Please note the changes in the font after alpabets are typed after numbers.
Comment 2 Owen Taylor 2004-08-10 09:58:44 EDT
Font selection is hard. Yes, the behavior you observe is a
little disturbing, but the alternatives are worse.

Comment 3 Leon Ho 2004-08-10 20:41:44 EDT
Well I agree on your saying. And I love the way it starts using
english monospace font glyphs too. Pardon my reopening, for letting me
illustrate one more case:
- The space's spacing is not the same hence the align of editing of
each line is different.
    - test case
         - type 4 spaces and then type "- 1234"
         - type 4 spaces and then type "- abcd"

Notice the line that changed to English monospace font, the space's
spacing is larger than the previous line. Well it is okay for browsing
etc. But when it goes down to email composing, or editing text file
layout then it may affect users. Attached is the screenshot.
Comment 4 Leon Ho 2004-08-10 20:43:05 EDT
Created attachment 102601 [details]
Screenshot of illustrating the space's spacing case.
Comment 5 Lawrence Lim 2004-08-26 21:31:17 EDT
Created attachment 103150 [details]
xchat screenshot
Comment 6 Lawrence Lim 2004-08-26 21:47:19 EDT
Created attachment 103151 [details]
xchat with pango 1.4.0-2

Downgraded pango on my machine from 1.5 to 1.4 and the difference between the
xchat screenshot varies quite a lot.
Comment 7 Lawrence Lim 2004-08-26 22:19:45 EDT
Having read through my comments earlier, I think I am not very clear
on the result. :-(

So I would just like to add that with pango 1.5 in the ja_JP locale,
you can noticed that most of the charcters at the end of each line are
cut off. Also, changing the style on the same line, like in between
regular style and bold, there is no spacing between those glyphs,
which is not very ideal.
Comment 8 Owen Taylor 2004-08-27 15:43:44 EDT
I don't think the last comments have anything to do with the rest
of this bug.

Might be related to:

 http://bugzilla.gnome.org/show_bug.cgi?id=149438

?
Comment 9 Leon Ho 2004-08-27 22:01:10 EDT
Well, it shows the same behaviour on all CJK (maybe others as well),
and it only happens on new pango (1.5.2). Old pango (1.4.X) are fine.
Comment 10 Owen Taylor 2004-08-28 08:49:43 EDT
Well, really, I don't think it's related to the font selection
issue. Can you file a separate bug?
Comment 11 Lawrence Lim 2004-08-30 00:37:35 EDT
Filed bug 131218 in regards to the characters truncating problem.
Comment 12 Leon Ho 2004-09-10 04:20:13 EDT
Created attachment 103677 [details]
a pango 1.4.1 screenshot for comparison on comment #4 screenshot

In pango 1.4.1, the space are in same value, so they are aligned to each other.
Comment 13 Leon Ho 2004-09-10 04:25:39 EDT
Created attachment 103679 [details]
loading the same file in gedit with pango 1.5.2 - lines are misaligned
Comment 14 Liang Zhang 2006-06-16 00:13:39 EDT
 Comment #3 from Behdad Esfahbod    (pango developer, points: 20)
2006-06-16 03:46 UTC [reply]

That's not a bug.  If you login with Chinese, Pango expects Chinese.  When you
enter English, it chooses the best font for English.  It has no way to know
that you are going to type English in advance.

*** This bug has been marked as a duplicate of 321113 ***
Comment 15 Liang Zhang 2006-06-16 00:15:08 EDT
This bug can be closed.
Comment 16 Leon Ho 2006-06-20 00:03:27 EDT
It is still a big problem if you look at comment #13. Idea here maybe use
English glyphs for ASCII area, so that you won't have different glyphs for the
same character in the same document.
Comment 17 Behdad Esfahbod 2006-06-20 02:52:25 EDT
(In reply to comment #16)
> It is still a big problem if you look at comment #13. Idea here maybe use
> English glyphs for ASCII area, so that you won't have different glyphs for the
> same character in the same document.

That's suboptimal.  If you have different languages, you want the digits match
their surrounding language for font.  I opened another gnome bug to fix the
issue observed in comment #13:

  http://bugzilla.gnome.org/show_bug.cgi?id=345386
Comment 18 Leon Ho 2006-07-17 02:37:24 EDT
This bug is also a part reason why we have a serious rendering/cursoring problem
in firefox pango support. It is bug 149991 - will cc' you on the bug as well..
Comment 19 Behdad Esfahbod 2006-07-25 15:59:41 EDT
I don't think firefox+pango can hit this issue.
Comment 20 Jens Petersen 2008-05-01 00:45:07 EDT
I guess it is unlikely that this will ever be fixed for RHEL4?

Shall we just close this?  It is fixed in Fedora 9, I believe.
Comment 21 Behdad Esfahbod 2008-05-01 00:56:03 EDT
(In reply to comment #20)
> I guess it is unlikely that this will ever be fixed for RHEL4?
> 
> Shall we just close this?  It is fixed in Fedora 9, I believe.

Yep.  Unlikely.  Go for it.

Note You need to log in before you can comment on or make changes to this bug.