Bug 1295690 - Backport: Support migration of non-HA router to HA and reverse
Backport: Support migration of non-HA router to HA and reverse
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-neutron (Show other bugs)
8.0 (Liberty)
All Linux
medium Severity high
: ga
: 8.0 (Liberty)
Assigned To: John Schwarz
Alexander Stafeyev
:
Depends On: 1292527
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-05 04:13 EST by John Schwarz
Modified: 2016-04-26 17:57 EDT (History)
13 users (show)

See Also:
Fixed In Version: openstack-neutron-7.0.1-6
Doc Type: Enhancement
Doc Text:
Previously, a router that was neither an HA nor a DVR router could not be converted into an HA router. Instead, it was necessary to create a new router and reconnect all the resources (interfaces, networks etc.) from the old router to the new one. This update adds the ability to convert a legacy router into an HA or non-HA router in a few simple commands: # neutron router-update ROUTER --admin-state-up=False # neutron router-update ROUTER --ha=True/False # neutron router-upgrade ROUTER --admin-state-up=True Replace ROUTER with the ID or name of the router to convert.
Story Points: ---
Clone Of: 1292527
Environment:
Last Closed: 2016-04-07 17:16:58 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Launchpad 1365426 None None None 2016-01-05 04:13 EST
OpenStack gerrit 233646 None None None 2016-01-05 04:13 EST
OpenStack gerrit 260528 None None None 2016-01-05 04:13 EST

  None (edit)
Comment 3 Alexander Stafeyev 2016-01-27 04:35:46 EST
[stack@instack ~]$ neutron router-create Router1 --ha false
Created a new router:
+-----------------------+--------------------------------------+
| Field                 | Value                                |
+-----------------------+--------------------------------------+
| admin_state_up        | True                                 |
| distributed           | False                                |
| external_gateway_info |                                      |
| ha                    | False                                |
| id                    | 00d53b6c-7c75-40be-863e-cb537bf3da0a |
| name                  | Router1                              |
| routes                |                                      |
| status                | ACTIVE                               |
| tenant_id             | 1bef2bc7801e42068d874332bef91932     |
+-----------------------+--------------------------------------+
[stack@instack ~]$ 
[stack@instack ~]$ 
[stack@instack ~]$ 
[stack@instack ~]$ 
[stack@instack ~]$ 
[stack@instack ~]$ 
[stack@instack ~]$ 
[stack@instack ~]$ 
[stack@instack ~]$ 
[stack@instack ~]$ neutron router-update 00d53b6c-7c75-40be-863e-cb537bf3da0a --ha true
Bad router request: Cannot change HA attribute of active routers. Please set router admin_state_up to False prior to upgrade.
[stack@instack ~]$ neutron router-update 00d53b6c-7c75-40be-863e-cb537bf3da0a --admin_state_up false
Updated router: 00d53b6c-7c75-40be-863e-cb537bf3da0a
[stack@instack ~]$ 
[stack@instack ~]$ neutron router-update 00d53b6c-7c75-40be-863e-cb537bf3da0a --ha true
Updated router: 00d53b6c-7c75-40be-863e-cb537bf3da0a
[stack@instack ~]$ neutron router-update 00d53b6c-7c75-40be-863e-cb537bf3da0a --admin_state_up true
Updated router: 00d53b6c-7c75-40be-863e-cb537bf3da0a
[stack@instack ~]$ neutron router-show Router1
Multiple router matches found for name 'Router1', use an ID to be more specific.
[stack@instack ~]$ neutron router-show 00d53b6c-7c75-40be-863e-cb537bf3da0a
+-----------------------+--------------------------------------+
| Field                 | Value                                |
+-----------------------+--------------------------------------+
| admin_state_up        | True                                 |
| distributed           | False                                |
| external_gateway_info |                                      |
| ha                    | True                                 |
| id                    | 00d53b6c-7c75-40be-863e-cb537bf3da0a |
| name                  | Router1                              |
| routes                |                                      |
| status                | ACTIVE                               |
| tenant_id             | 1bef2bc7801e42068d874332bef91932     |
+-----------------------+--------------------------------------+
Comment 4 errata-xmlrpc 2016-04-07 17:16:58 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-0603.html

Note You need to log in before you can comment on or make changes to this bug.