Bug 1295702 - Fix spurious failure in bug-1221481-allow-fops-on-dir-split-brain.t
Fix spurious failure in bug-1221481-allow-fops-on-dir-split-brain.t
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: replicate (Show other bugs)
mainline
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: bugs@gluster.org
: Triaged
Depends On:
Blocks: 1296400
  Show dependency treegraph
 
Reported: 2016-01-05 05:03 EST by Krutika Dhananjay
Modified: 2016-06-16 09:53 EDT (History)
1 user (show)

See Also:
Fixed In Version: glusterfs-3.8rc2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1296400 (view as bug list)
Environment:
Last Closed: 2016-06-16 09:53:22 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Krutika Dhananjay 2016-01-05 05:03:55 EST
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 1 Vijay Bellur 2016-01-05 05:07:15 EST
REVIEW: http://review.gluster.org/13172 (tests: Fix spurious failure in bug-1221481-allow-fops-on-dir-split-brain.t) posted (#1) for review on master by Krutika Dhananjay (kdhananj@redhat.com)
Comment 2 Vijay Bellur 2016-01-05 21:37:58 EST
REVIEW: http://review.gluster.org/13172 (tests: Fix spurious failure in bug-1221481-allow-fops-on-dir-split-brain.t) posted (#2) for review on master by Krutika Dhananjay (kdhananj@redhat.com)
Comment 3 Vijay Bellur 2016-01-08 06:02:26 EST
REVIEW: http://review.gluster.org/13172 (tests: Fix spurious failure in bug-1221481-allow-fops-on-dir-split-brain.t) posted (#3) for review on master by Krutika Dhananjay (kdhananj@redhat.com)
Comment 4 Vijay Bellur 2016-01-11 00:56:34 EST
REVIEW: http://review.gluster.org/13172 (tests: Fix spurious failure in bug-1221481-allow-fops-on-dir-split-brain.t) posted (#4) for review on master by Krutika Dhananjay (kdhananj@redhat.com)
Comment 5 Vijay Bellur 2016-01-18 07:37:12 EST
REVIEW: http://review.gluster.org/13172 (tests: Fix spurious failure in bug-1221481-allow-fops-on-dir-split-brain.t) posted (#5) for review on master by Krutika Dhananjay (kdhananj@redhat.com)
Comment 6 Vijay Bellur 2016-01-18 20:21:47 EST
REVIEW: http://review.gluster.org/13172 (tests: Fix spurious failure in bug-1221481-allow-fops-on-dir-split-brain.t) posted (#6) for review on master by Krutika Dhananjay (kdhananj@redhat.com)
Comment 7 Vijay Bellur 2016-01-20 23:26:56 EST
REVIEW: http://review.gluster.org/13172 (tests: Fix spurious failure in bug-1221481-allow-fops-on-dir-split-brain.t) posted (#7) for review on master by Krutika Dhananjay (kdhananj@redhat.com)
Comment 8 Vijay Bellur 2016-01-21 02:06:53 EST
REVIEW: http://review.gluster.org/13172 (tests: Fix spurious failure in bug-1221481-allow-fops-on-dir-split-brain.t.) posted (#8) for review on master by Krutika Dhananjay (kdhananj@redhat.com)
Comment 9 Vijay Bellur 2016-01-22 02:36:00 EST
REVIEW: http://review.gluster.org/13172 (tests: Fix spurious failure in bug-1221481-allow-fops-on-dir-split-brain.t.) posted (#9) for review on master by Pranith Kumar Karampuri (pkarampu@redhat.com)
Comment 10 Vijay Bellur 2016-01-23 01:02:08 EST
COMMIT: http://review.gluster.org/13172 committed in master by Pranith Kumar Karampuri (pkarampu@redhat.com) 
------
commit ea94b2b8767e0d477a672355d758e0e8393362ee
Author: Krutika Dhananjay <kdhananj@redhat.com>
Date:   Tue Jan 5 15:36:28 2016 +0530

    tests: Fix spurious failure in bug-1221481-allow-fops-on-dir-split-brain.t.
    
    Occasionally, when ls is executed, prior to READDIRP, a STAT is wound on
    the operand directory. And AFR fails STAT with EIO if it is in metadata split-brain
    which "dir" is in the test case in question. As a result, ls also fails with EIO,
    causing test 20 to return negative exit status.
    The fix is in the test script where the parts that cause the dir to go into
    metadata split-brain have been removed. Now "dir" will only have entry
    split-brain.
    
    Change-Id: I4e4e6ba0a2401c7168719cd44e5f4f4bcb8fdd89
    BUG: 1295702
    Signed-off-by: Krutika Dhananjay <kdhananj@redhat.com>
    Reviewed-on: http://review.gluster.org/13172
    Reviewed-by: Pranith Kumar Karampuri <pkarampu@redhat.com>
    Tested-by: Pranith Kumar Karampuri <pkarampu@redhat.com>
    Smoke: Gluster Build System <jenkins@build.gluster.com>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.com>
Comment 11 Niels de Vos 2016-06-16 09:53:22 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.0, please open a new bug report.

glusterfs-3.8.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://blog.gluster.org/2016/06/glusterfs-3-8-released/
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.