Bug 1296400 - Fix spurious failure in bug-1221481-allow-fops-on-dir-split-brain.t
Fix spurious failure in bug-1221481-allow-fops-on-dir-split-brain.t
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: replicate (Show other bugs)
3.7.7
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: bugs@gluster.org
: Triaged
Depends On: 1295702
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-07 02:28 EST by Krutika Dhananjay
Modified: 2016-04-19 03:41 EDT (History)
1 user (show)

See Also:
Fixed In Version: glusterfs-3.7.8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1295702
Environment:
Last Closed: 2016-04-19 03:41:21 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Krutika Dhananjay 2016-01-07 02:28:32 EST
+++ This bug was initially created as a clone of Bug #1295702 +++

Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

--- Additional comment from Vijay Bellur on 2016-01-05 05:07:15 EST ---

REVIEW: http://review.gluster.org/13172 (tests: Fix spurious failure in bug-1221481-allow-fops-on-dir-split-brain.t) posted (#1) for review on master by Krutika Dhananjay (kdhananj@redhat.com)

--- Additional comment from Vijay Bellur on 2016-01-05 21:37:58 EST ---

REVIEW: http://review.gluster.org/13172 (tests: Fix spurious failure in bug-1221481-allow-fops-on-dir-split-brain.t) posted (#2) for review on master by Krutika Dhananjay (kdhananj@redhat.com)
Comment 1 Vijay Bellur 2016-01-07 02:33:38 EST
REVIEW: http://review.gluster.org/13190 (tests: Fix spurious failure in bug-1221481-allow-fops-on-dir-split-brain.t) posted (#1) for review on release-3.7 by Krutika Dhananjay (kdhananj@redhat.com)
Comment 2 Vijay Bellur 2016-01-23 00:58:34 EST
REVIEW: http://review.gluster.org/13190 (tests: Fix spurious failure in bug-1221481-allow-fops-on-dir-split-brain.t) posted (#2) for review on release-3.7 by Krutika Dhananjay (kdhananj@redhat.com)
Comment 3 Vijay Bellur 2016-01-24 23:39:51 EST
REVIEW: http://review.gluster.org/13190 (tests: Fix spurious failure in bug-1221481-allow-fops-on-dir-split-brain.t) posted (#3) for review on release-3.7 by Krutika Dhananjay (kdhananj@redhat.com)
Comment 4 Vijay Bellur 2016-01-29 03:02:34 EST
REVIEW: http://review.gluster.org/13190 (tests: Fix spurious failure in bug-1221481-allow-fops-on-dir-split-brain.t) posted (#4) for review on release-3.7 by Krutika Dhananjay (kdhananj@redhat.com)
Comment 5 Vijay Bellur 2016-02-02 05:47:37 EST
COMMIT: http://review.gluster.org/13190 committed in release-3.7 by Raghavendra Talur (rtalur@redhat.com) 
------
commit 10153901f0649b2d12c505a0f9fbef7a69acf128
Author: Krutika Dhananjay <kdhananj@redhat.com>
Date:   Thu Jan 7 13:01:02 2016 +0530

    tests: Fix spurious failure in bug-1221481-allow-fops-on-dir-split-brain.t
    
            Backport of: http://review.gluster.org/#/c/13172/
    
    Occasionally, when ls is executed, prior to READDIRP, a STAT is wound
    on the operand directory. And AFR fails STAT with EIO if it is in
    metadata split-brain which "dir" is in the test case in question.
    As a result, ls also fails with EIO, causing test 20 to return negative
    exit status.
    The fix is in the test script where the parts that cause the dir to go
    into metadata split-brain have been removed. Now "dir" will only have
    entry split-brain.
    
    Change-Id: Icf3998ad6f8735c283171e22445406a2eaaaa23f
    BUG: 1296400
    Signed-off-by: Krutika Dhananjay <kdhananj@redhat.com>
    Reviewed-on: http://review.gluster.org/13190
    Smoke: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Pranith Kumar Karampuri <pkarampu@redhat.com>
    Tested-by: Pranith Kumar Karampuri <pkarampu@redhat.com>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.com>
Comment 6 Kaushal 2016-04-19 03:41:21 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.8, please open a new bug report.

glusterfs-3.7.8 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] https://www.gluster.org/pipermail/gluster-users/2016-February/025292.html
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.