Bug 1295853 - kpatch: update to latest version
kpatch: update to latest version
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: kpatch (Show other bugs)
7.2
Unspecified Linux
high Severity medium
: rc
: ---
Assigned To: Josh Poimboeuf
Chunyu Hu
: Rebase, ZStream
Depends On: 1282508
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-05 10:48 EST by Jan Kurik
Modified: 2016-02-16 05:59 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Rebase: Bug Fixes and Enhancements
Doc Text:
The kpatch package has been upgraded to upstream version 0.3.1, which provides a number of bug fixes and enhancements over the previous version. With this update, the kpatch tool is compatible with Red Hat Enterprise Linux 7.2 live kernel patches.
Story Points: ---
Clone Of: 1282508
Environment:
Last Closed: 2016-02-16 05:59:32 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:0209 normal SHIPPED_LIVE kpatch bug fix and enhancement update 2016-02-16 10:57:56 EST

  None (edit)
Description Jan Kurik 2016-01-05 10:48:10 EST
This bug has been copied from bug #1282508 and has been proposed
to be backported to 7.2 z-stream (EUS).
Comment 4 Josh Poimboeuf 2016-01-05 15:29:25 EST
Created kpatch-patch test RPM at:

http://file.rdu.redhat.com/~jpoimboe/2016-01-05-kpatch-7.2-cmdline/kpatch-patch-3_10_0-327-1-1.scratch.201601051511.el7.x86_64.rpm

When loaded, it adds 'kpatch=1' to /proc/cmdline.
Comment 8 Josh Poimboeuf 2016-01-22 11:33:37 EST
Thanks for testing and finding the issues!  I'll fix them in the other bz.
Comment 10 errata-xmlrpc 2016-02-16 05:59:32 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0209.html

Note You need to log in before you can comment on or make changes to this bug.