This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1295886 - logwatch --service sshd --detail 8 does not print Kerberos summary
logwatch --service sshd --detail 8 does not print Kerberos summary
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: logwatch (Show other bugs)
6.7
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Jan Synacek
BaseOS QE - Apps
: EasyFix, FastFix, Patch
Depends On:
Blocks: 1356047 1359260
  Show dependency treegraph
 
Reported: 2016-01-05 12:16 EST by Martin Frodl
Modified: 2017-03-21 05:32 EDT (History)
1 user (show)

See Also:
Fixed In Version: logwatch-7.3.6-55.el6
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
: 1295888 (view as bug list)
Environment:
Last Closed: 2017-03-21 05:32:02 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Martin Frodl 2016-01-05 12:16:14 EST
Description of problem:

When called with --service sshd --detail 8, logwatch does not print out the summary of successful Kerberos authentications. This summary is printed with detail level 9, 10, but also 7. Thus the detail level of 8 may be less verbose than 7, which is clearly undesired.

The root cause of this behaviour seems to be in using the 'greater than' operator where a 'greater than or equal' should be (in /usr/share/logwatch/scripts/services/sshd):

--- sshd.orig	2016-01-05 12:09:26.153006890 -0500
+++ sshd	2016-01-05 12:12:09.610000477 -0500
@@ -576,7 +576,7 @@
    }
 }
 
-if ( ($Detail == 7 && keys %KrbRealm > 1) || ($Detail > 8 && keys %KrbRealm) ){
+if ( ($Detail == 7 && keys %KrbRealm > 1) || ($Detail >= 8 && keys %KrbRealm) ){
    print "\nSucessfull Kerberos Authentication from ",(scalar keys %KrbRealm)," realm:\n";
    foreach my $realm (keys %KrbRealm) {
       if($Detail > 9){

Version-Release number of selected component (if applicable):
logwatch-7.3.6-52.el6.noarch
Comment 7 errata-xmlrpc 2017-03-21 05:32:02 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2017-0610.html

Note You need to log in before you can comment on or make changes to this bug.