Bug 1295888 - logwatch --service sshd --detail 8 does not print Kerberos summary
logwatch --service sshd --detail 8 does not print Kerberos summary
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: logwatch (Show other bugs)
7.2
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Jan Synacek
Martin Frodl
: EasyFix, Patch
Depends On:
Blocks: 1289485 1313485
  Show dependency treegraph
 
Reported: 2016-01-05 12:21 EST by Martin Frodl
Modified: 2016-11-03 23:30 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1295886
Environment:
Last Closed: 2016-11-03 23:30:46 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Martin Frodl 2016-01-05 12:21:09 EST
+++ This bug was initially created as a clone of Bug #1295886 +++

Description of problem:

When called with --service sshd --detail 8, logwatch does not print out the summary of successful Kerberos authentications. This summary is printed with detail level 9, 10, but also 7. Thus the detail level of 8 may be less verbose than 7, which is clearly undesired.

The root cause of this behaviour seems to be in using the 'greater than' operator where a 'greater than or equal' should be (in /usr/share/logwatch/scripts/services/sshd):

--- sshd.orig	2016-01-05 12:09:26.153006890 -0500
+++ sshd	2016-01-05 12:12:09.610000477 -0500
@@ -576,7 +576,7 @@
    }
 }
 
-if ( ($Detail == 7 && keys %KrbRealm > 1) || ($Detail > 8 && keys %KrbRealm) ){
+if ( ($Detail == 7 && keys %KrbRealm > 1) || ($Detail >= 8 && keys %KrbRealm) ){
    print "\nSucessfull Kerberos Authentication from ",(scalar keys %KrbRealm)," realm:\n";
    foreach my $realm (keys %KrbRealm) {
       if($Detail > 9){

Version-Release number of selected component (if applicable):
logwatch-7.4.0-28.20130522svn140.el7.noarch
Comment 7 errata-xmlrpc 2016-11-03 23:30:46 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2312.html

Note You need to log in before you can comment on or make changes to this bug.