Bug 1295922 - Content -> Lifecycle Environments are not visible on screen and no scroll bars appear to view the additional content
Summary: Content -> Lifecycle Environments are not visible on screen and no scroll bar...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: WebUI
Version: 6.1.5
Hardware: Unspecified
OS: Linux
high
high vote
Target Milestone: Unspecified
Assignee: Walden Raines
QA Contact: David Davis
URL: http://projects.theforeman.org/issues...
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-01-05 19:29 UTC by anerurka
Modified: 2019-11-14 07:17 UTC (History)
10 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-07-27 09:01:12 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:1500 normal SHIPPED_LIVE Red Hat Satellite 6.2 Base Libraries 2016-07-27 12:24:38 UTC

Description anerurka 2016-01-05 19:29:41 UTC
Description of problem:

If there are multiple Lifecycle Environment present under "Content -> Lifecycle Environments" then it does not fit on the screen and no scroll bar are available to scroll and view the content.

Version-Release number of selected component (if applicable):

Satellite Server v.6.1.5

How reproducible:

This can be reproduced by having 8 or more than 8 Lifecyle Environment present under "Content -> Lifecycle Environments". 

We can observe that if it does not fit on screen and it does not provide scroll bar to view.

Actual results:

No scroll bar to view the content on screen, which results in unable to access the content.

Expected results:

In case of multiple Environment and if it does not fit on screen then it should provide a scroll bar for complete access.

Comment 2 Andrew Schofield 2016-01-05 19:59:57 UTC
NB. The 8 Lifecycle environments is simply the number we have and means the screen has to be extended significantly. The issue here seems to be with the whole table.

Comment 3 Brad Buckingham 2016-01-08 16:15:40 UTC
Hi, Can you add a screenshot of the behavior?  Thanks!

Comment 11 Walden Raines 2016-02-25 14:46:11 UTC
Created redmine issue http://projects.theforeman.org/issues/13901 from this bug

Comment 12 Walden Raines 2016-02-25 19:35:50 UTC
PR - https://github.com/Katello/katello/pull/5813

Comment 13 Bryan Kearney 2016-02-29 15:03:33 UTC
Moving to POST since upstream bug http://projects.theforeman.org/issues/13901 has been closed
-------------
Walden Raines
Applied in changeset commit:katello|64044e198fd671850e7f45ec0bceecf2d9559bce.

Comment 14 Walden Raines 2016-03-02 15:38:52 UTC
*** Bug 1313321 has been marked as a duplicate of this bug. ***

Comment 16 David Davis 2016-04-04 13:07:21 UTC
Was able to see all the columns if I had 8 or more environments. However, the column/env names became impossible to read. I've opened a separate bug though for that:

https://bugzilla.redhat.com/show_bug.cgi?id=1323699

Verified against 6.2 Snap 6.

Comment 18 errata-xmlrpc 2016-07-27 09:01:12 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1500


Note You need to log in before you can comment on or make changes to this bug.