Bug 1295939 - Cannot Register Insights Client when CURL_CA_BUNDLE ENV Variables is set
Cannot Register Insights Client when CURL_CA_BUNDLE ENV Variables is set
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: redhat-access-insights (Show other bugs)
6.8
All All
high Severity high
: rc
: ---
Assigned To: jcrafts
Martin Kyral
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-05 15:16 EST by Keith Robertson
Modified: 2016-07-03 21:34 EDT (History)
3 users (show)

See Also:
Fixed In Version: redhat-access-insights-1.0.7-3.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1295940 (view as bug list)
Environment:
Last Closed: 2016-05-10 20:43:43 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Keith Robertson 2016-01-05 15:16:56 EST
Description of problem:
The Python Requests package, which is used by Insights to make HTTPS connections, will read the CURL_CA_BUNDLE environment variable.  This variable can interfere with the pinned CA certs used by the Insights client to validate connections to redhat.com.

This BZ tracks the effort to ignore this variable while running.
Comment 5 errata-xmlrpc 2016-05-10 20:43:43 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0928.html

Note You need to log in before you can comment on or make changes to this bug.