Bug 1296160 - Unable to drag or remove elements in service dialog edit
Unable to drag or remove elements in service dialog edit
Status: CLOSED ERRATA
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: UI - OPS (Show other bugs)
5.5.0
Unspecified Unspecified
medium Severity medium
: GA
: 5.5.2
Assigned To: Milan Zázrivec
Ramesh A
: ZStream
Depends On: 1284425
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-06 08:44 EST by Chris Pelland
Modified: 2016-02-10 10:31 EST (History)
15 users (show)

See Also:
Fixed In Version: 5.5.2.1
Doc Type: Bug Fix
Doc Text:
The previous version of CloudForms Management Engine had a user interface bug in Automate's custom service dialog editor where the user was not able to drag or remove existing elements in a service dialog. This bug was caused by errors in the drag and drop mechanism code. This bug was fixed by correcting the code errors. Users are now able to edit Automate service dialogs as expected in the new version of CloudForms Management Engine.
Story Points: ---
Clone Of: 1284425
Environment:
Last Closed: 2016-02-10 10:31:01 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:0159 normal SHIPPED_LIVE CFME 5.5.2 bug fixes and enhancement update 2016-02-10 15:19:02 EST

  None (edit)
Comment 3 CFME Bot 2016-01-08 14:02:19 EST
New commit detected on cfme/5.5.z:
https://code.engineering.redhat.com/gerrit/gitweb?p=cfme.git;a=commitdiff;h=2373db785a7e9b190040561f373322b0a657247c

commit 2373db785a7e9b190040561f373322b0a657247c
Author:     Milan Zazrivec <mzazrivec@redhat.com>
AuthorDate: Thu Nov 26 15:50:20 2015 +0100
Commit:     Milan Zazrivec <mzazrivec@redhat.com>
CommitDate: Fri Jan 8 15:10:57 2016 +0100

    Service dialog editing: fix drag & delete mechanism in UI
    
    In fact just style fixes after
    
    8ab99d20178a6b4515160ed3067852bf1510ba40
    0ae3cf18769393ed851119543d021c455cad45c8
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1296160
    (cherry picked from commit 043712dd7083607e396e87da057151f928a82c6a)

 .../_dialog_res_remove.html.haml                    |  2 +-
 .../miq_ae_customization/_dialog_resource.html.haml | 21 ++++++++++-----------
 .../_dialog_res_remove.html.haml_spec.rb            | 17 +++++++++++++++++
 .../_dialog_resource.html.haml_spec.rb              | 19 +++++++++++++++++++
 4 files changed, 47 insertions(+), 12 deletions(-)
 create mode 100644 spec/views/miq_ae_customization/_dialog_res_remove.html.haml_spec.rb
 create mode 100644 spec/views/miq_ae_customization/_dialog_resource.html.haml_spec.rb
Comment 4 CFME Bot 2016-01-08 14:02:51 EST
New commit detected on cfme/5.5.z:
https://code.engineering.redhat.com/gerrit/gitweb?p=cfme.git;a=commitdiff;h=43dda14f6ba6461a01ebef96bce4a354274796a0

commit 43dda14f6ba6461a01ebef96bce4a354274796a0
Merge: 86642e2 2373db7
Author:     Dan Clarizio <dclarizi@redhat.com>
AuthorDate: Fri Jan 8 13:41:29 2016 -0500
Commit:     Dan Clarizio <dclarizi@redhat.com>
CommitDate: Fri Jan 8 13:41:29 2016 -0500

    Merge branch 'fix_service_dialog_drag_and_delete' into '5.5.z'
    
    Service dialog editing: fix drag & delete mechanism in UI
    
    In fact just style fixes after
    
    8ab99d20178a6b4515160ed3067852bf1510ba40
    0ae3cf18769393ed851119543d021c455cad45c8
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1296160
    (cherry picked from commit 043712dd7083607e396e87da057151f928a82c6a)
    
    See merge request !686

 .../_dialog_res_remove.html.haml                    |  2 +-
 .../miq_ae_customization/_dialog_resource.html.haml | 21 ++++++++++-----------
 .../_dialog_res_remove.html.haml_spec.rb            | 17 +++++++++++++++++
 .../_dialog_resource.html.haml_spec.rb              | 19 +++++++++++++++++++
 4 files changed, 47 insertions(+), 12 deletions(-)
Comment 6 Ramesh A 2016-01-18 12:12:37 EST
Good to go. Verified and working fine in 5.5.2.1.20160114044944_395c086
Comment 7 errata-xmlrpc 2016-02-10 10:31:01 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:0159

Note You need to log in before you can comment on or make changes to this bug.