Bug 1284425 - Unable to drag or remove elements in service dialog edit
Unable to drag or remove elements in service dialog edit
Status: CLOSED ERRATA
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: UI - OPS (Show other bugs)
5.5.0
Unspecified Unspecified
medium Severity medium
: GA
: 5.6.0
Assigned To: Milan Zázrivec
Aziza Karol
ui:dialog
: ZStream
: 1287212 (view as bug list)
Depends On:
Blocks: 1296160
  Show dependency treegraph
 
Reported: 2015-11-23 05:17 EST by Aziza Karol
Modified: 2016-06-29 11:10 EDT (History)
9 users (show)

See Also:
Fixed In Version: 5.6.0.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1296160 (view as bug list)
Environment:
Last Closed: 2016-06-29 11:10:42 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
snpshot (68.68 KB, image/png)
2015-11-23 05:17 EST, Aziza Karol
no flags Details

  None (edit)
Description Aziza Karol 2015-11-23 05:17:21 EST
Created attachment 1097609 [details]
snpshot

Description of problem:


Version-Release number of selected component (if applicable):
5.5.0.11

How reproducible:
100%

Steps to Reproduce:
1.Navigate to Automate->customization
2.create a service dialog with few elements
3.click on edit dialog and try to drag or remove the elements

Actual results:
unable to drag or remove elements in service dialog edit. see attached screenshot

Expected results:
should be able to  drag or remove elements

Additional info:
Comment 2 Harpreet Kataria 2015-11-23 08:42:17 EST
Milan,

Can you look into this, let me know if you have any questions.

Thanks,
~Harpreet
Comment 3 Milan Zázrivec 2015-11-26 09:52:38 EST
https://github.com/ManageIQ/manageiq/pull/5621
Comment 4 CFME Bot 2015-12-02 14:44:57 EST
New commit detected on ManageIQ/manageiq/master:
https://github.com/ManageIQ/manageiq/commit/043712dd7083607e396e87da057151f928a82c6a

commit 043712dd7083607e396e87da057151f928a82c6a
Author:     Milan Zazrivec <mzazrivec@redhat.com>
AuthorDate: Thu Nov 26 15:50:20 2015 +0100
Commit:     Milan Zazrivec <mzazrivec@redhat.com>
CommitDate: Thu Nov 26 17:20:09 2015 +0100

    Service dialog editing: fix drag & delete mechanism in UI
    
    In fact just style fixes after
    
    8ab99d20178a6b4515160ed3067852bf1510ba40
    0ae3cf18769393ed851119543d021c455cad45c8
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1284425

 .../_dialog_res_remove.html.haml                    |  2 +-
 .../miq_ae_customization/_dialog_resource.html.haml | 21 ++++++++++-----------
 .../_dialog_res_remove.html.haml_spec.rb            | 17 +++++++++++++++++
 .../_dialog_resource.html.haml_spec.rb              | 19 +++++++++++++++++++
 4 files changed, 47 insertions(+), 12 deletions(-)
 create mode 100644 spec/views/miq_ae_customization/_dialog_res_remove.html.haml_spec.rb
 create mode 100644 spec/views/miq_ae_customization/_dialog_resource.html.haml_spec.rb
Comment 5 Harpreet Kataria 2015-12-02 15:11:39 EST
*** Bug 1287212 has been marked as a duplicate of this bug. ***
Comment 6 Aziza Karol 2016-04-20 03:34:08 EDT
Able to drag or remove elements in service dialog edit.

Verified:
5.6.0.1-beta2.20160413141124_e25ac0e
Comment 8 errata-xmlrpc 2016-06-29 11:10:42 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1348

Note You need to log in before you can comment on or make changes to this bug.