Bug 1296171 - Require API to Create/update/Del Crush Rule
Require API to Create/update/Del Crush Rule
Status: CLOSED ERRATA
Product: Red Hat Ceph Storage
Classification: Red Hat
Component: Calamari (Show other bugs)
1.3.1
Unspecified Unspecified
unspecified Severity unspecified
: rc
: 2.0
Assigned To: Gregory Meno
Harish NV Rao
:
Depends On:
Blocks: 1291304
  Show dependency treegraph
 
Reported: 2016-01-06 09:06 EST by Nishanth Thomas
Modified: 2016-08-23 15:29 EDT (History)
6 users (show)

See Also:
Fixed In Version: calamari-server-1.4.0-rc4
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-08-23 15:29:25 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
icolle: needinfo+


Attachments (Terms of Use)

  None (edit)
Description Nishanth Thomas 2016-01-06 09:06:14 EST
Currently there is no API available to CRUD on crush rule

http://calamari.readthedocs.org/en/latest/calamari_rest/resources/resources.html#api-reference

This is a very critical requirement for us for USM 1.0
Comment 3 Gregory Meno 2016-01-27 14:31:06 EST
This work is really just following the template of work that exists for updating crush nodes. I expect that this is at least two weeks of effort. I don't agree that this is top priority though. The need in MVP-011 could be satisfied in using the crush map endpoint as it has the ability to update rules.

http://calamari.readthedocs.org/en/latest/calamari_rest/resources/resources.html#crush-map

Retrieve is implemented here already

http://calamari.readthedocs.org/en/latest/calamari_rest/resources/resources.html#crushruleviewset

I recommend coming back to this one after closing other 2.0.0 bugs.
Comment 5 Gregory Meno 2016-03-02 13:39:13 EST
Harish yes it will
Comment 7 Mike McCune 2016-03-28 18:39:30 EDT
This bug was accidentally moved from POST to MODIFIED via an error in automation, please see mmccune@redhat.com with any questions
Comment 9 Harish NV Rao 2016-08-01 07:08:24 EDT
able to create, delete and modify the crush rule using the 'crush_rule' api.
Comment 11 errata-xmlrpc 2016-08-23 15:29:25 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1755

Note You need to log in before you can comment on or make changes to this bug.