Bug 1296175 - geo-rep: hard-link rename issue on changelog replay
geo-rep: hard-link rename issue on changelog replay
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: geo-replication (Show other bugs)
3.7.7
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Milind Changire
:
Depends On: 1296174 1296176
Blocks: glusterfs-3.7.9
  Show dependency treegraph
 
Reported: 2016-01-06 09:17 EST by Milind Changire
Modified: 2016-04-19 03:20 EDT (History)
2 users (show)

See Also:
Fixed In Version: glusterfs-3.7.9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1296174
Environment:
Last Closed: 2016-03-22 04:14:54 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Milind Changire 2016-01-06 09:17:45 EST
+++ This bug was initially created as a clone of Bug #1296174 +++

Description of problem:
hard-link creation followed by a rename causes stale hard-links if changelogs are replayed

Version-Release number of selected component (if applicable):


How reproducible:
always

Steps to Reproduce:
0. create and start geo-rep on a volume
1. touch f1; and wait for 20 seconds
2. ln f1 link1; mv link1 link2; and wait for 20 seconds
3. stop and start geo-rep
4. you will see link1 getting created on slave volume; ideally it shouldn't exist

Actual results:
link1 exists after logs are replayed

Expected results:
link1 shouldn't exist

Additional info:
Comment 1 Vijay Bellur 2016-03-08 03:38:08 EST
REVIEW: http://review.gluster.org/13638 (geo-rep: hard-link rename issues on changelog replay) posted (#1) for review on release-3.7 by Milind Changire (mchangir@redhat.com)
Comment 2 Vijay Bellur 2016-03-08 03:39:40 EST
REVIEW: http://review.gluster.org/13638 (geo-rep: hard-link rename issues on changelog replay) posted (#2) for review on release-3.7 by Milind Changire (mchangir@redhat.com)
Comment 3 Vijay Bellur 2016-03-09 03:26:30 EST
COMMIT: http://review.gluster.org/13638 committed in release-3.7 by Aravinda VK (avishwan@redhat.com) 
------
commit 0cb6e6e7020c5a4f2e5c34c6b8cbfa4fdeb45191
Author: Milind Changire <mchangir@redhat.com>
Date:   Wed Jan 6 21:23:51 2016 +0530

    geo-rep: hard-link rename issues on changelog replay
    
    Problem:
    LINK + RENAME changelog when replayed after worker restart causes stale
    hard-links to persist since VFS returns success for RENAME if hard-links
    point to same inode.
    
    Solution:
    Worker detects RENAME being issued on hard-links to the same inode and
    unlinks the source file-name. Conditionally rename by verifying that the
    source gfid matches with the on-disk gfid on the slave.
    
    Change-Id: I3ff1c30ef79e77503c8b246d46dab8ac3059ccf2
    BUG: 1296175
    Reviewed-on: http://review.gluster.org/13189
    Signed-off-by: Milind Changire <mchangir@redhat.com>
    Reviewed-on: http://review.gluster.org/13638
    Smoke: Gluster Build System <jenkins@build.gluster.com>
    Tested-by: Aravinda VK <avishwan@redhat.com>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Aravinda VK <avishwan@redhat.com>
Comment 4 Kaushal 2016-04-19 03:20:46 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.9, please open a new bug report.

glusterfs-3.7.9 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] https://www.gluster.org/pipermail/gluster-users/2016-March/025922.html
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.