Bug 1296196 - Sysrestore did not restore state if a key is specified in mixed case
Sysrestore did not restore state if a key is specified in mixed case
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: ipa (Show other bugs)
7.3
All All
urgent Severity urgent
: rc
: ---
Assigned To: Pavel Picka
Namita Soman
: ZStream
Depends On:
Blocks: 1298101
  Show dependency treegraph
 
Reported: 2016-01-06 10:05 EST by Petr Vobornik
Modified: 2016-11-04 01:48 EDT (History)
7 users (show)

See Also:
Fixed In Version: ipa-4.2.0-16.el7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1298101 (view as bug list)
Environment:
Last Closed: 2016-11-04 01:48:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
evidence (3.95 KB, text/plain)
2016-08-16 06:11 EDT, Pavel Picka
no flags Details

  None (edit)
Description Petr Vobornik 2016-01-06 10:05:36 EST
This bug is created as a clone of upstream ticket:
https://fedorahosted.org/freeipa/ticket/5574

When DNSSEC master is installed on server, after uninstallation state
{{{
[ods-enforcerd]
kasp_db_configured = True
}}}
is still there, even if uninstaller tries to remove it with restore_state().

This is caused by mixed case of "KASP_DB_configured" that is used in code (see that this has been saved as lower case in statefile). When I changed this value to lower case in code, it worked.

Possible solutions:
1) fix sysrestore

2) change key "KASP_DB_configured" to lower case and allow to store only keys in lower case
Comment 3 Martin Kosek 2016-01-12 10:59:59 EST
Upgrade breakage - high prio/sev.
Comment 7 Pavel Picka 2016-08-16 06:11 EDT
Created attachment 1191191 [details]
evidence

Verified on 4.4.0-7.el7.x86_64
Comment 9 errata-xmlrpc 2016-11-04 01:48:04 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2404.html

Note You need to log in before you can comment on or make changes to this bug.