Bug 1298101 - Sysrestore did not restore state if a key is specified in mixed case
Sysrestore did not restore state if a key is specified in mixed case
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: ipa (Show other bugs)
7.3
All All
urgent Severity urgent
: rc
: ---
Assigned To: Pavel Picka
Namita Soman
: ZStream
Depends On: 1296196
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-13 04:02 EST by Jan Kurik
Modified: 2016-02-16 05:58 EST (History)
10 users (show)

See Also:
Fixed In Version: ipa-4.2.0-15.el7_2.4
Doc Type: Bug Fix
Doc Text:
Keys in the sysrestore file were normalized to lowercase values. Previously, the sysrestore utility did not expect that keys had been migrated to lowercase, and did not return the correct state. Consequently, this could cause rewriting of the kasp.db DNSSEC database. With this update, the sysrestore utility is now case-sensitive, the DNSSEC database is no longer accidentally rewritten, and all sysrestore operations work as expected.
Story Points: ---
Clone Of: 1296196
Environment:
Last Closed: 2016-02-16 05:58:56 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
log (3.39 KB, text/plain)
2016-01-29 10:46 EST, Pavel Picka
no flags Details

  None (edit)
Description Jan Kurik 2016-01-13 04:02:51 EST
This bug has been copied from bug #1296196 and has been proposed
to be backported to 7.2 z-stream (EUS).
Comment 5 Pavel Picka 2016-01-29 10:46 EST
Created attachment 1119458 [details]
log

VERIFIED

4.2.0-15.el7_2.5.x86_64
Comment 7 errata-xmlrpc 2016-02-16 05:58:56 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0211.html

Note You need to log in before you can comment on or make changes to this bug.