Bug 1296349 - SELinux is preventing cups-pk-helper- from 'add_name' accesses on the directory 568d93f8cd31c.
SELinux is preventing cups-pk-helper- from 'add_name' accesses on the directo...
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
rawhide
x86_64 Unspecified
high Severity high
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:982e0a42e993f8b4284ba7be02c...
:
: 1296346 1296348 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-06 18:45 EST by Joachim Frieben
Modified: 2016-02-03 08:43 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-03 08:43:34 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Joachim Frieben 2016-01-06 18:45:33 EST
Description of problem:
SELinux is preventing cups-pk-helper- from 'add_name' accesses on the directory 568d93f8cd31c.

*****  Plugin catchall (100. confidence) suggests   **************************

If you believe that cups-pk-helper- should be allowed add_name access on the 568d93f8cd31c directory by default.
Then you should report this as a bug.
You can generate a local policy module to allow this access.
Do
allow this access for now by executing:
# grep cups-pk-helper- /var/log/audit/audit.log | audit2allow -M mypol
# semodule -i mypol.pp

Additional Information:
Source Context                system_u:system_r:cupsd_config_t:s0-s0:c0.c1023
Target Context                system_u:object_r:tmpfs_t:s0
Target Objects                568d93f8cd31c [ dir ]
Source                        cups-pk-helper-
Source Path                   cups-pk-helper-
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           
Target RPM Packages           
Policy RPM                    selinux-policy-3.13.1-164.fc24.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Permissive
Host Name                     (removed)
Platform                      Linux (removed) 4.4.0-0.rc8.git0.1.fc24.x86_64 #1
                              SMP Mon Jan 4 17:13:26 UTC 2016 x86_64 x86_64
Alert Count                   2
First Seen                    2016-01-06 23:23:26 CET
Last Seen                     2016-01-06 23:23:52 CET
Local ID                      0e6a6102-5b54-417b-9f70-6967dd85a094

Raw Audit Messages
type=AVC msg=audit(1452119032.839:591): avc:  denied  { add_name } for  pid=2528 comm="cups-pk-helper-" name="568d93f8cd31c" scontext=system_u:system_r:cupsd_config_t:s0-s0:c0.c1023 tcontext=system_u:object_r:tmpfs_t:s0 tclass=dir permissive=1


Hash: cups-pk-helper-,cupsd_config_t,tmpfs_t,dir,add_name

Version-Release number of selected component:
selinux-policy-3.13.1-164.fc24.noarch

Additional info:
reporter:       libreport-2.6.3
hashmarkername: setroubleshoot
kernel:         4.4.0-0.rc8.git0.1.fc24.x86_64
type:           libreport
Comment 1 Daniel Walsh 2016-01-07 09:08:56 EST
*** Bug 1296348 has been marked as a duplicate of this bug. ***
Comment 2 Daniel Walsh 2016-01-07 09:09:03 EST
*** Bug 1296346 has been marked as a duplicate of this bug. ***
Comment 3 Daniel Walsh 2016-01-07 09:09:45 EST
Looks like cups_config_t needs to be able to create content in a tmpfs_t directory.
Comment 4 Lukas Vrabec 2016-01-12 10:46:59 EST
I would this is caused by bad labeling /tmp. 

See https://github.com/systemd/systemd/issues/2196
Comment 5 Miroslav Grepl 2016-01-21 06:35:11 EST
(In reply to Lukas Vrabec from comment #4)
> I would this is caused by bad labeling /tmp. 
> 
> See https://github.com/systemd/systemd/issues/2196

Yes.

restorecon -Rv /tmp

will fix labeling for /tmp directory to tmp_t.
Comment 6 Lukas Vrabec 2016-02-03 08:43:34 EST
Will be fixed in next systemd release: 
https://github.com/evverx/systemd/commit/373bf8c037125039fdfd8637544ce6242beede9c

Note You need to log in before you can comment on or make changes to this bug.