Bug 129638 - keyboard->kbd
Summary: keyboard->kbd
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11 (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Brian Stein
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
: 129666 (view as bug list)
Depends On:
Blocks: FC3Target
TreeView+ depends on / blocked
 
Reported: 2004-08-11 09:32 UTC by Brian Stein
Modified: 2013-03-01 05:14 UTC (History)
6 users (show)

Fixed In Version: 6.7.99.2-2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-08-12 12:29:37 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Arjan van de Ven 2004-08-11 09:32:03 UTC
Description of problem:


Version-Release number of selected component (if applicable):

(EE) *** ERROR the legacy keyboard driver "keyboard" is deprecated
(EE) *** and has not been compiled into this X server.  It will be removed
(EE) *** in the next release of the Xorg server.
(EE) *** Please consider using the the new "kbd" driver for "Keyboard0".

Comment 1 Kristian Høgsberg 2004-08-11 17:26:35 UTC
We will add something like this

  perl -p -i -e 's/Driver(.*)"keyboard"/Driver\1"kbd"/gi' $configfile 

to the %pre section in the rpm.  And we need to update the config tools.

Comment 2 Jeremy Katz 2004-08-11 17:31:35 UTC
*** Bug 129666 has been marked as a duplicate of this bug. ***

Comment 3 Jeremy Katz 2004-08-11 17:47:06 UTC
Is kbd in the the xorg-x11 release we shipped in FC2/present?  If so,
I can go ahead and update pyxf86config to write out the newer driver name.

Comment 4 Kristian Høgsberg 2004-08-11 18:02:18 UTC
Yes it was already in XFree 4.3, at least, so it's been available
since RHL9.  Thanks.


Comment 5 Jeremy Katz 2004-08-11 18:15:51 UTC
Okay, pyxf86config >= 0.3.19 will set to the new keyboard driver. 
Building that now.

Still need the conversion to happen, though.

Comment 6 Mike A. Harris 2004-08-12 12:29:37 UTC
Fixed in 6.7.99.2-2


Note You need to log in before you can comment on or make changes to this bug.